Издаване на FreeBSD 12.3

Представен е релиз FreeBSD 12.3, публикуван за архитектурите amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 и armv6, armv7 и aarch64. Допълнително са подготвени образи за виртуализационни системи (QCOW2, VHD, VMDK, raw) и облачни среди Amazon EC2. Релизът FreeBSD 13.1 се очаква през пролетта на 2022 година.

Ключови нововъведения:

  • Добавен е скрипт /etc/rc.final, който се стартира на последния етап на работа след приключването на всички потребителски процеси.
  • В пакета филтър ipfw е предоставена команда dnctl за управление на настройките на системата за ограничаване на трафика dummynet.
  • Добавен е sysctl kern.crypto за управление на криптосистемата на ядрото, както и отладъчен sysctl debug.uma_reclaim.
  • Добавен е sysctl net.inet.tcp.tolerate_missing_ts, който допуска TCP-пакети без времеви печати (опция timestamp, RFC 1323/RFC 7323).
  • В ядрото GENERIC за архитектурата amd64 е включена опция COMPAT_LINUXKPI и е активиран драйвер mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • В зареждача е добавена възможността за зареждане на операционната система от ram-диск, както и е реализирана поддръжка на ZFS опции com.delphix:bookmark_written и com.datto:bookmark_v2.
  • В библиотеката fetch е добавена поддръжка за проксириране на FTP върху HTTPS.
  • В пакетния мениджър pkg за командите „bootstrap“ и „add“ е реализиран флаг „-r“ за указване на репозитория. Осигурено е използването на променливи на средата от файла pkg.conf.
  • В утилитата growfs вече има възможност за работа с файлови системи, монтирани в режим на четене и запис.
  • В утилитата etcupdate е реализиран режим на възстановяване на изменения за възстановяване на един или няколко файла. Добавен е флаг „-D“ за указване на целевата директория. Осигурено е извличане на данни с помощта на времева директория и е добавена обработка на SIGINT.
  • В утилитите freebsd-update и freebsd-version е добавен флаг „-j“ за поддръжка на jail среди.
  • Утилитата cpuset сега може да се използва в jail среди за промяна на параметрите на дъщерни jail.
  • В утилитата cmp са добавени опции: „-b“ (—print-bytes) за извеждане на различаващите се байтове, „-i“ (—ignore-initial) за игнориране на определен брой начални байтове, „-n“ (—bytes) за ограничаване на броя сравнявани байтове.
  • В утилитата daemon е добавен флаг „-H“ за обработка на SIGHUP и преотваряне на файла, в който се извършва изход (добавен за поддръжка на newsyslog).
  • В утилитата fstyp при указване на флага „-l“ е осигурено определяне и показване на файловите системи exFAT.
  • В утилитата mergemaster е реализирано обработването на символични линкове по време на обновяване.
  • В утилитата newsyslog е добавен флаг 'E' за деактивиране на ротацията на празни логове.
  • В утилитата tcpdump се появи възможност за декодиране на пакети на интерфейсите pfsync.
  • В утилитата top е добавена командата-филтър ' / ' за показване само на процеси или аргументи, които съответстват на зададената строка.
  • В unzip е добавена поддръжка за архиви, защитени с парола.
  • Подобрена е поддръжката на хардуера. Добавени са идентификатори на PCI-устройства за AHCI контролери ASMedia ASM116x и I2C контролери Intel Gemini Lake. Реализирана е поддръжка за мрежови адаптери Mikrotik 10/25G и безжични карти Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Добавен е нов драйвер igc за ethernet контролери Intel I225 2.5G/1G/100MB/10MB.
  • Netgraph-узел ng_bridge е адаптиран за SMP системи. В узела ng_nat е добавена поддръжка за CGN (Carrier Grade NAT, RFC 6598). Предоставена е възможност за подмяна на узела ng_source в която и да е част от Netgraph мрежата.
  • В драйвера rctl, използван за лимитиране на ресурсите, е добавена възможност за задаване на ограничение на потреблението на ресурси на стойност 0.
  • В интерфейса vlan е добавена поддръжка на система за приоритизиране на трафика и управление на пропускателната способност ALTQ.
  • В драйверите amdtemp и amdsmn е реализирана поддръжка за CPU Zen 3 'Vermeer' и APU Ryzen 4000 (Zen 2, 'Renoir').
  • Актуализирани са версиите на включените в базовата система странични приложения: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Утилитата unzip е синхронизирана с кодовата база на NetBSD.

Източник: opennet.ru

Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри 🔥 Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри | ProHoster