ΠŸΠΎΡ‰Π°Ρ‚Π° Mail.ru Π·Π°ΠΏΠΎΡ‡Π²Π° Π² тСстов Ρ€Π΅ΠΆΠΈΠΌ Π΄Π° ΠΏΡ€ΠΈΠ»Π°Π³Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈ MTA-STS

ΠŸΠΎΡ‰Π°Ρ‚Π° Mail.ru Π·Π°ΠΏΠΎΡ‡Π²Π° Π² тСстов Ρ€Π΅ΠΆΠΈΠΌ Π΄Π° ΠΏΡ€ΠΈΠ»Π°Π³Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈ MTA-STS

Накратко, MTA-STS Π΅ Π½Π°Ρ‡ΠΈΠ½ Π·Π° Π΄ΠΎΠΏΡŠΠ»Π½ΠΈΡ‚Π΅Π»Π½Π° Π·Π°Ρ‰ΠΈΡ‚Π° Π½Π° ΠΈΠΌΠ΅ΠΉΠ»ΠΈΡ‚Π΅ ΠΎΡ‚ ΠΏΠ΅Ρ€Π΅Ρ…Π²Π°Ρ‚ (Ρ‚.Π΅. Π°Ρ‚Π°ΠΊΠΈ Π½Π° Π·Π»ΠΎΠ½Π°ΠΌΠ΅Ρ€Π΅Π½ΠΈ Π»ΠΈΡ†Π° Π² срСдата aka MitM) ΠΏΡ€ΠΈ ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅ ΠΌΠ΅ΠΆΠ΄Ρƒ ΠΈΠΌΠ΅ΠΉΠ» ΡΡŠΡ€Π²ΡŠΡ€ΠΈ. Π’ΠΎΠΉ частично Ρ€Π΅ΡˆΠ°Π²Π° наслСдСнитС Π°Ρ€Ρ…ΠΈΡ‚Π΅ΠΊΡ‚ΡƒΡ€Π½ΠΈ ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ Π½Π° ΠΈΠΌΠ΅ΠΉΠ» ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅ ΠΈ Π΅ описан Π² относитСлно новия стандарт RFC 8461. Mail.ru Π΅ ΠΏΡŠΡ€Π²Π°Ρ‚Π° голяма ΠΈΠΌΠ΅ΠΉΠ» услуга Π² Π ΡƒΠ½Π΅Ρ‚Π°, която Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π° Ρ‚ΠΎΠ·ΠΈ стандарт. А ΠΏΠΎ-ΠΏΠΎΠ΄Ρ€ΠΎΠ±Π½ΠΎ Ρ‰Π΅ бъдС Ρ€Π°Π·ΠΊΠ°Π·Π°Π½ΠΎ ΠΏΠΎ-Π΄ΠΎΠ»Ρƒ.

Какъв ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌ Ρ€Π΅ΡˆΠ°Π²Π° MTA-STS?

Π˜ΡΡ‚ΠΎΡ€ΠΈΡ‡Π΅ΡΠΊΠΈ, ΠΈΠΌΠ΅ΠΉΠ» ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅ (SMTP, POP3, IMAP) ΠΏΡ€Π΅Π΄Π°Π²Π°Ρ…Π° информация Π² ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ Π²ΠΈΠ΄, ΠΊΠΎΠ΅Ρ‚ΠΎ позволява Π½Π° злоупотрСбяващитС Π΄Π° я ΠΏΡ€ΠΈΡ…Π²Π°Ρ‰Π°Ρ‚, Π½Π°ΠΏΡ€ΠΈΠΌΠ΅Ρ€ ΠΏΡ€ΠΈ Π΄ΠΎΡΡ‚ΡŠΠΏ Π΄ΠΎ комуникационния ΠΊΠ°Π½Π°Π».

Как ΠΈΠ·Π³Π»Π΅ΠΆΠ΄Π° ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΡŠΡ‚ Π½Π° доставка Π½Π° писмо ΠΎΡ‚ Π΅Π΄ΠΈΠ½ ΠΏΠΎΡ‚Ρ€Π΅Π±ΠΈΡ‚Π΅Π» Π½Π° Π΄Ρ€ΡƒΠ³:

ΠŸΠΎΡ‰Π°Ρ‚Π° Mail.ru Π·Π°ΠΏΠΎΡ‡Π²Π° Π² тСстов Ρ€Π΅ΠΆΠΈΠΌ Π΄Π° ΠΏΡ€ΠΈΠ»Π°Π³Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈ MTA-STS

Π˜ΡΡ‚ΠΎΡ€ΠΈΡ‡Π΅ΡΠΊΠΈ, Π°Ρ‚Π°ΠΊΠ° MitM бСшС възмоТна Π½Π° всяко място, ΠΊΡŠΠ΄Π΅Ρ‚ΠΎ ΠΏΡ€Π΅ΠΌΠΈΠ½Π°Π²Π° ΠΈΠΌΠ΅ΠΉΠ».

Π‘Ρ‚Π°Π½Π΄Π°Ρ€Ρ‚ΡŠΡ‚ RFC 8314 изисква Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π½ΠΎ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° TLS ΠΌΠ΅ΠΆΠ΄Ρƒ ΠΈΠΌΠ΅ΠΉΠ» ΠΊΠ»ΠΈΠ΅Π½Ρ‚Π° Π½Π° потрСбитСля (MUA) ΠΈ ΠΈΠΌΠ΅ΠΉΠ» ΡΡŠΡ€Π²ΡŠΡ€Π°. Ако Π²Π°ΡˆΠΈΡΡ‚ ΡΡŠΡ€Π²ΡŠΡ€ ΠΈ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈΡ‚Π΅ ΠΈΠΌΠ΅ΠΉΠ» прилоТСния отговарят Π½Π° RFC 8314, Π²ΠΈΠ΅ (Π² Π·Π½Π°Ρ‡ΠΈΡ‚Π΅Π»Π½Π° стСпСн) стС Π΅Π»ΠΈΠΌΠΈΠ½ΠΈΡ€Π°Π»ΠΈ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° Man-in-the-Middle Π°Ρ‚Π°ΠΊΠΈ ΠΌΠ΅ΠΆΠ΄Ρƒ потрСбитСля ΠΈ ΠΈΠΌΠ΅ΠΉΠ» ΡΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅.

Π‘ΠΏΠ°Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΎΠ±Ρ‰ΠΎΠΏΡ€ΠΈΠ΅Ρ‚ΠΈΡ‚Π΅ ΠΏΡ€Π°ΠΊΡ‚ΠΈΠΊΠΈ (стандартизирани RFC 8314) Π΅Π»ΠΈΠΌΠΈΠ½ΠΈΡ€Π° Π°Ρ‚Π°ΠΊΠ°Ρ‚Π° Π² близост Π΄ΠΎ потрСбитСля:

ΠŸΠΎΡ‰Π°Ρ‚Π° Mail.ru Π·Π°ΠΏΠΎΡ‡Π²Π° Π² тСстов Ρ€Π΅ΠΆΠΈΠΌ Π΄Π° ΠΏΡ€ΠΈΠ»Π°Π³Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈ MTA-STS

ИмСйл ΡΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅ Π½Π° Mail.ru отговаряха Π½Π° RFC 8314 ΠΎΡ‰Π΅ ΠΏΡ€Π΅Π΄ΠΈ ΠΏΡ€ΠΈΠ΅ΠΌΠ°Π½Π΅Ρ‚ΠΎ Π½Π° стандарта, Π²ΡΡŠΡ‰Π½ΠΎΡΡ‚, Ρ‚ΠΎΠΉ просто фиксира Π²Π΅Ρ‡Π΅ ΠΏΡ€ΠΈΠ΅Ρ‚ΠΈΡ‚Π΅ ΠΏΡ€Π°ΠΊΡ‚ΠΈΠΊΠΈ, ΠΈ Π½Π΅ бСшС Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌΠΎ Π΄Π° настранявамС Π΄ΠΎΠΏΡŠΠ»Π½ΠΈΡ‚Π΅Π»Π½ΠΎ. Но Π°ΠΊΠΎ Π²Π°ΡˆΠΈΡΡ‚ ΠΈΠΌΠ΅ΠΉΠ» ΡΡŠΡ€Π²ΡŠΡ€ всС ΠΎΡ‰Π΅ допуска ΠΏΠΎΡ‚Ρ€Π΅Π±ΠΈΡ‚Π΅Π»ΠΈ Ρ‡Ρ€Π΅Π· нСбСзопасни ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈ, Π΅ Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π½ΠΎ Π΄Π° Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Ρ‚Π΅ ΠΏΡ€Π΅ΠΏΠΎΡ€ΡŠΠΊΠΈΡ‚Π΅ Π½Π° Ρ‚ΠΎΠ·ΠΈ стандарт, Ρ‚ΡŠΠΉ ΠΊΠ°Ρ‚ΠΎ Π΅ ΠΌΠ½ΠΎΠ³ΠΎ вСроятно ΠΏΠΎΠ½Π΅ част ΠΎΡ‚ Π²Π°ΡˆΠΈΡ‚Π΅ ΠΏΠΎΡ‚Ρ€Π΅Π±ΠΈΡ‚Π΅Π»ΠΈ Π΄Π° работят с ΠΈΠΌΠ΅ΠΉΠ»Π° Π±Π΅Π· ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅, Π΄ΠΎΡ€ΠΈ ΠΈ Π΄Π° Π³ΠΎ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‚Π΅.

ΠŸΠΎΡ‡Ρ‚ΠΎΠ²ΠΈΡΡ‚ ΠΊΠ»ΠΈΠ΅Π½Ρ‚ Π²ΠΈΠ½Π°Π³ΠΈ Ρ€Π°Π±ΠΎΡ‚ΠΈ с Π΅Π΄ΠΈΠ½ ΠΈ ΡΡŠΡ‰ пощСнски ΡΡŠΡ€Π²ΡŠΡ€ Π½Π° ΡΡŠΡ‰Π°Ρ‚Π° организация. МоТС ΠΏΡ€ΠΈΠ½ΡƒΠ΄ΠΈΡ‚Π΅Π»Π½ΠΎ Π΄Π° Π½Π°ΠΊΠ°Ρ€Π°Ρ‚Π΅ всички ΠΏΠΎΡ‚Ρ€Π΅Π±ΠΈΡ‚Π΅Π»ΠΈ Π΄Π° сС ΡΠ²ΡŠΡ€Π·Π²Π°Ρ‚ ΠΏΠΎ бСзопасСн Π½Π°Ρ‡ΠΈΠ½, слСд ΠΊΠΎΠ΅Ρ‚ΠΎ Π΄Π° Π½Π°ΠΏΡ€Π°Π²ΠΈΡ‚Π΅ тСхничСски нСвъзмоТно ΡΠ²ΡŠΡ€Π·Π²Π°Π½Π΅Ρ‚ΠΎ ΠΏΠΎ Π½Π΅Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ (Ρ‚ΠΎΠ²Π° Ρ‚ΠΎΡ‡Π½ΠΎ изисква RFC 8314). Понякога Π΅ слоТно, Π½ΠΎ ΠΎΡΡŠΡ‰Π΅ΡΡ‚Π²ΠΈΠΌΠΎ. Π‘ Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° ΠΌΠ΅ΠΆΠ΄Ρƒ пощСнскитС ΡΡŠΡ€Π²ΡŠΡ€ΠΈ Π΅ всС ΠΏΠΎ-Ρ‚Ρ€ΡƒΠ΄Π½ΠΎ. Π‘ΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅ ΠΏΡ€ΠΈΠ½Π°Π΄Π»Π΅ΠΆΠ°Ρ‚ Π½Π° Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ ΠΎΡ€Π³Π°Π½ΠΈΠ·Π°Ρ†ΠΈΠΈ ΠΈ чСсто сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Ρ‚ Π² Ρ€Π΅ΠΆΠΈΠΌ β€žΠΏΠΎΡΡ‚Π°Π²ΠΈ ΠΈ Π·Π°Π±Ρ€Π°Π²ΠΈβ€œ, ΠΊΠΎΠ΅Ρ‚ΠΎ ΠΏΡ€Π°Π²ΠΈ нСвъзмоТно Π΅Π΄Π½ΠΎΠ²Ρ€Π΅ΠΌΠ΅Π½Π½ΠΎΡ‚ΠΎ ΠΏΡ€Π΅ΠΌΠΈΠ½Π°Π²Π°Π½Π΅ Π½Π° бСзопасСн ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ» Π±Π΅Π· Π½Π°Ρ€ΡƒΡˆΠ΅Π½ΠΈΠ΅ Π½Π° ΡΠ²ΡŠΡ€Π·Π°Π½ΠΎΡΡ‚Ρ‚Π°. Π’ SMTP ΠΎΡ‚ доста Π²Ρ€Π΅ΠΌΠ΅ Π΅ ΠΏΡ€Π΅Π΄Π²ΠΈΠ΄Π΅Π½ΠΎ Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΠ΅ STARTTLS, позволяващо Π½Π° ΡΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅, ΠΊΠΎΠΈΡ‚ΠΎ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‚ ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅, Π΄Π° ΠΏΡ€Π΅ΠΌΠΈΠ½Π°Ρ‚ Π½Π° TLS. Но Π½Π°ΠΏΠ°Π΄Π°Ρ‚Π΅Π», ΠΊΠΎΠΉΡ‚ΠΎ ΠΈΠΌΠ° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π΄Π° влияС Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ°, ΠΌΠΎΠΆΠ΅ Π΄Π° β€žΠΈΠ·Ρ€Π΅ΠΆΠ΅β€œ информацията Π·Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° Ρ‚Π°Π·ΠΈ ΠΊΠΎΠΌΠ°Π½Π΄Π° ΠΈ Π΄Π° Π½Π°ΠΊΠ°Ρ€Π° ΡΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅ Π΄Π° ΠΊΠΎΠΌΡƒΠ½ΠΈΠΊΠΈΡ€Π°Ρ‚ Ρ‡Ρ€Π΅Π· ΠΎΠ±ΠΈΠΊΠ½ΠΎΠ²Π΅Π½ тСкстови ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ» (Ρ‚.Π½. Π°Ρ‚Π°ΠΊΠ° ΠΏΠΎ ΠΏΠΎΠ½ΠΈΠΆΠ°Π²Π°Π½Π΅ Π½Π° вСрсията Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π°). По ΡΡŠΡ‰Π°Ρ‚Π° ΠΏΡ€ΠΈΡ‡ΠΈΠ½Π°, Π·Π° STARTTLS ΠΎΠ±ΠΈΠΊΠ½ΠΎΠ²Π΅Π½ΠΎ Π½Π΅ сС провСрява валидността Π½Π° сСртификата (Π½Π΅Π΄ΠΎΠ²Π΅Ρ€Π΅Π½ сСртификат ΠΌΠΎΠΆΠ΅ Π΄Π° Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π° ΠΎΡ‚ пасивни Π°Ρ‚Π°ΠΊΠΈ ΠΈ Ρ‚ΠΎΠ²Π° Π½Π΅ Π΅ ΠΏΠΎ-лошо ΠΎΡ‚ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΈΠΌΠ΅ΠΉΠ» Π² ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ тСкст). Π‘Π»Π΅Π΄ΠΎΠ²Π°Ρ‚Π΅Π»Π½ΠΎ, STARTTLS Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π° само ΠΎΡ‚ пасивно ΠΏΠΎΠ΄ΡΠ»ΡƒΡˆΠ²Π°Π½Π΅.

MTA-STS частично Ρ€Π΅ΡˆΠ°Π²Π° ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠ° с ΠΏΠ΅Ρ€Π΅Ρ…Π²Π°Ρ‰Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΈΠΌΠ΅ΠΉΠ»ΠΈ ΠΌΠ΅ΠΆΠ΄Ρƒ пощСнскитС ΡΡŠΡ€Π²ΡŠΡ€ΠΈ, ΠΊΠΎΠ³Π°Ρ‚ΠΎ нападатСлят ΠΈΠΌΠ° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π°ΠΊΡ‚ΠΈΠ²Π½ΠΎ Π΄Π° влияС Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ°. Ако Π΄ΠΎΠΌΠ΅ΠΉΠ½ΡŠΡ‚ Π½Π° получатСля ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° MTA-STS ΠΈ ΡΡŠΡ€Π²ΡŠΡ€ΡŠΡ‚ Π½Π° податСля ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° MTA-STS, Ρ‚ΠΎΠΉ Ρ‰Π΅ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π° ΠΈΠΌΠ΅ΠΉΠ»Π° само Ρ‡Ρ€Π΅Π· TLS-съСдинСниС, само Π½Π° ΡΡŠΡ€Π²ΡŠΡ€ΠΈΡ‚Π΅, ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ΠΈ Π² ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°, ΠΈ само с ΠΏΡ€ΠΎΠ²Π΅Ρ€ΠΊΠ° Π½Π° сСртификата Π½Π° ΡΡŠΡ€Π²ΡŠΡ€Π°.

Π—Π°Ρ‰ΠΎ частично? MTA-STS Ρ€Π°Π±ΠΎΡ‚ΠΈ само Π°ΠΊΠΎ Π΄Π²Π΅Ρ‚Π΅ страни са сС ΠΏΠΎΠ³Ρ€ΠΈΠΆΠΈΠ»ΠΈ Π΄Π° внСдрят Ρ‚ΠΎΠ·ΠΈ стандарт ΠΈ MTA-STS Π½Π΅ Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π° ΠΏΡ€ΠΈ сцСнарии, ΠΏΡ€ΠΈ ΠΊΠΎΠΈΡ‚ΠΎ нападатСлят ΠΈΠΌΠ° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π΄Π° ΠΏΠΎΠ»ΡƒΡ‡ΠΈ Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат Π·Π° Π΄ΠΎΠΌΠ΅ΠΉΠ½ ΠΎΡ‚ Π΅Π΄ΠΈΠ½ ΠΎΡ‚ ΠΏΡƒΠ±Π»ΠΈΡ‡Π½ΠΈΡ‚Π΅ CA.

Как Ρ€Π°Π±ΠΎΡ‚ΠΈ MTA-STS

ΠŸΠΎΠ»ΡƒΡ‡Π°Ρ‚Π΅Π»ΡΡ‚

  1. Настройва ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° STARTTLS с Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат Π½Π° пощСнския ΡΡŠΡ€Π²ΡŠΡ€.Β 
  2. ΠŸΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° Ρ‡Ρ€Π΅Π· HTTPS ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° MTA-STS, Π·Π° публикацията сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° спСциалСн Π΄ΠΎΠΌΠ΅ΠΉΠ½ mta-sts ΠΈ спСциалСн well-known ΠΏΡŠΡ‚, Π½Π°ΠΏΡ€ΠΈΠΌΠ΅Ρ€ https://mta-sts.mail.ru/.well-known/mta-sts.txt. ΠŸΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° ΡΡŠΠ΄ΡŠΡ€ΠΆΠ° списък Π½Π° пощСнскитС ΡΡŠΡ€Π²ΡŠΡ€ΠΈ (mx), ΠΊΠΎΠΈΡ‚ΠΎ ΠΈΠΌΠ°Ρ‚ ΠΏΡ€Π°Π²ΠΎ Π΄Π° ΠΏΠΎΠ»ΡƒΡ‡Π°Π²Π°Ρ‚ ΠΏΠΎΡ‰Π° Π·Π° Ρ‚ΠΎΠ·ΠΈ Π΄ΠΎΠΌΠ΅ΠΉΠ½.
  3. ΠŸΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° спСциална TXT-запис _mta-sts Π² DNS с вСрсия Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°. ΠŸΡ€ΠΈ промяна Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°, Ρ‚Π°Π·ΠΈ запис трябва Π΄Π° бъдС ΠΎΠ±Π½ΠΎΠ²Π΅Π½Π° (Ρ‚ΠΎΠ²Π° сигнализира Π½Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡Π°, Ρ‡Π΅ Π΅ Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌΠΎ Π΄Π° поиска ΠΎΡ‚Π½ΠΎΠ²ΠΎ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°). НапримСр, _mta-sts.mail.ru. TXT "v=STSv1; id=20200303T120000;"

Π˜Π·ΠΏΡ€Π°Ρ‰Π°Ρ‡

Π˜Π·ΠΏΡ€Π°Ρ‰Π°Ρ‡ΡŠΡ‚ иска DNS-запис _mta-sts, ΠΏΡ€ΠΈ наличност ΠΏΡ€Π°Π²ΠΈ Π·Π°ΠΏΠΈΡ‚Π²Π°Π½Π΅ Π·Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° ΠΏΠΎ HTTPS (свСрявайки сСртификата). ΠŸΠΎΠ»ΡƒΡ‡Π΅Π½Π°Ρ‚Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° сС ΠΊΠ΅ΡˆΠΈΡ€Π° (Π² случай, Ρ‡Π΅ атакуващият Π±Π»ΠΎΠΊΠΈΡ€Π° Π΄ΠΎΡΡ‚ΡŠΠΏΠ° Π΄ΠΎ нСя ΠΈΠ»ΠΈ подмСня DNS-записа).

ΠŸΡ€ΠΈ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅ Π½Π° ΠΏΠΎΡ‰Π° сС провСрява Π΄Π°Π»ΠΈ:

  • ΡΡŠΡ€Π²ΡŠΡ€ΡŠΡ‚, Π½Π° ΠΊΠΎΠΉΡ‚ΠΎ сС доставя ΠΏΠΎΡ‰Π°Ρ‚Π°, Π΅ Π² ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°;
  • ΡΡŠΡ€Π²ΡŠΡ€ΡŠΡ‚ ΠΏΡ€ΠΈΠ΅ΠΌΠ° ΠΏΠΎΡ‰Π° с ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° TLS (STARTTLS) ΠΈ ΠΈΠΌΠ° Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат.

ΠŸΡ€Π΅Π΄ΠΈΠΌΡΡ‚Π²Π° Π½Π° MTA-STS

MTA-STS ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° Ρ‚Π΅Ρ…Π½ΠΎΠ»ΠΎΠ³ΠΈΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ Π²Π΅Ρ‡Π΅ са Π²Π½Π΅Π΄Ρ€Π΅Π½ΠΈ Π² ΠΏΠΎΠ²Π΅Ρ‡Π΅Ρ‚ΠΎ ΠΎΡ€Π³Π°Π½ΠΈΠ·Π°Ρ†ΠΈΠΈ (SMTP+STARTTLS, HTTPS, DNS). Π—Π° Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π΅ ΠΎΡ‚ страна Π½Π° получатСля Π½Π΅ сС изисква спСциална софтуСрна ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° стандарта.

ΠΠ΅Π΄ΠΎΡΡ‚Π°Ρ‚ΡŠΡ†ΠΈ Π½Π° MTA-STS

НСобходимо Π΅ Π΄Π° сС слСди валидността Π½Π° сСртификата Π½Π° ΡƒΠ΅Π± ΠΈ пощСнския ΡΡŠΡ€Π²ΡŠΡ€, приспособлСниСто Π½Π° ΠΈΠΌΠ΅Π½Π°Ρ‚Π° ΠΈ Π½Π°Π²Ρ€Π΅ΠΌΠ΅Π½Π½ΠΈΡ‚Π΅ обновлСния. ΠŸΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ с сСртификата Ρ‰Π΅ Π΄ΠΎΠ²Π΅Π΄Π°Ρ‚ Π΄ΠΎ Π½Π΅Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° доставянС Π½Π° ΠΏΠΎΡ‰Π°Ρ‚Π°.

ΠžΡ‚ страна Π½Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡Π° Π΅ Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌ MTA с ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈ MTA-STS, Π² ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° "извън кутия" MTA-STS Π½Π΅ сС ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° Π² MTA.

MTA-STS ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° списък с Π΄ΠΎΠ²Π΅Ρ€Π΅Π½ΠΈ ΠΊΠΎΡ€Π΅Π½ΠΎΠ²ΠΈ CA.

MTA-STS Π½Π΅ Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π° ΠΎΡ‚ Π°Ρ‚Π°ΠΊΠΈ, ΠΏΡ€ΠΈ ΠΊΠΎΠΈΡ‚ΠΎ атакуващият ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат. Π’ ΠΏΠΎΠ²Π΅Ρ‡Π΅Ρ‚ΠΎ случаи, MitM Π±Π»ΠΈΠ·ΠΎ Π΄ΠΎ ΡΡŠΡ€Π²ΡŠΡ€Π° ΠΏΡ€Π΅Π΄ΠΏΠΎΠ»Π°Π³Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΈΠ·Π΄Π°Π²Π°Π½Π΅ Π½Π° сСртификат. Подобна Π°Ρ‚Π°ΠΊΠ° ΠΌΠΎΠΆΠ΅ Π΄Π° бъдС ΠΎΡ‚ΠΊΡ€ΠΈΡ‚Π° Ρ‡Ρ€Π΅Π· Certificate Transparency. Π‘Π»Π΅Π΄ΠΎΠ²Π°Ρ‚Π΅Π»Π½ΠΎ, Π² ΠΎΠ±Ρ‰ΠΈ Π»ΠΈΠ½ΠΈΠΈ, MTA-STS ΠΌΠΈΠ½ΠΈΠΌΠΈΠ·ΠΈΡ€Π°, Π½ΠΎ Π½Π΅ Π΅Π»ΠΈΠΌΠΈΠ½ΠΈΡ€Π° напълно Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΏΡ€ΠΈΡ…Π²Π°Ρ‰Π°Π½Π΅ Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊ.

Π”Π²Π°Ρ‚Π° послСдни ΠΏΡƒΠ½ΠΊΡ‚Π° правят MTA-STS ΠΏΠΎ-ΠΌΠ°Π»ΠΊΠΎ Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ Π² сравнСниС с конкурСнтния стандарт DANE Π·Π° SMTP (RFC 7672), Π½ΠΎ тСхничСски ΠΏΠΎ-Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½, Ρ‚.Π΅. Π·Π° MTA-STS Π΅ ΠΌΠ°Π»ΠΊΠΎ вСроятно писмото Π΄Π° Π½Π΅ бъдС доставСно ΠΏΠΎΡ€Π°Π΄ΠΈ тСхничСски ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ, ΠΏΡ€ΠΈΡ‡ΠΈΠ½Π΅Π½ΠΈ ΠΎΡ‚ внСдряванСто Π½Π° стандарта.

ΠšΠΎΠ½ΠΊΡƒΡ€ΠΈΡ€Π°Ρ‰ стандарт β€” DANE

DANE ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° DNSSEC Π·Π° ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Π½Π΅ Π½Π° информация Π·Π° сСртификати ΠΈ Π½Π΅ изисква Π΄ΠΎΠ²Π΅Ρ€ΠΈΠ΅ към външни удостовСряващи Ρ†Π΅Π½Ρ‚Ρ€ΠΎΠ²Π΅, ΠΊΠΎΠ΅Ρ‚ΠΎ Π΅ Π·Π½Π°Ρ‡ΠΈΡ‚Π΅Π»Π½ΠΎ ΠΏΠΎ-сигурно. Но ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° DNSSEC Π·Π½Π°Ρ‡ΠΈΡ‚Π΅Π»Π½ΠΎ ΠΏΠΎ-чСсто Π²ΠΎΠ΄ΠΈ Π΄ΠΎ тСхничСски ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ, Π°ΠΊΠΎ сС основавамС Π½Π° статистиката ΠΎΡ‚ няколко Π³ΠΎΠ΄ΠΈΠ½ΠΈ ΡƒΠΏΠΎΡ‚Ρ€Π΅Π±Π° (Π²ΡŠΠΏΡ€Π΅ΠΊΠΈ ΠΏΠΎΠ»ΠΎΠΆΠΈΡ‚Π΅Π»Π½Π°Ρ‚Π° Π΄ΠΈΠ½Π°ΠΌΠΈΠΊΠ° Π² надСТдността Π½Π° DNSSEC ΠΈ Π½Π΅Π³ΠΎΠ²Π°Ρ‚Π° тСхничСска ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° ΠΊΠ°Ρ‚ΠΎ цяло). Π—Π° внСдряванС Π½Π° DANE Π² SMTP ΠΎΡ‚ страна Π½Π° получатСля, Π½Π°Π»ΠΈΡ‡ΠΈΠ΅Ρ‚ΠΎ Π½Π° DNSSEC Π·Π° DNS-Π·ΠΎΠ½Π°Ρ‚Π° Π΅ Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π½ΠΎ, ΠΊΠ°Ρ‚ΠΎ Π΅ особСно Π²Π°ΠΆΠ½ΠΎ ΠΏΡ€Π°Π²ΠΈΠ»Π½ΠΎΡ‚ΠΎ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Π½Π΅ Π½Π° NSEC/NSEC3, с ΠΊΠΎΠ΅Ρ‚ΠΎ ΠΈΠΌΠ° систСмни ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ Π² DNSSEC.

Ако DNSSEC Π΅ ΠΊΠΎΠ½Ρ„ΠΈΠ³ΡƒΡ€ΠΈΡ€Π°Π½ с Π³Ρ€Π΅ΡˆΠΊΠΈ, Ρ‚ΠΎΠ²Π° ΠΌΠΎΠΆΠ΅ Π΄Π° Π΄ΠΎΠ²Π΅Π΄Π΅ Π΄ΠΎ ΠΎΡ‚ΠΊΠ°Π·ΠΈ ΠΏΡ€ΠΈ доставката Π½Π° ΠΈΠΌΠ΅ΠΉΠ»ΠΈ, Π°ΠΊΠΎ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‰Π°Ρ‚Π° страна ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° DANE, Π΄ΠΎΡ€ΠΈ Π°ΠΊΠΎ ΠΏΠΎΠ»ΡƒΡ‡Π°Π²Π°Ρ‰Π°Ρ‚Π° страна Π½ΠΈΡ‰ΠΎ Π½Π΅ Π·Π½Π°Π΅ Π·Π° Π½Π΅Π³ΠΎ. Π—Π°Ρ‚ΠΎΠ²Π°, Π²ΡŠΠΏΡ€Π΅ΠΊΠΈ Ρ‡Π΅ DANE Π΅ ΠΏΠΎ-стар ΠΈ Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ стандарт ΠΈ Π²Π΅Ρ‡Π΅ Π΅ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Π½ Π² някои ΡΡŠΡ€Π²ΡŠΡ€Π½ΠΈ софтуСрни прилоТСния ΠΎΡ‚ страна Π½Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡Π°, фактичСски внСдряванСто ΠΌΡƒ остава Π½Π΅Π·Π½Π°Ρ‡ΠΈΡ‚Π΅Π»Π½ΠΎ, ΠΌΠ½ΠΎΠ³ΠΎ ΠΎΡ€Π³Π°Π½ΠΈΠ·Π°Ρ†ΠΈΠΈ Π½Π΅ са Π³ΠΎΡ‚ΠΎΠ²ΠΈ Π΄Π° Π³ΠΎ внСдрят ΠΏΠΎΡ€Π°Π΄ΠΈ нСобходимостта ΠΎΡ‚ настройка Π½Π° DNSSEC, ΠΊΠΎΠ΅Ρ‚ΠΎ Π·Π½Π°Ρ‡ΠΈΡ‚Π΅Π»Π½ΠΎ забавя внСдряванСто Π½Π° DANE ΠΏΡ€Π΅Π· всички Π³ΠΎΠ΄ΠΈΠ½ΠΈ, Π² ΠΊΠΎΠΈΡ‚ΠΎ ΡΡ‚Π°Π½Π΄Π°Ρ€Ρ‚ΡŠΡ‚ ΡΡŠΡ‰Π΅ΡΡ‚Π²ΡƒΠ²Π°.

DANE ΠΈ MTA-STS Π½Π΅ си ΠΏΡ€ΠΎΡ‚ΠΈΠ²ΠΎΡ€Π΅Ρ‡Π°Ρ‚ ΠΈ ΠΌΠΎΠ³Π°Ρ‚ Π΄Π° Π±ΡŠΠ΄Π°Ρ‚ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈ Π·Π°Π΅Π΄Π½ΠΎ.

Каква Π΅ ΠΏΠΎΠ΄ΠΊΡ€Π΅ΠΏΠ°Ρ‚Π° Π·Π° MTA-STS Π² ΠΏΠΎΡ‰Π°Ρ‚Π° Mail.ru

Mail.ru ΠΎΡ‚Π΄Π°Π²Π½Π° ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° MTA-STS Π·Π° всички основни Π΄ΠΎΠΌΠ΅ΠΉΠ½ΠΈ. Π’ ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° Ρ€Π°Π±ΠΎΡ‚ΠΈΠΌ ΠΏΠΎ внСдряванС Π½Π° клиСнтската част ΠΎΡ‚ стандарта. Към ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° Π½Π° написванС Π½Π° статията, ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈΡ‚Π΅ сС ΠΏΡ€ΠΈΠ»Π°Π³Π°Ρ‚ Π² Π½Π΅Π±Π»ΠΎΠΊΠΈΡ€Π°Ρ‰ Ρ€Π΅ΠΆΠΈΠΌ (Π² случай, Ρ‡Π΅ доставката Π΅ Π±Π»ΠΎΠΊΠΈΡ€Π°Π½Π° ΠΎΡ‚ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°, писмото Ρ‰Π΅ бъдС доставСно Ρ‡Ρ€Π΅Π· β€žΡ€Π΅Π·Π΅Ρ€Π²Π΅Π½β€œ ΡΡŠΡ€Π²ΡŠΡ€ Π±Π΅Π· ΠΏΡ€ΠΈΠ»Π°Π³Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈΡ‚Π΅), слСд Ρ‚ΠΎΠ²Π° Ρ‰Π΅ бъдС Π½Π°Π»ΠΎΠΆΠ΅Π½ Π±Π»ΠΎΠΊΠΈΡ€Π°Ρ‰ Ρ€Π΅ΠΆΠΈΠΌ Π·Π° ΠΌΠ°Π»ΠΊΠ° част ΠΎΡ‚ изходящия SMTP Ρ‚Ρ€Π°Ρ„ΠΈΠΊ, постСпСнно 100% ΠΎΡ‚ Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° Ρ‰Π΅ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° ΠΏΡ€ΠΈΠ»Π°Π³Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈΡ‚Π΅.

Кои ΠΎΡ‰Π΅ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‚ стандарта

Към ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈΡ‚Π΅ MTA-STS ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Ρ‚ ΠΎΠΊΠΎΠ»ΠΎ 0.05% ΠΎΡ‚ Π°ΠΊΡ‚ΠΈΠ²Π½ΠΈΡ‚Π΅ Π΄ΠΎΠΌΠ΅ΠΉΠ½ΠΈ, Π½ΠΎ всС ΠΏΠ°ΠΊ Ρ‚Π΅ Π²Π΅Ρ‡Π΅ Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π°Ρ‚ голям ΠΎΠ±Π΅ΠΌ ΠΎΡ‚ пощСнския Ρ‚Ρ€Π°Ρ„ΠΈΠΊ, Ρ‚ΡŠΠΉ ΠΊΠ°Ρ‚ΠΎ ΡΡ‚Π°Π½Π΄Π°Ρ€Ρ‚ΡŠΡ‚ сС ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° ΠΎΡ‚ Π³ΠΎΠ»Π΅ΠΌΠΈ ΠΈΠ³Ρ€Π°Ρ‡ΠΈ β€” Google, Comcast ΠΈ частично Verizon (AOL, Yahoo). Много Π΄Ρ€ΡƒΠ³ΠΈ пощСнски услуги обявиха, Ρ‡Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° стандарта Ρ‰Π΅ бъдС Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π² Π±Π»ΠΈΠ·ΠΊΠΎ Π±ΡŠΠ΄Π΅Ρ‰Π΅.

Как Ρ‚ΠΎΠ²Π° Ρ‰Π΅ ΠΌΠ΅ засСгнС?

Никак, Π°ΠΊΠΎ Π²Π°ΡˆΠΈΡΡ‚ Π΄ΠΎΠΌΠ΅ΠΉΠ½ Π½Π΅ ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° MTA-STS. Ако ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Ρ‚Π΅ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°, Ρ‚ΠΎ ΠΈΠΌΠ΅ΠΉΠ»ΠΈΡ‚Π΅ Π·Π° ΠΏΠΎΡ‚Ρ€Π΅Π±ΠΈΡ‚Π΅Π»ΠΈΡ‚Π΅ Π½Π° вашия пощСнски ΡΡŠΡ€Π²ΡŠΡ€ Ρ‰Π΅ Π±ΡŠΠ΄Π°Ρ‚ ΠΏΠΎ-Π΄ΠΎΠ±Ρ€Π΅ Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ΠΈ ΠΎΡ‚ ΠΏΡ€ΠΈΡ…Π²Π°Ρ‰Π°Π½Π΅.

Как Π΄Π° внСдря MTA-STS?

ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° MTA-STS ΠΎΡ‚ страна Π½Π° получатСля

Π”ΠΎΡΡ‚Π°Ρ‚ΡŠΡ‡Π½ΠΎ Π΅ Π΄Π° ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Ρ‚Π΅ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° Ρ‡Ρ€Π΅Π· HTTPS ΠΈ DNS записи, Π΄Π° ΠΊΠΎΠ½Ρ„ΠΈΠ³ΡƒΡ€ΠΈΡ€Π°Ρ‚Π΅ Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат ΠΎΡ‚ Π΅Π΄ΠΈΠ½ ΠΎΡ‚ Π΄ΠΎΠ²Π΅Ρ€Π΅Π½ΠΈΡ‚Π΅ CA (ΠΌΠΎΠΆΠ΅ Let’s Encrypt) Π·Π° STARTTLS Π² MTA (STARTTLS сС ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° ΠΎΡ‚ всички ΡΡŠΠ²Ρ€Π΅ΠΌΠ΅Π½Π½ΠΈ MTA), спСциална ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° ΠΎΡ‚ страна Π½Π° MTA Π½Π΅ Π΅ Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌΠ°.

Π‘Ρ‚ΡŠΠΏΠΊΠ° ΠΏΠΎ ΡΡ‚ΡŠΠΏΠΊΠ°, Ρ‚ΠΎΠ²Π° ΠΈΠ·Π³Π»Π΅ΠΆΠ΄Π° Ρ‚Π°ΠΊΠ°:

  1. ΠšΠΎΠ½Ρ„ΠΈΠ³ΡƒΡ€ΠΈΡ€Π°ΠΉΡ‚Π΅ STARTTLS Π² използвания MTA (postfix, exim, sendmail, Microsoft Exchange ΠΈ Ρ‚.Π½.).
  2. Π£Π±Π΅Π΄Π΅Ρ‚Π΅ сС, Ρ‡Π΅ сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° Π²Π°Π»ΠΈΠ΄Π΅Π½ сСртификат (ΠΈΠ·Π΄Π°Π΄Π΅Π½ ΠΎΡ‚ Π΄ΠΎΠ²Π΅Ρ€Π΅Π½ CA, Π½Π΅ Π΅ ΠΈΠ·Ρ‚Π΅ΠΊΡŠΠ», ΡΡƒΠ±Π΅ΠΊΡ‚ΡŠΡ‚ Π½Π° сСртификата ΡΡŠΠΎΡ‚Π²Π΅Ρ‚ΡΡ‚Π²Π° Π½Π° MX записа, ΠΏΠΎ ΠΊΠΎΠΉΡ‚ΠΎ сС доставя ΠΏΠΎΡ‰Π°Ρ‚Π° Π·Π° вашия Π΄ΠΎΠΌΠ΅ΠΉΠ½).
  3. ΠšΠΎΠ½Ρ„ΠΈΠ³ΡƒΡ€ΠΈΡ€Π°ΠΉΡ‚Π΅ TLS-RPT записа, ΠΏΠΎ ΠΊΠΎΠΉΡ‚ΠΎ Ρ‰Π΅ сС доставят ΠΎΡ‚Ρ‡Π΅Ρ‚ΠΈΡ‚Π΅ Π·Π° ΠΏΡ€ΠΈΠ»Π°Π³Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠΈΡ‚Π΅ (с услугитС, ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‰ΠΈ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅ Π½Π° ΠΎΡ‚Ρ‡Π΅Ρ‚ΠΈ TLS). ΠŸΡ€ΠΈΠΌΠ΅Ρ€ Π½Π° записа (Π·Π° Π΄ΠΎΠΌΠ΅ΠΉΠ½ example.com):
    smtp._tls.example.com. 300 IN TXT "v=TLSRPTv1;rua=mailto:tlsrpt@example.com"

    Π’Π°Π·ΠΈ записка инструктира ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡ΠΈΡ‚Π΅ Π½Π° ΠΈΠΌΠ΅ΠΉΠ»ΠΈ Π΄Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‚ статистичСски ΠΎΡ‚Ρ‡Π΅Ρ‚ΠΈ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° TLS Π² SMTP Π½Π° адрСса tlsrpt@exmple.com.

    Π‘Π»Π΅Π΄Π΅Ρ‚Π΅ ΠΎΡ‚Ρ‡Π΅Ρ‚ΠΈΡ‚Π΅ Π² ΠΏΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠ΅Π½ΠΈΠ΅ Π½Π° няколко Π΄Π½ΠΈ, ΡƒΠ²Π΅Ρ€Π΅Ρ‚Π΅ сС, Ρ‡Π΅ няма Π³Ρ€Π΅ΡˆΠΊΠΈ.

  4. ΠŸΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°ΠΉΡ‚Π΅ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° MTA-STS Ρ‡Ρ€Π΅Π· HTTPS. ΠŸΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° сС ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π° ΠΊΠ°Ρ‚ΠΎ тСкстов Ρ„Π°ΠΉΠ» с Ρ‚Π΅Ρ€ΠΌΠΈΠ½Π°Ρ‚ΠΎΡ€ΠΈΡ‚Π΅ Π½Π° Ρ€Π΅Π΄ΠΎΠ²Π΅Ρ‚Π΅ CRLF Π½Π° ΡƒΠΊΠ°Π·Π°Π½ΠΎΡ‚ΠΎ мСстополоТСниС.
    https://mta-sts.example.com/.well-known/mta-sts.txt
    

    ΠŸΡ€ΠΈΠΌΠ΅Ρ€Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°:

    version: STSv1
    mode: enforce
    mx: mxs.mail.ru
    mx: emx.mail.ru
    mx: mx2.corp.mail.ru
    max_age: 86400
    

    ΠŸΠΎΠ»Π΅Ρ‚ΠΎ version ΡΡŠΠ΄ΡŠΡ€ΠΆΠ° вСрсията Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° (Π² ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° Ρ‚ΠΎΠ²Π° Π΅ STSv1), Mode Π·Π°Π΄Π°Π²Π° Ρ€Π΅ΠΆΠΈΠΌΠ° Π½Π° ΠΏΡ€ΠΈΠ»Π°Π³Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π°, testing β€” тСстов Ρ€Π΅ΠΆΠΈΠΌ (ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° Π½Π΅ сС ΠΏΡ€ΠΈΠ»Π°Π³Π°), enforce β€” "Π±ΠΎΠ΅Π½" Ρ€Π΅ΠΆΠΈΠΌ. ΠŸΡŠΡ€Π²ΠΎ ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°ΠΉΡ‚Π΅ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° с mode: testing, Π°ΠΊΠΎ няма ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈ с ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° Π² тСстовия Ρ€Π΅ΠΆΠΈΠΌ, слСд извСстно Π²Ρ€Π΅ΠΌΠ΅ ΠΌΠΎΠΆΠ΅ Π΄Π° сС ΠΏΡ€Π΅Π²ΠΊΠ»ΡŽΡ‡ΠΈ Π½Π° mode: enforce.

    Π’ mx сС Π·Π°Π΄Π°Π²Π° списък Π½Π° всички пощСнски ΡΡŠΡ€Π²ΡŠΡ€ΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ ΠΌΠΎΠ³Π°Ρ‚ Π΄Π° ΠΏΡ€ΠΈΠ΅ΠΌΠ°Ρ‚ ΠΏΠΎΡ‰Π° Π·Π° вашия Π΄ΠΎΠΌΠ΅ΠΉΠ½ (всСки ΡΡŠΡ€Π²ΡŠΡ€ трябва Π΄Π° ΠΈΠΌΠ° ΠΊΠΎΠ½Ρ„ΠΈΠ³ΡƒΡ€ΠΈΡ€Π°Π½ сСртификат, ΡΡŠΠΎΡ‚Π²Π΅Ρ‚ΡΡ‚Π²Π°Ρ‰ Π½Π° ΠΈΠΌΠ΅Ρ‚ΠΎ, Π·Π°Π΄Π°Π΄Π΅Π½ΠΎ Π² mx). Max_age Π·Π°Π΄Π°Π²Π° Π²Ρ€Π΅ΠΌΠ΅Ρ‚ΠΎ Π·Π° ΠΊΠ΅ΡˆΠΈΡ€Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° (вСднъТ Π·Π°ΠΏΠΎΠΌΠ½Π΅Π½Π°Ρ‚Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° Ρ‰Π΅ сС ΠΏΡ€ΠΈΠ»Π°Π³Π° Π΄ΠΎΡ€ΠΈ Π°ΠΊΠΎ атакуващият Π±Π»ΠΎΠΊΠΈΡ€Π° Π½Π΅ΠΉΠ½ΠΎΡ‚ΠΎ ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅ ΠΈΠ»ΠΈ Ρ€Π°Π·Π²Π°Π»ΠΈ DNS записитС Π·Π° Π²Ρ€Π΅ΠΌΠ΅Ρ‚ΠΎ Π½Π° ΠΊΠ΅ΡˆΠΈΡ€Π°Π½Π΅; сигнализиранС Π·Π° нСобходимост ΠΎΡ‚ ΠΏΠΎΠ²Ρ‚ΠΎΡ€Π½ΠΎ Π·Π°ΠΏΠΈΡ‚Π²Π°Π½Π΅ Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° ΠΌΠΎΠΆΠ΅ Π΄Π° сС Π½Π°ΠΏΡ€Π°Π²ΠΈ Ρ‡Ρ€Π΅Π· промяна Π½Π° mta-sts записа Π² DNS).

  5. ΠŸΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°ΠΉΡ‚Π΅ Π² DNS TXT запис:Β 
    _mta-sts.example.com. TXT "v=STS1; id=someid;"
    

    Π’ ΠΏΠΎΠ»Π΅Ρ‚ΠΎ id ΠΌΠΎΠΆΠ΅Ρ‚Π΅ Π΄Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Ρ‚Π΅ ΠΏΡ€ΠΎΠΈΠ·Π²ΠΎΠ»Π΅Π½ ΠΈΠ΄Π΅Π½Ρ‚ΠΈΡ„ΠΈΠΊΠ°Ρ‚ΠΎΡ€ (Π½Π°ΠΏΡ€ΠΈΠΌΠ΅Ρ€ Π²Ρ€Π΅ΠΌΠ΅Π²ΠΈ ΠΏΠ΅Ρ‡Π°Ρ‚), ΠΏΡ€ΠΈ промяна Π½Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° Ρ‚ΠΎΠΉ трябва Π΄Π° сС промСня, ΠΊΠΎΠ΅Ρ‚ΠΎ позволява Π½Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡ΠΈΡ‚Π΅ Π΄Π° Ρ€Π°Π·Π±Π΅Ρ€Π°Ρ‚, Ρ‡Π΅ Π΅ Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌΠΎ Π΄Π° сС ΠΏΠΎΠ²Ρ‚ΠΎΡ€ΠΈ Π·Π°ΠΏΠΈΡ‚Π²Π°Π½Π΅Ρ‚ΠΎ Π·Π° ΠΊΠ΅ΡˆΠΈΡ€Π°Π½Π°Ρ‚Π° ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° (Π°ΠΊΠΎ ΠΈΠ΄Π΅Π½Ρ‚ΠΈΡ„ΠΈΠΊΠ°Ρ‚ΠΎΡ€ΡŠΡ‚ сС Ρ€Π°Π·Π»ΠΈΡ‡Π°Π²Π° ΠΎΡ‚ ΠΊΠ΅ΡˆΠΈΡ€Π°Π½Π°Ρ‚Π°).

ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° MTA-STS ΠΎΡ‚ страна Π½Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‡Π°

Π—Π° ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° ситуацията Π½Π΅ Π΅ Π΄ΠΎΠ±Ρ€Π°, Ρ‚ΡŠΠΉ ΠΊΠ°Ρ‚ΠΎ ΡΡ‚Π°Π½Π΄Π°Ρ€Ρ‚ΡŠΡ‚ Π΅ Π½ΠΎΠ².

  • Exim β€” няма Π²Π³Ρ€Π°Π΄Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°, ΠΈΠΌΠ° външСн скрипт https://github.com/Bobberty/MTASTS-EXIM-PERLΒ 
  • Postfix β€” няма Π²Π³Ρ€Π°Π΄Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°, ΠΈΠΌΠ° външСн скрипт, Π·Π° ΠΊΠΎΠΉΡ‚ΠΎ ΠΏΠΎΠ΄Ρ€ΠΎΠ±Π½ΠΎ Π΅ описано Π² Π₯Π°Π±Ρ€Π° https://habr.com/en/post/424961/

Π’ Π·Π°ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈΠ΅ относно Β«Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π½ΠΈΡ TLSΒ»

Π’ послСдно Π²Ρ€Π΅ΠΌΠ΅ Ρ€Π΅Π³ΡƒΠ»Π°Ρ‚ΠΎΡ€ΠΈΡ‚Π΅ ΠΎΠ±Ρ€ΡŠΡ‰Π°Ρ‚ Π²Π½ΠΈΠΌΠ°Π½ΠΈΠ΅ Π½Π° сигурността Π½Π° ΠΏΠΎΡ‰Π°Ρ‚Π° (ΠΈ Ρ‚ΠΎΠ²Π° Π΅ Π΄ΠΎΠ±Ρ€Π΅). НапримСр, DMARC Π΅ Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ Π·Π° всички Π΄ΡŠΡ€ΠΆΠ°Π²Π½ΠΈ учрСТдСния Π² БАЩ ΠΈ всС ΠΏΠΎ-чСсто сС изисква Π² финансовия сСктор, Π² Ρ€Π΅Π³ΡƒΠ»ΠΈΡ€Π°Π½ΠΈΡ‚Π΅ сфСри ΠΏΡ€ΠΎΠ½ΠΈΠΊΠ²Π°Π½Π΅Ρ‚ΠΎ Π½Π° стандарта достига 90%. Π’ ΠΌΠΎΠΌΠ΅Π½Ρ‚Π° някои Ρ€Π΅Π³ΡƒΠ»Π°Ρ‚ΠΎΡ€ΠΈ изискват внСдряванС Π½Π° Β«Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ TLSΒ» с ΠΎΡ‚Π΄Π΅Π»Π½ΠΈ Π΄ΠΎΠΌΠ΅ΠΉΠ½ΠΈ, Π½ΠΎ ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΡŠΡ‚ Π·Π° осигуряванС Π½Π° Β«Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ TLSΒ» Π½Π΅ Π΅ ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ ΠΈ Π½Π° ΠΏΡ€Π°ΠΊΡ‚ΠΈΠΊΠ° Ρ‚Π°Π·ΠΈ настройка чСсто сС въвСТда ΠΏΠΎ Π½Π°Ρ‡ΠΈΠ½, ΠΊΠΎΠΉΡ‚ΠΎ Π΄ΠΎΡ€ΠΈ ΠΌΠΈΠ½ΠΈΠΌΠ°Π»Π½ΠΎ Π½Π΅ Π·Π°Ρ‰ΠΈΡ‚Π°Π²Π° ΠΎΡ‚ Ρ€Π΅Π°Π»Π½ΠΈ Π°Ρ‚Π°ΠΊΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ Π²Π΅Ρ‡Π΅ са ΠΏΡ€Π΅Π΄Π²ΠΈΠ΄Π΅Π½ΠΈ Π² Ρ‚Π°ΠΊΠΈΠ²Π° ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠΈ ΠΊΠ°Ρ‚ΠΎ DANE ΠΈΠ»ΠΈ MTA-STS.

Ако Ρ€Π΅Π³ΡƒΠ»Π°Ρ‚ΠΎΡ€ΡŠΡ‚ изисква Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π΅ Π½Π° Β«Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ TLSΒ» с ΠΎΡ‚Π΄Π΅Π»Π½ΠΈ Π΄ΠΎΠΌΠ΅ΠΉΠ½ΠΈ, ΠΏΡ€Π΅ΠΏΠΎΡ€ΡŠΡ‡Π²Π°ΠΌΠ΅ Π΄Π° сС обмисли MTA-STS ΠΈΠ»ΠΈ нСговия частичСн Π°Π½Π°Π»ΠΎΠ³ ΠΊΠ°Ρ‚ΠΎ Π½Π°ΠΉ-подходящ ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΡŠΠΌ, Ρ‚ΠΎΠΉ отстранява нСобходимостта ΠΎΡ‚ бСзопасно настройванС Π·Π° всСки Π΄ΠΎΠΌΠ΅ΠΉΠ½ ΠΏΠΎΠΎΡ‚Π΄Π΅Π»Π½ΠΎ. Ако ΠΈΠΌΠ°Ρ‚Π΅ затруднСния с Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π΅Ρ‚ΠΎ Π½Π° клиСнтската част Π½Π° MTA-STS (Π΄ΠΎΠΊΠ°Ρ‚ΠΎ ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΡŠΡ‚ Π½Π΅ ΠΏΠΎΠ»ΡƒΡ‡ΠΈ ΡˆΠΈΡ€ΠΎΠΊΠ° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°, Π½Π°ΠΉ-вСроятно Ρ‰Π΅ Π±ΡŠΠ΄Π°Ρ‚ Ρ‚Π°ΠΊΠ°Π²Π°), ΠΌΠΎΠΆΠ΅Ρ‚Π΅ Π΄Π° ΠΏΡ€Π΅ΠΏΠΎΡ€ΡŠΡ‡Π°Ρ‚Π΅ слСдния ΠΏΠΎΠ΄Ρ…ΠΎΠ΄:

  1. ΠŸΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°ΠΉΡ‚Π΅ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ°Ρ‚Π° MTA-STS ΠΈ/ΠΈΠ»ΠΈ записитС DANE (DANE ΠΈΠΌΠ° смисъл Π΄Π° сС добавя само Π°ΠΊΠΎ Π²Π°ΡˆΠΈΡΡ‚ Π΄ΠΎΠΌΠ΅ΠΉΠ½ Π²Π΅Ρ‡Π΅ ΠΈΠΌΠ° Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½ DNSSEC, Π° MTA-STS Π² ΠΊΠ°ΠΊΡŠΠ²Ρ‚ΠΎ ΠΈ Π΄Π° Π΅ случай), Ρ‚ΠΎΠ²Π° Ρ‰Π΅ Π·Π°Ρ‰ΠΈΡ‚ΠΈ Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° към вас ΠΈ Ρ‰Π΅ Π²ΠΈ освободи ΠΎΡ‚ нСобходимостта Π΄Π° искатС ΠΎΡ‚ Π΄Ρ€ΡƒΠ³ΠΈ пощСнски слуТби Π΄Π° настроят Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ TLS Π·Π° вашия Π΄ΠΎΠΌΠ΅ΠΉΠ½, Π°ΠΊΠΎ пощСнската слуТба Π²Π΅Ρ‡Π΅ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° MTA-STS ΠΈ/ΠΈΠ»ΠΈ DANE.
  2. Π—Π° Π³ΠΎΠ»Π΅ΠΌΠΈΡ‚Π΅ пощСнски услуги Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°ΠΉΡ‚Π΅ "Π°Π½Π°Π»ΠΎΠ³" Π½Π° MTA-STS Ρ‡Ρ€Π΅Π· ΠΎΡ‚Π΄Π΅Π»Π½ΠΈ настройки Π½Π° транспорта Π·Π° всСки Π΄ΠΎΠΌΠ΅ΠΉΠ½, ΠΊΠΎΠΈΡ‚ΠΎ Ρ‰Π΅ фиксират MX, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ Π·Π° Ρ€Π΅Π»Π΅ Π½Π° ΠΏΠΎΡ‰Π°Ρ‚Π° ΠΈ Ρ‰Π΅ изискват Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π½Π° ΠΏΡ€ΠΎΠ²Π΅Ρ€ΠΊΠ° Π½Π° TLS сСртификата. Ако Π΄ΠΎΠΌΠ΅Π½ΠΈΡ‚Π΅ Π²Π΅Ρ‡Π΅ ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Ρ‚ ΠΏΠΎΠ»ΠΈΡ‚ΠΈΠΊΠ° MTA-STS, Ρ‚ΠΎΠ²Π° вСроятно ΠΌΠΎΠΆΠ΅ Π΄Π° сС Π½Π°ΠΏΡ€Π°Π²ΠΈ Π±Π΅Π·Π±ΠΎΠ»Π΅Π·Π½Π΅Π½ΠΎ. Π‘Π°ΠΌΠΎΡ‚ΠΎ Π²ΠΊΠ»ΡŽΡ‡Π²Π°Π½Π΅ Π½Π° Π·Π°Π΄ΡŠΠ»ΠΆΠΈΡ‚Π΅Π»Π΅Π½ TLS Π·Π° Π΄ΠΎΠΌΠ΅ΠΉΠ½ Π±Π΅Π· фиксация Π½Π° рСлСя ΠΈ ΠΏΡ€ΠΎΠ²Π΅Ρ€ΠΊΠ° Π½Π° сСртификата Π·Π° Π½Π΅Π³ΠΎ Π΅ Π½Π΅Π΅Ρ„Π΅ΠΊΡ‚ΠΈΠ²Π½ΠΎ ΠΎΡ‚ Π³Π»Π΅Π΄Π½Π° Ρ‚ΠΎΡ‡ΠΊΠ° Π½Π° сигурността ΠΈ Π½Π΅ добавя Π½ΠΈΡ‰ΠΎ към ΡΡŠΡ‰Π΅ΡΡ‚Π²ΡƒΠ²Π°Ρ‰ΠΈΡ‚Π΅ ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠΈ STARTTLS.

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: habr.com

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster