ИздаванС на FreeBSD 12.3

ΠŸΡ€Π΅Π΄ΡΡ‚Π°Π²Π΅Π½ Π΅ Ρ€Π΅Π»ΠΈΠ· FreeBSD 12.3, ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Π½ Π·Π° Π°Ρ€Ρ…ΠΈΡ‚Π΅ΠΊΡ‚ΡƒΡ€ΠΈΡ‚Π΅ amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 ΠΈ armv6, armv7 ΠΈ aarch64. Π”ΠΎΠΏΡŠΠ»Π½ΠΈΡ‚Π΅Π»Π½ΠΎ са ΠΏΠΎΠ΄Π³ΠΎΡ‚Π²Π΅Π½ΠΈ ΠΎΠ±Ρ€Π°Π·ΠΈ Π·Π° Π²ΠΈΡ€Ρ‚ΡƒΠ°Π»ΠΈΠ·Π°Ρ†ΠΈΠΎΠ½Π½ΠΈ систСми (QCOW2, VHD, VMDK, raw) ΠΈ ΠΎΠ±Π»Π°Ρ‡Π½ΠΈ срСди Amazon EC2. Π Π΅Π»ΠΈΠ·ΡŠΡ‚ FreeBSD 13.1 сС ΠΎΡ‡Π°ΠΊΠ²Π° ΠΏΡ€Π΅Π· ΠΏΡ€ΠΎΠ»Π΅Ρ‚Ρ‚Π° Π½Π° 2022 Π³ΠΎΠ΄ΠΈΠ½Π°.

ΠšΠ»ΡŽΡ‡ΠΎΠ²ΠΈ нововъвСдСния:

  • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ скрипт /etc/rc.final, ΠΊΠΎΠΉΡ‚ΠΎ сС стартира Π½Π° послСдния Π΅Ρ‚Π°ΠΏ Π½Π° Ρ€Π°Π±ΠΎΡ‚Π° слСд ΠΏΡ€ΠΈΠΊΠ»ΡŽΡ‡Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° всички потрСбитСлски процСси.
  • Π’ ΠΏΠ°ΠΊΠ΅Ρ‚Π° Ρ„ΠΈΠ»Ρ‚ΡŠΡ€ ipfw Π΅ прСдоставСна ΠΊΠΎΠΌΠ°Π½Π΄Π° dnctl Π·Π° ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° настройкитС Π½Π° систСмата Π·Π° ΠΎΠ³Ρ€Π°Π½ΠΈΡ‡Π°Π²Π°Π½Π΅ Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° dummynet.
  • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ sysctl kern.crypto Π·Π° ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° криптосистСмата Π½Π° ядрото, ΠΊΠ°ΠΊΡ‚ΠΎ ΠΈ ΠΎΡ‚Π»Π°Π΄ΡŠΡ‡Π΅Π½ sysctl debug.uma_reclaim.
  • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ sysctl net.inet.tcp.tolerate_missing_ts, ΠΊΠΎΠΉΡ‚ΠΎ допуска TCP-ΠΏΠ°ΠΊΠ΅Ρ‚ΠΈ Π±Π΅Π· Π²Ρ€Π΅ΠΌΠ΅Π²ΠΈ ΠΏΠ΅Ρ‡Π°Ρ‚ΠΈ (опция timestamp, RFC 1323/RFC 7323).
  • Π’ ядрото GENERIC Π·Π° Π°Ρ€Ρ…ΠΈΡ‚Π΅ΠΊΡ‚ΡƒΡ€Π°Ρ‚Π° amd64 Π΅ Π²ΠΊΠ»ΡŽΡ‡Π΅Π½Π° опция COMPAT_LINUXKPI ΠΈ Π΅ Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
  • Π’ Π·Π°Ρ€Π΅ΠΆΠ΄Π°Ρ‡Π° Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° Π·Π°Ρ€Π΅ΠΆΠ΄Π°Π½Π΅ Π½Π° ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΎΠ½Π½Π°Ρ‚Π° систСма ΠΎΡ‚ ram-диск, ΠΊΠ°ΠΊΡ‚ΠΎ ΠΈ Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ZFS ΠΎΠΏΡ†ΠΈΠΈ com.delphix:bookmark_written ΠΈ com.datto:bookmark_v2.
  • Π’ Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ°Ρ‚Π° fetch Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° проксириранС Π½Π° FTP Π²ΡŠΡ€Ρ…Ρƒ HTTPS.
  • Π’ пакСтния ΠΌΠ΅Π½ΠΈΠ΄ΠΆΡŠΡ€ pkg Π·Π° ΠΊΠΎΠΌΠ°Π½Π΄ΠΈΡ‚Π΅ β€žbootstrapβ€œ ΠΈ β€žaddβ€œ Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ Ρ„Π»Π°Π³ β€ž-rβ€œ Π·Π° ΡƒΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° рСпозитория. ΠžΡΠΈΠ³ΡƒΡ€Π΅Π½ΠΎ Π΅ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΏΡ€ΠΎΠΌΠ΅Π½Π»ΠΈΠ²ΠΈ Π½Π° срСдата ΠΎΡ‚ Ρ„Π°ΠΉΠ»Π° pkg.conf.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° growfs Π²Π΅Ρ‡Π΅ ΠΈΠΌΠ° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° Ρ€Π°Π±ΠΎΡ‚Π° с Ρ„Π°ΠΉΠ»ΠΎΠ²ΠΈ систСми, ΠΌΠΎΠ½Ρ‚ΠΈΡ€Π°Π½ΠΈ Π² Ρ€Π΅ΠΆΠΈΠΌ Π½Π° Ρ‡Π΅Ρ‚Π΅Π½Π΅ ΠΈ запис.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° etcupdate Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ Ρ€Π΅ΠΆΠΈΠΌ Π½Π° Π²ΡŠΠ·ΡΡ‚Π°Π½ΠΎΠ²ΡΠ²Π°Π½Π΅ Π½Π° измСнСния Π·Π° Π²ΡŠΠ·ΡΡ‚Π°Π½ΠΎΠ²ΡΠ²Π°Π½Π΅ Π½Π° Π΅Π΄ΠΈΠ½ ΠΈΠ»ΠΈ няколко Ρ„Π°ΠΉΠ»Π°. Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ Ρ„Π»Π°Π³ β€ž-Dβ€œ Π·Π° ΡƒΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° Ρ†Π΅Π»Π΅Π²Π°Ρ‚Π° дирСктория. ΠžΡΠΈΠ³ΡƒΡ€Π΅Π½ΠΎ Π΅ ΠΈΠ·Π²Π»ΠΈΡ‡Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ с ΠΏΠΎΠΌΠΎΡ‰Ρ‚Π° Π½Π° Π²Ρ€Π΅ΠΌΠ΅Π²Π° дирСктория ΠΈ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ° Π½Π° SIGINT.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚ΠΈΡ‚Π΅ freebsd-update ΠΈ freebsd-version Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ Ρ„Π»Π°Π³ β€ž-jβ€œ Π·Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° jail срСди.
  • Π£Ρ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° cpuset сСга ΠΌΠΎΠΆΠ΅ Π΄Π° сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° Π² jail срСди Π·Π° промяна Π½Π° ΠΏΠ°Ρ€Π°ΠΌΠ΅Ρ‚Ρ€ΠΈΡ‚Π΅ Π½Π° Π΄ΡŠΡ‰Π΅Ρ€Π½ΠΈ jail.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° cmp са Π΄ΠΎΠ±Π°Π²Π΅Π½ΠΈ ΠΎΠΏΡ†ΠΈΠΈ: β€ž-bβ€œ (β€”print-bytes) Π·Π° ΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ Π½Π° Ρ€Π°Π·Π»ΠΈΡ‡Π°Π²Π°Ρ‰ΠΈΡ‚Π΅ сС Π±Π°ΠΉΡ‚ΠΎΠ²Π΅, β€ž-iβ€œ (β€”ignore-initial) Π·Π° ΠΈΠ³Π½ΠΎΡ€ΠΈΡ€Π°Π½Π΅ Π½Π° ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ Π±Ρ€ΠΎΠΉ Π½Π°Ρ‡Π°Π»Π½ΠΈ Π±Π°ΠΉΡ‚ΠΎΠ²Π΅, β€ž-nβ€œ (β€”bytes) Π·Π° ΠΎΠ³Ρ€Π°Π½ΠΈΡ‡Π°Π²Π°Π½Π΅ Π½Π° броя сравнявани Π±Π°ΠΉΡ‚ΠΎΠ²Π΅.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° daemon Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ Ρ„Π»Π°Π³ β€ž-Hβ€œ Π·Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ° Π½Π° SIGHUP ΠΈ прСотварянС Π½Π° Ρ„Π°ΠΉΠ»Π°, Π² ΠΊΠΎΠΉΡ‚ΠΎ сС ΠΈΠ·Π²ΡŠΡ€ΡˆΠ²Π° ΠΈΠ·Ρ…ΠΎΠ΄ (Π΄ΠΎΠ±Π°Π²Π΅Π½ Π·Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° newsyslog).
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° fstyp ΠΏΡ€ΠΈ ΡƒΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° Ρ„Π»Π°Π³Π° β€ž-lβ€œ Π΅ осигурСно опрСдСлянС ΠΈ ΠΏΠΎΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° Ρ„Π°ΠΉΠ»ΠΎΠ²ΠΈΡ‚Π΅ систСми exFAT.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° mergemaster Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ΠΎ ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° символични Π»ΠΈΠ½ΠΊΠΎΠ²Π΅ ΠΏΠΎ Π²Ρ€Π΅ΠΌΠ΅ Π½Π° обновяванС.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° newsyslog Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ Ρ„Π»Π°Π³ 'E' Π·Π° Π΄Π΅Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½Π΅ Π½Π° ротацията Π½Π° ΠΏΡ€Π°Π·Π½ΠΈ Π»ΠΎΠ³ΠΎΠ²Π΅.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° tcpdump сС появи Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° Π΄Π΅ΠΊΠΎΠ΄ΠΈΡ€Π°Π½Π΅ Π½Π° ΠΏΠ°ΠΊΠ΅Ρ‚ΠΈ Π½Π° интСрфСйситС pfsync.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° top Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΊΠΎΠΌΠ°Π½Π΄Π°Ρ‚Π°-Ρ„ΠΈΠ»Ρ‚ΡŠΡ€ ' / ' Π·Π° ΠΏΠΎΠΊΠ°Π·Π²Π°Π½Π΅ само Π½Π° процСси ΠΈΠ»ΠΈ Π°Ρ€Π³ΡƒΠΌΠ΅Π½Ρ‚ΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ ΡΡŠΠΎΡ‚Π²Π΅Ρ‚ΡΡ‚Π²Π°Ρ‚ Π½Π° Π·Π°Π΄Π°Π΄Π΅Π½Π°Ρ‚Π° строка.
  • Π’ unzip Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° Π°Ρ€Ρ…ΠΈΠ²ΠΈ, Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ΠΈ с ΠΏΠ°Ρ€ΠΎΠ»Π°.
  • ΠŸΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° Ρ…Π°Ρ€Π΄ΡƒΠ΅Ρ€Π°. Π”ΠΎΠ±Π°Π²Π΅Π½ΠΈ са ΠΈΠ΄Π΅Π½Ρ‚ΠΈΡ„ΠΈΠΊΠ°Ρ‚ΠΎΡ€ΠΈ Π½Π° PCI-устройства Π·Π° AHCI ΠΊΠΎΠ½Ρ‚Ρ€ΠΎΠ»Π΅Ρ€ΠΈ ASMedia ASM116x ΠΈ I2C ΠΊΠΎΠ½Ρ‚Ρ€ΠΎΠ»Π΅Ρ€ΠΈ Intel Gemini Lake. Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈ Π°Π΄Π°ΠΏΡ‚Π΅Ρ€ΠΈ Mikrotik 10/25G ΠΈ Π±Π΅Π·ΠΆΠΈΡ‡Π½ΠΈ ΠΊΠ°Ρ€Ρ‚ΠΈ Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π½ΠΎΠ² Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ igc Π·Π° ethernet ΠΊΠΎΠ½Ρ‚Ρ€ΠΎΠ»Π΅Ρ€ΠΈ Intel I225 2.5G/1G/100MB/10MB.
  • Netgraph-ΡƒΠ·Π΅Π» ng_bridge Π΅ Π°Π΄Π°ΠΏΡ‚ΠΈΡ€Π°Π½ Π·Π° SMP систСми. Π’ ΡƒΠ·Π΅Π»Π° ng_nat Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° CGN (Carrier Grade NAT, RFC 6598). ΠŸΡ€Π΅Π΄ΠΎΡΡ‚Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° подмяна Π½Π° ΡƒΠ·Π΅Π»Π° ng_source Π² която ΠΈ Π΄Π° Π΅ част ΠΎΡ‚ Netgraph ΠΌΡ€Π΅ΠΆΠ°Ρ‚Π°.
  • Π’ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€Π° rctl, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ Π·Π° Π»ΠΈΠΌΠΈΡ‚ΠΈΡ€Π°Π½Π΅ Π½Π° рСсурситС, Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° Π·Π°Π΄Π°Π²Π°Π½Π΅ Π½Π° ΠΎΠ³Ρ€Π°Π½ΠΈΡ‡Π΅Π½ΠΈΠ΅ Π½Π° ΠΏΠΎΡ‚Ρ€Π΅Π±Π»Π΅Π½ΠΈΠ΅Ρ‚ΠΎ Π½Π° рСсурси Π½Π° стойност 0.
  • Π’ интСрфСйса vlan Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° систСма Π·Π° ΠΏΡ€ΠΈΠΎΡ€ΠΈΡ‚ΠΈΠ·ΠΈΡ€Π°Π½Π΅ Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° ΠΈ ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° пропускатСлната способност ALTQ.
  • Π’ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈΡ‚Π΅ amdtemp ΠΈ amdsmn Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° CPU Zen 3 'Vermeer' ΠΈ APU Ryzen 4000 (Zen 2, 'Renoir').
  • Актуализирани са вСрсиитС Π½Π° Π²ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈΡ‚Π΅ Π² Π±Π°Π·ΠΎΠ²Π°Ρ‚Π° систСма странични прилоТСния: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Π£Ρ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° unzip Π΅ синхронизирана с ΠΊΠΎΠ΄ΠΎΠ²Π°Ρ‚Π° Π±Π°Π·Π° Π½Π° NetBSD.

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: opennet.ru

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster