Издание на http сървъра Lighttpd 1.4.65

Състоянието на релиза на лекото http-сървър lighttpd 1.4.65, който се опитва да комбинира висока производителност, сигурност, съответствие на стандартите и гъвкавост на настройките. Lighttpd е подходящ за прилагане при системи с високо натоварване и е насочен към ниска консумация на памет и CPU. В новата версия са представени 173 промени. Кодът на проекта е написан на C и се разпространява под лиценз BSD.

Основни нововъведения:

  • Добавена е поддръжка на WebSocket през HTTP/2, както и реализиран RFC 8441, който описва механизма за стартиране на протокола WebSockets в един поток в рамките на HTTP/2 връзка.
  • Реализирана е разширена схема за управление на приоритетите, позволяваща на клиента да влияе на приоритета на предаваните сървър отговори (RFC 9218) и да управлява приоритетите при пренасочване на заявки. За HTTP/2 е осигурена поддръжка на кадъра PRIORITY_UPDATE.
  • В настройките lighttpd.conf е добавена поддръжка на условни съпоставяния с привързване към началото (=^) и края (=$) на реда. Подобни проверки на текста са значително по-бързи от регулярните изрази и са достатъчни за много прости проверки.
  • В mod_webdav е добавена поддръжка за частични операции PUT (обхващащи част от данните с помощта на заглавката Range). За включване може да се използва опцията ‘webdav.opts += ("partial-put-copy-modify" => "enable").
  • В mod_accesslog е добавена опцията ‘accesslog.escaping = ‘json'.
  • В mod_deflate е добавена поддръжка за компилиране с libdeflate.
  • Ускорено е предаването на тялото на заявката през HTTP/2.
  • Стойността на параметъра server.max-keep-alive-requests по подразбиране е променена от 100 на 1000.
  • В списъка с MIME типове ‘application/javascript’ е заменен с ‘text/javascript’ (RFC 9239).

В бъдеще е планирано прилагането на по-строги настройки за шифри за TLS и деактивиране по подразбиране на остарели шифри. Настройката CipherString ще бъде променена от ‘HIGH’ на ‘EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384’. Освен това планирано е премахването на остарели опции TLS: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Освен това ще продължи почистването на мини-модулите, които могат да бъдат заменени с по-гъвкава Lua реализация на mod_magnet. По-конкретно, планирано е премахването на модулите mod_evasive, mod_secdownload, mod_uploadprogress и mod_usertrack.

Източник: opennet.ru

Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри 🔥 Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри | ProHoster