ИзданиС Π½Π° криптографската Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ° OpenSSL 3.3.0

Π‘Π»Π΅Π΄ ΠΏΠ΅Ρ‚ мСсСца Ρ€Π°Π·Ρ€Π°Π±ΠΎΡ‚ΠΊΠ°, бСшС прСдставСна вСрсия 3.3.0 Π½Π° Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ°Ρ‚Π° OpenSSL, която Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅ SSL/TLS ΠΈ Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° OpenSSL 3.3 Ρ‰Π΅ ΠΏΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠΈ Π΄ΠΎ Π°ΠΏΡ€ΠΈΠ» 2026 Π³ΠΎΠ΄ΠΈΠ½Π°. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΏΡ€Π΅Π΄ΠΈΡˆΠ½ΠΈΡ‚Π΅ вСрсии OpenSSL 3.2, 3.1 ΠΈ 3.0 LTS Ρ‰Π΅ ΠΏΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠΈ Π΄ΠΎ Π½ΠΎΠ΅ΠΌΠ²Ρ€ΠΈ 2025 Π³ΠΎΠ΄ΠΈΠ½Π°, ΠΌΠ°Ρ€Ρ‚ 2025 Π³ΠΎΠ΄ΠΈΠ½Π° ΠΈ сСптСмври 2026 Π³ΠΎΠ΄ΠΈΠ½Π° ΡΡŠΠΎΡ‚Π²Π΅Ρ‚Π½ΠΎ. ΠšΠΎΠ΄ΡŠΡ‚ Π½Π° ΠΏΡ€ΠΎΠ΅ΠΊΡ‚Π° Π΅ разпространСн ΠΏΠΎΠ΄ Π»ΠΈΡ†Π΅Π½Π· Apache 2.0.

Основни нововъвСдСния в OpenSSL 3.3.0:

  • ΠŸΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠ°Π²Π° интСграцията Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° QUIC (RFC 9000), прСдставляващ надстройка Π½Π°Π΄ ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° UDP, ΠΊΠΎΠΉΡ‚ΠΎ сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° ΠΊΠ°Ρ‚ΠΎ транспорт Π² ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° HTTP/3. Π’ Π½ΠΎΠ²ΠΎΡ‚ΠΎ ΠΈΠ·Π΄Π°Π½ΠΈΠ΅:
    • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° трасировка Π½Π° QUIC-ΡΠ²ΡŠΡ€Π·Π²Π°Π½ΠΈΡ Ρ‡Ρ€Π΅Π· Π²ΠΎΠ΄Π΅Π½Π΅ Π½Π° диагностичСн Π»ΠΎΠ³ Π² Ρ„ΠΎΡ€ΠΌΠ°Ρ‚ qlog.
    • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΏΠΎΠ»ΠΈΠ½Π³ Π² Π½Π΅Π±Π»ΠΎΠΊΠΈΡ€Π°Ρ‰ Ρ€Π΅ΠΆΠΈΠΌ Π½Π° QUIC-ΡΠ²ΡŠΡ€Π·Π²Π°Π½ΠΈΡ ΠΈ ΠΏΠΎΡ‚ΠΎΠΊΠΎΠ²ΠΈ ΠΎΠ±Π΅ΠΊΡ‚ΠΈ.
    • Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΎΠΏΡ‚ΠΈΠΌΠΈΠ·ΠΈΡ€Π°Π½Π° гСнСрация Π½Π° ΠΊΠ°Π΄Ρ€ΠΈ Π·Π° Π·Π°Π²ΡŠΡ€ΡˆΠ²Π°Π½Π΅ Π½Π° ΠΏΠΎΡ‚ΠΎΠΊΠ° ΠΏΡ€ΠΈ QUIC-ΡΠ²ΡŠΡ€Π·Π²Π°Π½ΠΈΡ.
    • ΠŸΡ€Π΅Π΄ΠΎΡΡ‚Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° Π΄Π΅Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½Π΅ Π½Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ°Ρ‚Π° Π½Π° ΡΡŠΠ±ΠΈΡ‚ΠΈΡ QUIC ΠΏΡ€ΠΈ извиквания Π½Π° API.
    • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° настройка Π½Π° Ρ‚Π°ΠΉΠΌΠ°ΡƒΡ‚ Π½Π° нСактивност Π·Π° QUIC.
    • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ API Π·Π° Π·Π°ΠΏΠΈΡ‚Π²Π°Π½Π΅ Π·Π° Ρ€Π°Π·ΠΌΠ΅Ρ€ ΠΈ стСпСн Π½Π° запълванС Π½Π° Π±ΡƒΡ„Π΅Ρ€Π° Π·Π° запис Π·Π° QUIC ΠΏΠΎΡ‚ΠΎΡ†ΠΈ.
  • Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ΠΈ са Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΡ Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° Π·Π° ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° сСртификатитС CMP (Certificate Management Protocol), ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ΠΈ Π² спСцификациитС RFC 9480 (ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ΠΈΠ΅ Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° CMPv3) ΠΈ RFC 9483 (лСсСн ΠΏΡ€ΠΎΡ„ΠΈΠ» Π·Π° устройства с ΠΎΠ³Ρ€Π°Π½ΠΈΡ‡Π΅Π½ΠΈ рСсурси).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° Π΄Π΅Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½Π΅ Π½Π° Π΅Ρ‚Π°ΠΏΠ° Π½Π° компилация Π½Π° функцията atexit.
  • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π²Π°Ρ€ΠΈΠ°Π½Ρ‚ Π½Π° API SSL_SESSION, ΠΊΠΎΠΉΡ‚ΠΎ Π½Π΅ Π΅ ΠΈΠ·Π»ΠΎΠΆΠ΅Π½ Π½Π° ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠ° ΠΎΡ‚ 2038 Π³ΠΎΠ΄ΠΈΠ½Π°: Π΄ΠΎΠ±Π°Π²Π΅Π½ΠΈ са Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈΡ‚Π΅ SSL_SESSION_get_time_ex() ΠΈ SSL_SESSION_set_time_ex(), ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Ρ‰ΠΈ 64-Π±ΠΈΡ‚ΠΎΠ²ΠΈ Ρ‚ΠΈΠΏΠΎΠ²Π΅ time_t Π½Π° 32-Π±ΠΈΡ‚ΠΎΠ²ΠΈ систСми.
  • Π’ функцията EVP_PKEY_fromdata Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° Π°Π²Ρ‚ΠΎΠΌΠ°Ρ‚ΠΈΡ‡Π½ΠΎ ΠΈΠ·Π²Π»ΠΈΡ‡Π°Π½Π΅ Π½Π° ΠΏΠ°Ρ€Π°ΠΌΠ΅Ρ‚Ρ€ΠΈ ΠΎΡ‚ китайската Ρ‚Π΅ΠΎΡ€Π΅ΠΌΠ° Π·Π° ΠΎΡΡ‚Π°Ρ‚ΡŠΡ†ΠΈΡ‚Π΅ (CRT, Chinese Remainder Theorem).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΈΠ³Π½ΠΎΡ€ΠΈΡ€Π°Π½Π΅ Π½Π° нСизвСстни ΠΈΠΌΠ΅Π½Π° Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ Π·Π° подписи, Π·Π°Π΄Π°Π΄Π΅Π½ΠΈ Π² конфигурацията TLS SignatureAlgorithms ΠΈ ClientSignatureAlgorithms.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° настройка Π½Π° ΠΏΡ€ΠΈΠΎΡ€ΠΈΡ‚Π΅Ρ‚Π½ΠΎΡ‚ΠΎ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° PSK-ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅ ΠΏΡ€ΠΈ ΡΡŠΡ€Π²ΡŠΡ€ TLS 1.3 ΠΏΠΎ Π²Ρ€Π΅ΠΌΠ΅ Π½Π° Π²ΡŠΠ·ΡΡ‚Π°Π½ΠΎΠ²ΡΠ²Π°Π½Π΅ Π½Π° сСсия.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ функцията EVP_DigestSqueeze(), която позволява ΡΡŠΠΊΡ€Π°Ρ‰Π°Π²Π°Π½Π΅ Π½Π° Ρ€Π°Π·ΠΌΠ΅Ρ€Π° Π½Π° SHAKE Ρ…Π΅Ρˆ (ΠΏΡ€Π΅ΠΌΠ°Ρ…Π²Π°Π½Π΅ Π½Π° ΡΡ‚Π°Ρ€ΡˆΠΈ Π±ΠΈΡ‚ΠΎΠ²Π΅), ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°ΠΉΠΊΠΈ няколко ΠΈΡ‚Π΅Ρ€Π°Ρ†ΠΈΠΈ с Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Ρ€Π°Π·ΠΌΠ΅Ρ€ΠΈ Π½Π° ΠΈΠ·Ρ…ΠΎΠ΄Π°.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° СкспортиранС Π½Π° Ρ„Π°ΠΉΠ»ΠΎΠ²Π΅ Π·Π° сборка Π·Π° CMake Π½Π° Unix-ΠΏΠΎΠ΄ΠΎΠ±Π½ΠΈ систСми ΠΈ Windows (Π² допълнСниС към СкспортиранСто Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° pkg-config).
  • Π˜Π·Π²ΡŠΡ€ΡˆΠ΅Π½ΠΈ ΠΎΠΏΡ‚ΠΈΠΌΠΈΠ·Π°Ρ†ΠΈΠΈ Π½Π° производитСлността: ΠžΠΏΡ‚ΠΈΠΌΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ Ρ€Π°Π±ΠΎΡ‚Π°Ρ‚Π° Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌΠ° AES-GCM Π½Π° устройства с Ρ‡ΠΈΠΏΠΎΠ²Π΅ Microsoft Azure Cobalt 100. Π’ рСализацията Π½Π° AES-CTR Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ускорСниС с ΠΏΠΎΠΌΠΎΡ‰Ρ‚Π° Π½Π° Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΡ ARM Neoverse V1 ΠΈ V2. Π’ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈ са ΠΎΠΏΡ‚ΠΈΠΌΠΈΠ·Π°Ρ†ΠΈΠΈ Π½Π° AES ΠΈ SHA3 Π·Π° систСми Apple с Ρ‡ΠΈΠΏΠΎΠ²Π΅ M3. Π’ Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ криптографски Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈ са ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈ Π²Π΅ΠΊΡ‚ΠΎΡ€Π½ΠΈ Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΡ RISC-V. Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ асСмблСрна рСализация Π½Π° md5 Π·Π° CPU Loongarch64.

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: opennet.ru

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster