ИздаванС Π½Π° криптографската Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ° OpenSSL 4.0.0

ИзлСзС Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ°Ρ‚Π° OpenSSL 4.0.0, която ΠΏΡ€Π΅Π΄Π»Π°Π³Π° рСализация Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅ TLS ΠΈ Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅. OpenSSL 4.0 Π΅ класифициран ΠΊΠ°Ρ‚ΠΎ ΠΈΠ·Π΄Π°Π½ΠΈΠ΅ с ΠΎΠ±ΠΈΠΊΠ½ΠΎΠ²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°, ΠΊΠ°Ρ‚ΠΎ Π°ΠΊΡ‚ΡƒΠ°Π»ΠΈΠ·Π°Ρ†ΠΈΠΈ сС ΠΈΠ·Π΄Π°Π²Π°Ρ‚ Π² Ρ‚Π΅Ρ‡Π΅Π½ΠΈΠ΅ Π½Π° 13 мСсСца. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΏΡ€Π΅Π΄ΠΈΡˆΠ½ΠΈΡ‚Π΅ вСрсии OpenSSL 3.6, 3.5 LTS, 3.4 ΠΈ 3.0 LTS Ρ‰Π΅ ΠΏΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠΈ Π΄ΠΎ Π½ΠΎΠ΅ΠΌΠ²Ρ€ΠΈ 2026 Π³., Π°ΠΏΡ€ΠΈΠ» 2030 Π³., ΠΎΠΊΡ‚ΠΎΠΌΠ²Ρ€ΠΈ 2026 Π³. ΠΈ сСптСмври 2026 Π³. ΡΡŠΠΎΡ‚Π²Π΅Ρ‚Π½ΠΎ. ΠšΠΎΠ΄ΡŠΡ‚ Π½Π° ΠΏΡ€ΠΎΠ΅ΠΊΡ‚Π° сС разпространява ΠΏΠΎΠ΄ Π»ΠΈΡ†Π΅Π½Π· Apach 2.0.

Основни нововъвСдСния:

  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° TLS Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΠ΅Ρ‚ΠΎ ECH (Encrypted ClientHello, RFC 9849), ΠΊΠΎΠ΅Ρ‚ΠΎ Π΅ ΠΏΡ€Π΅Π΄Π½Π°Π·Π½Π°Ρ‡Π΅Π½ΠΎ Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ Π½Π° информацията Π·Π° ΠΏΠ°Ρ€Π°ΠΌΠ΅Ρ‚Ρ€ΠΈΡ‚Π΅ Π½Π° TLS сСсиитС, ΠΊΠ°Ρ‚ΠΎ исканото Π΄ΠΎΠΌΠ΅ΠΉΠ½ ΠΈΠΌΠ΅. Π—Π° Ρ€Π°Π·Π»ΠΈΠΊΠ° ΠΎΡ‚ Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΠ΅Ρ‚ΠΎ ESNI (Encrypted Server Name Indication), Π² ECH вмСсто ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ Π½Π° Π½ΠΈΠ²ΠΎ ΠΎΡ‚Π΄Π΅Π»Π½ΠΈ ΠΏΠΎΠ»Π΅Ρ‚Π°, всичкото TLS ΡΡŠΠΎΠ±Ρ‰Π΅Π½ΠΈΠ΅ ClientHello Π΅ ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½ΠΎ, ΠΊΠΎΠ΅Ρ‚ΠΎ позволява Π±Π»ΠΎΠΊΠΈΡ€Π°Π½Π΅ Π½Π° Ρ‚Π΅Ρ‡ΠΎΠ²Π΅Ρ‚Π΅ Ρ‡Ρ€Π΅Π· ΠΏΠΎΠ»Π΅Ρ‚Π°, ΠΊΠΎΠΈΡ‚ΠΎ Π½Π΅ ΠΎΠ±Ρ…Π²Π°Ρ‰Π° ESNI, ΠΊΠ°Ρ‚ΠΎ ΠΏΠΎΠ»Π΅Ρ‚ΠΎ PSK (Pre-Shared Key).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈΡ‚Π΅, ΠΎΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ΠΈ Π² RFC 8998, ΠΊΠΎΠΈΡ‚ΠΎ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Ρ‚ стандартизирания Π² ΠšΠΈΡ‚Π°ΠΉ Π½Π°Π±ΠΎΡ€ ΠΎΡ‚ ΠΊΡ€ΠΈΠΏΡ‚ΠΎΠ°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ SM2: Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌ Π·Π° Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅ Π½Π° Ρ†ΠΈΡ„Ρ€ΠΎΠ²Π° подпис sm2sig_sm3, Π³Ρ€ΡƒΠΏΠ° Π·Π° ΠΎΠ±ΠΌΠ΅Π½ Π½Π° ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅ curveSM2 ΠΈ постквантова Π³Ρ€ΡƒΠΏΠ° curveSM2MLKEM768.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ криптографска функция Π·Π° Ρ…Π΅ΡˆΠΈΡ€Π°Π½Π΅ cSHAKE, Π±Π°Π·ΠΈΡ€Π°Π½Π° Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌΠ° SHA-3, която позволява Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅Ρ‚ΠΎ Π½Π° Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Ρ…Π΅ΡˆΠΎΠ²Π΅ Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° Π΅Π΄Π½ΠΈ ΠΈ ΡΡŠΡ‰ΠΈ Π²Ρ…ΠΎΠ΄Π½ΠΈ Π΄Π°Π½Π½ΠΈ Π·Π° Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ Π°Ρ‚Π°ΠΊΠΈ, ΠΌΠ°Π½ΠΈΠΏΡƒΠ»ΠΈΡ€Π°Ρ‰ΠΈ ΠΏΠΎΠ²Ρ‚ΠΎΡ€Π½ΠΎΡ‚ΠΎ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ.
  • Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ Ρ…ΠΈΠ±Ρ€ΠΈΠ΄Π΅Π½ Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌ β€žML-DSA-MUβ€œ, ΠΊΠΎΠΉΡ‚ΠΎ ΡΡŠΡ‡Π΅Ρ‚Π°Π²Π° постквантовия Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌ Π·Π° Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅ Π½Π° Ρ†ΠΈΡ„Ρ€ΠΎΠ²Π° подпис ML-DSA (CRYSTALS-Dilithium) с класичСската Ρ…Π΅Ρˆ функция SHAKE256.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈ Π·Π° Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅ Π½Π° ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅ SNMP KDF, Π±Π°Π·ΠΈΡ€Π°Π½ΠΈ Π½Π° HMAC-SHA ΠΈ SRTP KDF Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° AES-CM, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈ Π² ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈΡ‚Π΅ ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈ SNMPv3 ΠΈ SRTP Π·Π° създаванС Π½Π° криптографски ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅.
  • Към ΠΊΠΎΠΌΠ°Π½Π΄Π°Ρ‚Π° β€žopenssl fipsinstallβ€œ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° опция β€ž-defer_testsβ€œ, която позволява ΠΎΡ‚Π»Π°Π³Π°Π½Π΅ Π½Π° стартиранСто Π½Π° тСстовСтС ΠΏΡ€ΠΈ инсталиранС Π½Π° FIPS ΠΌΠΎΠ΄ΡƒΠ»ΠΈ.
  • Π—Π° ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠ°Ρ‚Π° Windows Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° статично ΠΈΠ»ΠΈ Π΄ΠΈΠ½Π°ΠΌΠΈΡ‡Π½ΠΎ ΡΠ²ΡŠΡ€Π·Π²Π°Π½Π΅ с Visual C++ Runtime.
  • Π’ TLS 1.2 Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° съгласиС Π½Π° ΠΎΠ±ΠΌΠ΅Π½Π° Π½Π° ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅ Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌΠ° FFDHE, ΠΊΠΎΠΉΡ‚ΠΎ отговаря Π½Π° RFC 7919.
  • ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° SSLv3 ΠΈ SSLv2 Client Hello Π΅ ΠΏΡ€Π΅ΠΊΡ€Π°Ρ‚Π΅Π½Π°.
  • ΠŸΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° Π΄ΠΈΠ½Π°ΠΌΠΈΡ‡Π½ΠΎ Π·Π°Ρ€Π΅ΠΆΠ΄Π°Π΅ΠΌΠΈ ΠΌΠΎΠ΄ΡƒΠ»ΠΈ, вмСсто ΠΊΠΎΠΈΡ‚ΠΎ Π·Π° Ρ€Π°Π·ΡˆΠΈΡ€ΡΠ²Π°Π½Π΅ Π½Π° функционалността Π½Π° OpenSSL слСдва Π΄Π° сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° концСпцията Π½Π° ΡΠ²ΡŠΡ€Π·Π°Π½ΠΈ доставчици.
  • Π’ TLS Π½Π° Π΅Ρ‚Π°ΠΏΠ° Π½Π° компилация Π΅ ΠΈΠ·ΠΊΠ»ΡŽΡ‡Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° остарСли Π΅Π»ΠΈΠΏΡ‚ΠΈΡ‡Π½ΠΈ ΠΊΡ€ΠΈΠ²ΠΈ. Π—Π° Π²Ρ€ΡŠΡ‰Π°Π½Π΅ ΠΌΠΎΠΆΠ΅ Π΄Π° сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° опцията Β«enable-tls-deprecated-ecΒ».
  • ΠŸΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚Π° Π΅ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π΅Ρ‚Π° c_rehash, вмСсто Π½Π΅Π³ΠΎ трябва Π΄Π° сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° ΠΊΠΎΠΌΠ°Π½Π΄Π°Ρ‚Π° Β«openssl rehashΒ».
  • ΠžΡ‚ ΠΊΠΎΠΌΠ°Π½Π΄Π°Ρ‚Π° Β«openssl caΒ» Π΅ ΠΏΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚Π° остарялата опция Β«msie-hackΒ».
  • ΠŸΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° собствСни ΠΌΠ΅Ρ‚ΠΎΠ΄ΠΈ EVP_CIPHER, EVP_MD, EVP_PKEY ΠΈ EVP_PKEY_ASN1.
  • ΠŸΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚ΠΈ са остарСли Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈ SSL/TLS, ΡΠ²ΡŠΡ€Π·Π°Π½ΠΈ с фиксирани вСрсии Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅, Π½Π°ΠΏΡ€ΠΈΠΌΠ΅Ρ€ Β«TLSv1_client_method()Β».
  • ΠŸΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚ΠΈ са остарСли Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈ ERR_get_state(), ERR_remove_state() ΠΈ ERR_remove_thread_state().
  • ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° Ρ†Π΅Π»Π΅Π²ΠΈ ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠΈ darwin-i386{,-cc} ΠΈ darwin-ppc{,64}{,-cc} Π΅ ΠΏΡ€Π΅ΠΊΡ€Π°Ρ‚Π΅Π½Π°.

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: opennet.ru

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster