ИзданиС на OpenBSD 6.9

ΠŸΡ€Π΅Π΄ΡΡ‚Π°Π²Π΅Π½ Π΅ новият свободСн крос-ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠ΅Π½ UNIX-ΠΏΠΎΠ΄ΠΎΠ±Π΅Π½ ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΎΠ½Π΅Π½ систСма OpenBSD 6.9. ΠŸΠΎΠ΄Ρ‡Π΅Ρ€Ρ‚Π°Π²Π° сС, Ρ‡Π΅ Ρ‚ΠΎΠ²Π° Π΅ 50-ият Π±Ρ€ΠΎΠΉ Π½Π° ΠΏΡ€ΠΎΠ΅ΠΊΡ‚Π°, ΠΊΠΎΠΉΡ‚ΠΎ Ρ‚Π°Π·ΠΈ Π³ΠΎΠ΄ΠΈΠ½Π° Π½Π°Π²ΡŠΡ€ΡˆΠ²Π° 26 Π³ΠΎΠ΄ΠΈΠ½ΠΈ. ΠŸΡ€ΠΎΠ΅ΠΊΡ‚ΡŠΡ‚ OpenBSD Π΅ основан ΠΎΡ‚ Π’Π΅ΠΎ Π΄Π΅ Π Π°Π°Π΄Ρ‚ (Theo de Raadt) ΠΏΡ€Π΅Π· 1995 Π³. слСд ΠΊΠΎΠ½Ρ„Π»ΠΈΠΊΡ‚ с Ρ€Π°Π·Ρ€Π°Π±ΠΎΡ‚Ρ‡ΠΈΡ†ΠΈΡ‚Π΅ Π½Π° NetBSD, Π² Ρ€Π΅Π·ΡƒΠ»Ρ‚Π°Ρ‚ Π½Π° ΠΊΠΎΠΉΡ‚ΠΎ Π΄ΠΎΡΡ‚ΡŠΠΏΡŠΡ‚ Π½Π° Π’Π΅ΠΎ Π΄ΠΎ CVS рСпозитория Π½Π° NetBSD Π΅ Π±Π»ΠΎΠΊΠΈΡ€Π°Π½. Π‘Π»Π΅Π΄ Ρ‚ΠΎΠ²Π° Π’Π΅ΠΎ Π΄Π΅ Π Π°Π°Π΄Ρ‚ ΠΈ Π³Ρ€ΡƒΠΏΠ° ΡΡŠΠΌΠΈΡˆΠ»Π΅Π½ΠΈΡ†ΠΈ ΡΡŠΠ·Π΄Π°Π²Π°Ρ‚ Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° Π΄ΡŠΡ€Π²ΠΎΡ‚ΠΎ с ΠΈΠ·Ρ…ΠΎΠ΄Π΅Π½ ΠΊΠΎΠ΄ Π½Π° NetBSD Π½ΠΎΠ²Π° ΠΎΡ‚Π²ΠΎΡ€Π΅Π½Π° ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΎΠ½Π½Π° систСма, Ρ‡ΠΈΠΉΡ‚ΠΎ основни Ρ†Π΅Π»ΠΈ Π·Π° Ρ€Π°Π·Π²ΠΈΡ‚ΠΈΠ΅ са прСносимост (ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‚ сС 13 Ρ…Π°Ρ€Π΄ΡƒΠ΅Ρ€Π½ΠΈ ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠΈ), стандартизация, ΠΊΠΎΡ€Π΅ΠΊΡ‚Π½Π° Ρ€Π°Π±ΠΎΡ‚Π°, Π°ΠΊΡ‚ΠΈΠ²Π½Π° сигурност ΠΈ ΠΈΠ½Ρ‚Π΅Π³Ρ€ΠΈΡ€Π°Π½ΠΈ криптографски срСдства. Π Π°Π·ΠΌΠ΅Ρ€ΡŠΡ‚ Π½Π° пълния инсталационСн ISO ΠΎΠ±Ρ€Π°Π· Π½Π° Π±Π°Π·ΠΎΠ²Π°Ρ‚Π° систСма OpenBSD 6.9 Π΅ 544 MB.

ОсвСн самата ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΎΠ½Π½Π° систСма, ΠΏΡ€ΠΎΠ΅ΠΊΡ‚ΡŠΡ‚ OpenBSD Π΅ извСстСн със своитС ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½Ρ‚ΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ са ΠΏΠΎΠ»ΡƒΡ‡ΠΈΠ»ΠΈ разпространСниС Π² Π΄Ρ€ΡƒΠ³ΠΈ систСми ΠΈ сС Π΄ΠΎΠΊΠ°Π·Π°Π»ΠΈ ΠΊΠ°Ρ‚ΠΎ Π΅Π΄Π½ΠΈ ΠΎΡ‚ Π½Π°ΠΉ-сигурнитС ΠΈ качСствСни Ρ€Π΅ΡˆΠ΅Π½ΠΈΡ. Π‘Ρ€Π΅Π΄ тях са: LibreSSL (Ρ„ΠΎΡ€ΠΊ Π½Π° OpenSSL), OpenSSH, пакСтният Ρ„ΠΈΠ»Ρ‚ΡŠΡ€ PF, Π΄Π΅ΠΌΠΎΠ½ΠΈΡ‚Π΅ Π·Π° ΠΌΠ°Ρ€ΡˆΡ€ΡƒΡ‚ΠΈΠ·Π°Ρ†ΠΈΡ OpenBGPD ΠΈ OpenOSPFD, NTP-ΡΡŠΡ€Π²ΡŠΡ€ΡŠΡ‚ OpenNTPD, пощСнският ΡΡŠΡ€Π²ΡŠΡ€ OpenSMTPD, ΠΌΡƒΠ»Ρ‚ΠΈΠΏΠ»Π΅ΠΊΡΠΎΡ€ΡŠΡ‚ Π½Π° тСкстов Ρ‚Π΅Ρ€ΠΌΠΈΠ½Π°Π» (Π°Π½Π°Π»ΠΎΠ³ Π½Π° GNU screen) tmux, Π΄Π΅ΠΌΠΎΠ½ΡŠΡ‚ identd с рСализация Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° IDENT, BSDL-Π°Π»Ρ‚Π΅Ρ€Π½Π°Ρ‚ΠΈΠ²Π° Π½Π° ΠΏΠ°ΠΊΠ΅Ρ‚Π° GNU groff β€” mandoc, ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ» Π·Π° ΠΎΡ€Π³Π°Π½ΠΈΠ·ΠΈΡ€Π°Π½Π΅ Π½Π° отказоустойчиви систСми CARP (Common Address Redundancy Protocol), Π»Π΅ΠΊ http-ΡΡŠΡ€Π²ΡŠΡ€, ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π° Π·Π° синхронизация Π½Π° Ρ„Π°ΠΉΠ»ΠΎΠ²Π΅ OpenRSYNC.

Основни подобрСния:

  • Π’ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€Π° softraid Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ Ρ€Π΅ΠΆΠΈΠΌ RAID1C с рСализация Π½Π° софтуСрСн RAID1 с ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ.
  • Π’ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈ са Π΄Π²Π° Π½ΠΎΠ²ΠΈ Ρ„ΠΎΠ½ΠΎΠ²ΠΈ процСса β€” dhcpleased ΠΈ resolvd, ΠΊΠΎΠΈΡ‚ΠΎ работят Π·Π°Π΅Π΄Π½ΠΎ с slaacd ΠΈ unwind Π·Π° Π°Π²Ρ‚ΠΎΠΌΠ°Ρ‚ΠΈΡ‡Π½Π° настройка Π½Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈΡ‚Π΅ интСрфСйси ΠΈ опрСдСлянС Π½Π° ΠΈΠΌΠ΅Π½Π° Π² DNS. Π’ dhcpleased Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΡŠΡ‚ DHCP Π·Π° ΠΏΠΎΠ»ΡƒΡ‡Π°Π²Π°Π½Π΅ Π½Π° IP адрСси, Π° Π² resolvd Π΅ осигурСно ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° ΡΡŠΠ΄ΡŠΡ€ΠΆΠ°Π½ΠΈΠ΅Ρ‚ΠΎ Π½Π° resolv.conf Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° Π΄Π°Π½Π½ΠΈ Π·Π° ΠΈΠΌΠ΅Π½Π° Π½Π° ΡΡŠΡ€Π²ΡŠΡ€ΠΈ, ΠΏΠΎΠ»ΡƒΡ‡Π΅Π½ΠΈ ΠΎΡ‚ dhcpleased, slaacd ΠΈ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈ ΠΊΠ°Ρ‚ΠΎ umb.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π½Π°Ρ‡Π°Π»Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° устройства Apple с процСсор M1. Π’ΠΊΠ»ΡŽΡ‡ΠΈΡ‚Π΅Π»Π½ΠΎ Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ΠΎ Ρ€Π°Π·ΠΏΠΎΠ·Π½Π°Π²Π°Π½Π΅ Π½Π° arm64 ядра Apple Icestorm/Firestorm ΠΈ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Π±Π΅Π·ΠΆΠΈΡ‡Π½ΠΈ Ρ‡ΠΈΠΏΠΎΠ²Π΅ BCM4378, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈ Π² SoC Apple M1.
  • ΠŸΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠ°Ρ‚Π° powerpc64, Ρ€Π°Π·Π²ΠΈΠ²Π°Π½Π° Π·Π° 64-Π±ΠΈΡ‚ΠΎΠ²ΠΈ систСми Π½Π° Π±Π°Π·Π°Ρ‚Π° Π½Π° процСсори POWER8 ΠΈ POWER9. Π’ сравнСниС с ΠΏΡ€Π΅Π΄ΠΈΡˆΠ½ΠΎΡ‚ΠΎ ΠΈΠ·Π΄Π°Π½ΠΈΠ΅ Π·Π° powerpc64 Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠ° Π·Π° Π·Π°Ρ‰ΠΈΡ‚Π° RETGUARD, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ astfb Π·Π° Ρ„Ρ€Π΅ΠΉΠΌΠ±ΡƒΡ„Π΅Ρ€Π° Aspeed BMC, Ρ€Π΅ΡˆΠ΅Π½ΠΈ са ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈΡ‚Π΅ с Ρ€Π°Π±ΠΎΡ‚Π°Ρ‚Π° Π½Π° Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈΡ‚Π΅ radeondrm ΠΈ amdgpu Π½Π° систСми с GPU AMD, Π² сборкитС Π½Π° ядрото Π·Π° ram-диск Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΎ Π·Π°Ρ€Π΅ΠΆΠ΄Π°Π½Π΅, Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Π΅Π½Π΅Ρ€Π³ΠΈΠΉΠ½ΠΈ Ρ€Π΅ΠΆΠΈΠΌΠΈ Π·Π° CPU POWER9, Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΈΠ·ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈΡ, Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½ΠΈ ΠΏΡ€ΠΈ ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΈ с ΠΏΠ»Π°Π²Π°Ρ‰Π° запСтая, Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° IPMI Π·Π° систСми PowerNV.
  • Π—Π° ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠΈΡ‚Π΅ ARM64 Π΅ осигурСна ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° CPU Cortex-A78AE, Cortex-X1 ΠΈ Neoverse V1, Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ΠΈ са ΠΎΠΏΡ‚ΠΈΠΌΠΈΠ·ΠΈΡ€Π°Π½ΠΈ Π·Π° ARM64 Π²Π°Ρ€ΠΈΠ°Π½Ρ‚ΠΈ Π½Π° извикванията copyin, copyout ΠΈ kcopy, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ cryptox Π·Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΎΡ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΡΡ‚Π° ARMv8, ΠΊΠ°ΠΊΡ‚ΠΎ ΠΈ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ smmu Π·Π° RM System MMU с ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Guard Page. ΠŸΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½a Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° устройствата Raspberry Pi, Rock Pi N10, NanoPi ΠΈ Pinebook Pro.
  • Π’ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€Π° video Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ sysctl-ΠΏΠ°Ρ€Π°ΠΌΠ΅Ρ‚ΡŠΡ€ kern.video.record, ΠΊΠΎΠΉΡ‚ΠΎ ΠΏΠΎΠ΄ΠΎΠ±Π½ΠΎ Π½Π° kern.audio.record управлява Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΠΏΡ€Π°Π·Π΅Π½ ΠΎΠ±Ρ€Π°Π· ΠΏΡ€ΠΈ ΠΎΠΏΠΈΡ‚ΠΈ Π·Π° запис Π½Π° Π²ΠΈΠ΄Π΅ΠΎ (Π·Π° Ρ€Π°Π·Ρ€Π΅ΡˆΠ°Π²Π°Π½Π΅ Π½Π° записа Π΅ Π½Π΅ΠΎΠ±Ρ…ΠΎΠ΄ΠΈΠΌΠΎ Π΄Π° сС ΠΏΡ€ΠΎΠΌΠ΅Π½ΠΈ стойността Π½Π° 1). На процСситС Π΅ Ρ€Π°Π·Ρ€Π΅ΡˆΠ΅Π½ΠΎ ΠΌΠ½ΠΎΠ³ΠΎΠΊΡ€Π°Ρ‚Π½ΠΎ отварянС Π½Π° устройството video (Ρ€Π΅ΡˆΠ°Π²Π° ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈΡ‚Π΅ с ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΡƒΠ΅Π±ΠΊΠ°ΠΌΠ΅Ρ€Π°Ρ‚Π° Π² Firefox ΠΈ BigBlueButton).
  • Π”ΠΎΠ±Π°Π²Π΅Π½ΠΈ са Ρ‚ΠΎΡ‡ΠΊΠΈ Π·Π° прослСдяванС Π½Π° извикванията malloc ΠΈ free, позволяващи Ρ‡Ρ€Π΅Π· dt ΠΈ btrace Π΄Π° сС прослСдява ΡΠ²ΡŠΡ€Π·Π°Π½Π°Ρ‚Π° с Ρ€Π°Π·ΠΏΡ€Π΅Π΄Π΅Π»Π΅Π½ΠΈΠ΅Ρ‚ΠΎ Π½Π° ΠΏΠ°ΠΌΠ΅Ρ‚Ρ‚Π° активност. Π’ btrace Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° опция β€˜-n’ Π·Π° парсинг Π½Π° ΠΏΡ€ΠΎΠ³Ρ€Π°ΠΌΠ°Ρ‚Π° Π±Π΅Π· ΠΈΠ·Π²ΡŠΡ€ΡˆΠ²Π°Π½Π΅ Π½Π° ΠΊΠ°ΠΊΠ²ΠΈΡ‚ΠΎ ΠΈ Π΄Π° Π±ΠΈΠ»ΠΎ дСйствия.
  • ΠŸΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° многопроцСсорни систСми (SMP). ΠžΡ‚ ΠΎΠ±Ρ‰Π°Ρ‚Π° Π±Π»ΠΎΠΊΠΈΡ€ΠΎΠ²ΠΊΠ° Π½Π° ядрото Π΅ ΠΈΠ·Π²Π΅Π΄Π΅Π½Π° рСализацията Π½Π° UNIX-сокСтитС, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ ΠΎΠ±Ρ‰ mutex Π·Π° сСриализация Π½Π° ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΈΡ‚Π΅ с msgbuf, ΠΏΡ€Π΅Π²Π΅Π΄Π΅Π½ Π΅ Π² mp-safe Ρ€Π΅ΠΆΠΈΠΌ ΠΈΠ·Π²ΠΈΠΊΠ²Π°Π½Π΅Ρ‚ΠΎ Π½Π° uvm_pagealloc, ΠΏΡ€Π΅ΠΌΠ°Ρ…Π½Π°Ρ‚ΠΈ са Π±Π»ΠΎΠΊΠΈΡ€ΠΎΠ²ΠΊΠΈΡ‚Π΅ ΠΏΡ€ΠΈ извикванията getppid ΠΈ sendsyslog.
  • ΠšΠΎΡ€ΠΈΠ³ΠΈΡ€Π°Π½ΠΈ са ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈΡ‚Π΅ Π² ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½Ρ‚ΠΈΡ‚Π΅ DRM (Direct Rendering Manager), Π² Ρ‚ΠΎΠ²Π° число са отстранСни сривовСтС Π² Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€Π° radeondrm Π½Π° систСмитС Powerbook5/6 ΠΈ RV350, установСна Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° DRI3 Π² Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈΡ‚Π΅ amdgpu ΠΈ ati, Π·Π° ΡΡŠΠ²ΠΌΠ΅ΡΡ‚ΠΈΠΌΠΎΡΡ‚ с Linux Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ΠΎ ΡΡŠΠ·Π΄Π°Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° устройства Π² ΠΊΠ°Ρ‚Π°Π»ΠΎΠ³Π° /dev/dri/.
  • ВнСсСни са подобрСния Π² Ρ…ΠΈΠΏΠ΅Ρ€Π²ΠΈΠ·ΠΎΡ€Π° VMM. Π’ Π±Π΅ΠΊΠ΅Π½Π΄Π° Π·Π° ΡƒΠΏΡ€Π°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° Π²ΠΈΡ€Ρ‚ΡƒΠ°Π»Π½ΠΈΡ‚Π΅ машини vmd Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° Π·Π°Ρ€Π΅ΠΆΠ΄Π°Π½Π΅ Π½Π° компрСсирани RAM-дисковС.
  • ВнСсСни са подобрСния Π² Π·Π²ΡƒΠΊΠΎΠ²Π°Ρ‚Π° подсистСма. ΠŸΡ€Π΅Π΄ΠΎΡΡ‚Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΎΡ‚Π΄Π΅Π»Π½ΠΎ Π·Π°ΠΊΡ€Π΅ΠΏΠ²Π°Π½Π΅ Π½Π° Π·Π²ΡƒΠΊΠΎΠ²ΠΈΡ‚Π΅ устройства sndio само Π·Π° Π²ΡŠΠ·ΠΏΡ€ΠΎΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ ΠΈ само Π·Π° запис. Π’ sndiod Π΅ задСйстван нискочСстотСн Ρ„ΠΈΠ»Ρ‚ΡŠΡ€ с ΠΊΡ€Π°ΠΉΠ½Π° импулсна характСристика (КИΠ₯-Ρ„ΠΈΠ»Ρ‚Ρ€) осмия Ρ€Π΅Π΄, ΠΊΠΎΠΉΡ‚ΠΎ позволява Π΄Π° сС отстранят ΡˆΡƒΠΌΠΎΠ²Π΅Ρ‚Π΅ ΠΎΡ‚ Π½Π°Π»ΠΎΠΆΠ΅Π½ΠΈΡ‚Π΅ спСктри ΠΏΡ€ΠΈ рСсСмплиранС. По ΠΏΠΎΠ΄Ρ€Π°Π·Π±ΠΈΡ€Π°Π½Π΅ функцията Π·Π° Π°Π²Ρ‚ΠΎΠΌΠ°Ρ‚ΠΈΡ‡Π½ΠΎ намаляванС Π½Π° Π·Π²ΡƒΠΊΠ°, ΠΊΠΎΠ³Π°Ρ‚ΠΎ Π½ΠΎΠ²Π° ΠΏΡ€ΠΎΠ³Ρ€Π°ΠΌΠ° Π·Π°ΠΏΠΎΡ‡Π½Π΅ Π²ΡŠΠ·ΠΏΡ€ΠΎΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ (autovolume), Π΅ ΠΈΠ·ΠΊΠ»ΡŽΡ‡Π΅Π½Π°, Π° стойността ΠΏΠΎ ΠΏΠΎΠ΄Ρ€Π°Π·Π±ΠΈΡ€Π°Π½Π΅ Π·Π° Π½ΠΈΠ²ΠΎΡ‚ΠΎ Π½Π° Π·Π²ΡƒΠΊΠ° Π΅ 127. Π Π°Π·Ρ€Π΅ΡˆΠ΅Π½ΠΎ Π΅ ΠΌΠΈΠΊΡˆΠΈΡ€Π°Π½Π΅ Π½Π° Π·Π²ΡƒΠΊΠ° ΠΎΡ‚ Π°Π»Ρ‚Π΅Ρ€Π½Π°Ρ‚ΠΈΠ²Π½ΠΈ устройства, Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ ΠΏΠΎ Π½ΠΈΠ²ΠΎΡ‚ΠΎ Π½Π° ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Π½Π°Ρ‚Π° функционалност Π² sndiod.
  • По ΠΏΠΎΠ΄Ρ€Π°Π·Π±ΠΈΡ€Π°Π½Π΅ Π΅ Π°ΠΊΡ‚ΠΈΠ²ΠΈΡ€Π°Π½ΠΎ ΠΈΠ·Π³Ρ€Π°ΠΆΠ΄Π°Π½Π΅Ρ‚ΠΎ ΠΈ инсталацията Π½Π° ΠΎΡ‚Π»Π°Π΄Ρ‡ΠΈΠΊΠ° LLDB.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚Ρ‡ΠΈΠΊΠ° logger Π² rcctl, rc.subr ΠΈ rc.d, ΠΊΠΎΠ΅Ρ‚ΠΎ позволява ΠΎΡ€Π³Π°Π½ΠΈΠ·ΠΈΡ€Π°Π½Π΅ Π½Π° Π»ΠΎΠ³ΠΎΠ²Π΅Ρ‚Π΅ ΠΎΡ‚ Ρ„ΠΎΠ½ΠΎΠ²ΠΈΡ‚Π΅ процСси, ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Ρ‰ΠΈ Π΄Π°Π½Π½ΠΈ Π² stdout/stderr.
  • Π—Π° Ρ‚ΡŠΡ‡ΠΏΠ°Π΄ΠΎΠ²Π΅ Π΅ прСдоставСна Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° настройка Π½Π° ΠΏΠΎΠ΄Ρ€Π΅Π΄Π±Π°Ρ‚Π° Π½Π° Π±ΡƒΡ‚ΠΎΠ½ΠΈΡ‚Π΅ Ρ‡Ρ€Π΅Π· wsconsctl. Π’ wscons Π΅ ΠΏΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ°Ρ‚Π° Π½Π° Π΅Π΄Π½ΠΎΠ²Ρ€Π΅ΠΌΠ΅Π½Π½ΠΈ докосвания.
  • Π—Π° ARM64 устройства Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° APM Π·Π° ΠΏΠΎΠ»ΡƒΡ‡Π°Π²Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ Π·Π° консумация Π½Π° СнСргия ΠΈ заряд Π½Π° батСрията. Π—Π° ΠΎΠ³Ρ€Π°Π½ΠΈΡ‡Π°Π²Π°Π½Π΅ Π½Π° Π΄ΠΎΡΡ‚ΡŠΠΏΠ° Π½Π° процСса apmd Π΄ΠΎ Ρ„Π°ΠΉΠ»ΠΎΠ²Π°Ρ‚Π° систСма Π΅ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΎ ΠΏΠΎΠ²ΠΈΠΊΠ²Π°Π½Π΅Ρ‚ΠΎ unveil.
  • Π Π°Π·ΡˆΠΈΡ€Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° Ρ…Π°Ρ€Π΄ΡƒΠ΅Ρ€. Π”ΠΎΠ±Π°Π²Π΅Π½ΠΈ са Π½ΠΎΠ²ΠΈ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈ acpige (Π·Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ° Π½Π° ACPI ΡΡŠΠ±ΠΈΡ‚ΠΈΡ, ΠΊΠ°Ρ‚ΠΎ натисканС Π½Π° Π±ΡƒΡ‚ΠΎΠ½Π° Π·Π° Π·Π°Ρ…Ρ€Π°Π½Π²Π°Π½Π΅), pchgpio (Π·Π° GPIO ΠΊΠΎΠ½Ρ‚Ρ€ΠΎΠ»Π΅Ρ€ΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ сС Π½Π°ΠΌΠΈΡ€Π°Ρ‚ Π½Π° ΡΡŠΠ²Ρ€Π΅ΠΌΠ΅Π½Π½ΠΈΡ‚Π΅ Intel PCH), ujoy (Π·Π° ΠΈΠ³Ρ€ΠΎΠ²ΠΈ ΠΊΠΎΠ½Ρ‚Ρ€ΠΎΠ»Π΅Ρ€ΠΈ), uhidpp (Π·Π° Logitech HID++ устройства). Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° AMD Vi ΠΈ Intel VTD IOMMU Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΡ Π·Π° изолация Π½Π° PCI устройства ΠΈ Π±Π»ΠΎΠΊΠΈΡ€Π°Π½Π΅ Π½Π° Π½Π΅ΠΏΡ€Π°Π²ΠΈΠ»Π΅Π½ Π΄ΠΎΡΡ‚ΡŠΠΏ Π΄ΠΎ ΠΏΠ°ΠΌΠ΅Ρ‚Ρ‚Π°. Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΊΠΎΠΌΠΏΡŽΡ‚Ρ€ΠΈ Lynloong LM9002/9003 ΠΈ LM9013. Π’ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈΡ‚Π΅ pcamux ΠΈ imxiic Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ACPI.
  • ΠŸΠΎΠ΄ΠΎΠ±Ρ€Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈ Π°Π΄Π°ΠΏΡ‚Π΅Ρ€ΠΈ: mvpp (SFP+ ΠΈ 10G Π·Π° Marvel Armada Ethernet), mvneta (1000base-x ΠΈ 2500base-x), mvsw (Marvel SOHO ΠΊΠΎΠΌΡƒΡ‚Π°Ρ‚ΠΎΡ€ΠΈ), rge (ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Wake on LAN), Netgear ProSecure UTM25. Π—Π° Π±Π΅Π·ΠΆΠΈΡ‡Π½ΠΈΡ‚Π΅ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ΠΈ iwm, iwn ΠΈ athn Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° RA (802.11n Tx Rate Adaptation). Π’ бСзТичния стСк Π΅ осигурСн Π°Π²Ρ‚ΠΎΠΌΠ°Ρ‚ΠΈΡ‡Π΅Π½ ΠΈΠ·Π±ΠΎΡ€ Π½Π° Ρ€Π΅ΠΆΠΈΠΌΠΈ 11a/b/g/n/ac ΠΏΡ€ΠΈ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° ΠΌΡ€Π΅ΠΆΠΎΠ² интСрфСйс Π² Ρ€Π΅ΠΆΠΈΠΌ Ρ‚ΠΎΡ‡ΠΊΠ° Π·Π° Π΄ΠΎΡΡ‚ΡŠΠΏ.
  • Π’ мрСТовия стСк Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ Π΄Ρ€Π°ΠΉΠ²Π΅Ρ€ veb (Virtual Ethernet Bridge). Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΌΠΎΠ½ΠΈΡ‚ΠΎΡ€ΠΈΠ½Π³, ΠΏΡ€ΠΈ която ΠΏΠ°ΠΊΠ΅Ρ‚ΠΈΡ‚Π΅, ΠΈΠ΄Π²Π°Ρ‰ΠΈ Π½Π° мрСТовия интСрфСйс, Π½Π΅ сС ΠΏΡ€Π΅Π΄Π°Π²Π°Ρ‚ Π½Π° мрСТовия стСк Π·Π° ΠΎΠ±Ρ€Π°Π±ΠΎΡ‚ΠΊΠ°, Π½ΠΎ ΠΌΠΎΠ³Π°Ρ‚ Π΄Π° сС ΠΏΡ€ΠΈΠ»Π°Π³Π°Ρ‚ ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠΈ Π·Π° Π°Π½Π°Π»ΠΈΠ· Π½Π° Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ°, ΠΊΠ°Ρ‚ΠΎ BPF. Π”ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π½ΠΎΠ² Ρ‚ΠΈΠΏ ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈ интСрфСйси β€” etherbridge. ΠžΡΠΈΠ³ΡƒΡ€Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° (ΠΊΠΎΠΌΠ°Π½Π΄Π° route sourceaddr) Π·Π° прСнаписванС Π½Π° изходящия IP адрСси адрСс Π·Π° ΠΏΡ€ΠΎΠ³Ρ€Π°ΠΌΠΈ, заобикаляйки стандартния Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΡŠΠΌ Π·Π° ΠΈΠ·Π±ΠΎΡ€ Π½Π° адрСс. ΠžΡΠΈΠ³ΡƒΡ€Π΅Π½ΠΎ Π΅ Π°Π²Ρ‚ΠΎΠΌΠ°Ρ‚ΠΈΡ‡Π½ΠΎ ΠΏΠΎΠ²Π΄ΠΈΠ³Π°Π½Π΅ Π½Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈΡ‚Π΅ интСрфСйси ΠΏΡ€ΠΈ Π²ΠΊΠ»ΡŽΡ‡Π²Π°Π½Π΅ Π½Π° Ρ€Π΅ΠΆΠΈΠΌΠ° Π·Π° автонастройка (AUTOCONF4 ΠΈ AUTOCONF6).
  • Π’ инсталатора Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° доставка Π½Π° компрСсирано ΠΈΠ·ΠΎΠ±Ρ€Π°ΠΆΠ΅Π½ΠΈΠ΅ Π½Π° ram-диск (bsd.rd) Π½Π° всички ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ°Ρ‚ ΠΏΠΎΠ΄ΠΎΠ±Π΅Π½ Ρ‚ΠΈΠΏ Π·Π°Ρ€Π΅ΠΆΠ΄Π°Π½Π΅.
  • Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½ Π΅ ΠΈΠ·Ρ…ΠΎΠ΄ Ρ‡Ρ€Π΅Π· syslog Π½Π° ΠΏΡ€Π΅Π΄ΡƒΠΏΡ€Π΅ΠΆΠ΄Π΅Π½ΠΈΠ΅ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π² printf подмяна Π½Π° Ρ„ΠΎΡ€ΠΌΠ°Ρ‚ΠΈΡ€Π°Ρ‰ΠΈ Π½ΠΈΠ·ΠΎΠ²Π΅ Β«%nΒ».
  • Π’ Π΄Π΅ΠΌΠΎΠ½Π° Π½Π° ΠΌΠ°Ρ€ΡˆΡ€ΡƒΡ‚ΠΈΠ·Π°Ρ†ΠΈΡ OpenBGPD Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Π—Π° ΠΏΠΎΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° основна информация Π·Π° RTR-сСсиитС Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΊΠΎΠΌΠ°Π½Π΄Π° Β«bgpctl show rtrΒ».
  • Π˜Π·Π²ΡŠΡ€ΡˆΠ΅Π½Π° Π΅ рСструктуризация Π½Π° ΠΊΠΎΠ΄Π° ospfd ΠΈ ospf6d с Ρ†Π΅Π» унификация с Π΄Ρ€ΡƒΠ³ΠΈ Π΄Π΅ΠΌΠΎΠ½ΠΈ Π½Π° ΠΌΠ°Ρ€ΡˆΡ€ΡƒΡ‚ΠΈΠ·Π°Ρ†ΠΈΡ ΠΈ опростяванС Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π°. НалаганС Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° ΠΌΡ€Π΅ΠΆΠΎΠ²ΠΈ интСрфСйси Π² Ρ€Π΅ΠΆΠΈΠΌ Ρ‚ΠΎΡ‡ΠΊΠ°-Ρ‚ΠΎΡ‡ΠΊΠ°.
  • ВградСният HTTP-сСрвСр httpd Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π° Π½ΠΎΠ²ΠΈ ΠΎΠΏΡ†ΠΈΠΈ Β«location (found|notfound)Β» Π·Π° ΠΏΡ€ΠΎΠ²Π΅Ρ€ΠΊΠ° Π½Π° ΡΡŠΡ‰Π΅ΡΡ‚Π²ΡƒΠ²Π°Π½Π΅Ρ‚ΠΎ Π½Π° рСсурси.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° rpki-client Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° RRDP (The RPKI Repository Delta Protocol, RFC 8182). Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΡƒΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° ΠΏΠΎΠ²Π΅Ρ‡Π΅ ΠΎΡ‚ Π΅Π΄ΠΈΠ½ URI Π² Ρ„Π°ΠΉΠ»Π° TAL.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° dig Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° RFC 8914 (Extended DNS Error) ΠΈ RFC 8976 (ZONEMD).
  • Π’ dhclient Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΡƒΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° ΠΎΠΏΡ†ΠΈΠΈ Π² Ρ„Π°ΠΉΠ»ΠΎΠ²Π΅Ρ‚Π΅ hostname.if, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°ΠΉΠΊΠΈ Ρ€Π΅Π΄ΠΎΠ²Π΅ Β«dhcpΒ».
  • Π’ Π΄Π΅ΠΌΠΎΠ½Π° snmpd Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° пълна ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΡ€Π΅ΠΎΠ±Ρ€Π°Π·ΡƒΠ²Π°Π½Π΅Ρ‚ΠΎ Trapv1 Π² Trapv2 (RFC 3584). Π’ snmpd.conf са Π΄ΠΎΠ±Π°Π²Π΅Π½ΠΈ Π½ΠΎΠ²ΠΈ ΠΊΠ»ΡŽΡ‡ΠΎΠ²ΠΈ Π΄ΡƒΠΌΠΈ read, write ΠΈ notify. Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° snmp Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° изброявания SMI.
  • Π’ DNS Ρ€Π΅Π·ΠΎΠ»Π²Π΅Ρ€Π° unwind Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° DNS64 ΠΈ ΠΏΡ€ΠΈΠ΅ΠΌΠ°Π½Π΅ Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠΈ Ρ‡Ρ€Π΅Π· TCP-ΠΏΠΎΡ€Ρ‚.
  • Π’ ΡƒΡ‚ΠΈΠ»ΠΈΡ‚Π°Ρ‚Π° ftp Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π·Π° постоянни прСнасочвания (RFC 7538) ΠΈ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅ Π½Π° Π·Π°Π³Π»Π°Π²ΠΊΠ°Ρ‚Π° If-Modified-Since ΠΏΡ€ΠΈ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅ Π½Π° запитвания ΠΏΠΎ HTTP/HTTPS.
  • Π’ OpenSMTPD Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° опция Β«-aΒ» Π·Π° ΠΈΠ·Π²ΡŠΡ€ΡˆΠ²Π°Π½Π΅ Π½Π° аутСнтикация ΠΏΡ€Π΅Π΄ΠΈ ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅Ρ‚ΠΎ Π½Π° ΡΡŠΠΎΠ±Ρ‰Π΅Π½ΠΈΠ΅. БрСдствата Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ са прСмСстСни Π½Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ°Ρ‚Π° libtls. Π’ ΡΠ»ΡƒΡˆΠ°Ρ‰ΠΈΡ‚Π΅ сокСти Π·Π° TLS Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° настройка Π½Π° няколко сСртификата, ΠΊΠΎΠΈΡ‚ΠΎ сС ΠΈΠ·Π±ΠΈΡ€Π°Ρ‚ Π² зависимост ΠΎΡ‚ ΠΈΠΌΠ΅Ρ‚ΠΎ Π΄ΠΎΠΌΠ΅ΠΉΠ½ (SNI).
  • Π’ LibreSSL Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° DTLSv1.2. Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΊΠΎΠΌΠΏΠΈΠ»ΠΈΡ€Π°Π½Π΅ само Π½Π° libtls (β€˜β€”enable-libtls-only’) Π±Π΅Π· libcrypto ΠΈ libssl.
  • ОбновСн Π΅ ΠΏΠ°ΠΊΠ΅Ρ‚ΡŠΡ‚ OpenSSH. ΠŸΠΎΠ΄Ρ€ΠΎΠ±Π΅Π½ ΠΎΠ±Π·ΠΎΡ€ Π½Π° подобрСнията ΠΌΠΎΠΆΠ΅ Π΄Π° сС Π²ΠΈΠ΄ΠΈ Ρ‚ΡƒΠΊ: OpenSSH 8.5, OpenSSH 8.6.
  • Броят Π½Π° ΠΏΠΎΡ€Ρ‚ΠΎΠ²Π΅Ρ‚Π΅ Π·Π° Π°Ρ€Ρ…ΠΈΡ‚Π΅ΠΊΡ‚ΡƒΡ€Π°Ρ‚Π° AMD64 Π΅ 11310, Π·Π° aarch64 β€” 10943, Π·Π° i386 β€” 10468. ΠœΠ΅ΠΆΠ΄Ρƒ вСрсиитС Π½Π° прилоТСнията Π² ΠΏΠΎΡ€Ρ‚ΠΎΠ²Π΅Ρ‚Π΅: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 ΠΈ ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    ОбновСни са ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½Ρ‚ΠΈΡ‚Π΅ ΠΎΡ‚ Ρ‚Ρ€Π΅Ρ‚ΠΈ страни, Π²ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈ Π² OpenBSD 6.9:

    • Графичният стСк Xenocara, Π±Π°Π·ΠΈΡ€Π°Π½ Π½Π° X.Org 7.7 с xserver 1.20.10 + ΠΏΠ°Ρ‡ΠΎΠ²Π΅, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ ΠΏΠ°Ρ‡ΠΊΠΈ)
    • GCC 4.2.1 (+ ΠΏΠ°Ρ‡ΠΎΠ²Π΅) ΠΈ 3.3.6 (+ ΠΏΠ°Ρ‡ΠΎΠ²Π΅)
    • Perl 5.32.1 (+ ΠΏΠ°Ρ‡ΠΎΠ²Π΅)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ ΠΏΠ°Ρ‡ΠΎΠ²Π΅)
    • Gdb 6.3 (+ ΠΏΠ°Ρ‡)
    • Awk 18.12.2020
    • Expat 2.2.10

К ΠΈΠ·Π»ΠΈΠ·Π°Π½Π΅Ρ‚ΠΎ Π½Π° вСрсия OpenBSD 6.9 Π΅ посвСтСна Π½ΠΎΠ²Π°Ρ‚Π° пСсСн Β«Vetera NovisΒ».

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: opennet.ru

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster