ΠΡΠ΅Π΄ΡΡΠ°Π²Π΅Π½ Π΅ Π½ΠΎΠ²ΠΈΡΡ ΡΠ²ΠΎΠ±ΠΎΠ΄Π΅Π½ ΠΊΡΠΎΡ-ΠΏΠ»Π°ΡΡΠΎΡΠΌΠ΅Π½ UNIX-ΠΏΠΎΠ΄ΠΎΠ±Π΅Π½ ΠΎΠΏΠ΅ΡΠ°ΡΠΈΠΎΠ½Π΅Π½ ΡΠΈΡΡΠ΅ΠΌΠ° OpenBSD 6.9. ΠΠΎΠ΄ΡΠ΅ΡΡΠ°Π²Π° ΡΠ΅, ΡΠ΅ ΡΠΎΠ²Π° Π΅ 50-ΠΈΡΡ Π±ΡΠΎΠΉ Π½Π° ΠΏΡΠΎΠ΅ΠΊΡΠ°, ΠΊΠΎΠΉΡΠΎ ΡΠ°Π·ΠΈ Π³ΠΎΠ΄ΠΈΠ½Π° Π½Π°Π²ΡΡΡΠ²Π° 26 Π³ΠΎΠ΄ΠΈΠ½ΠΈ. ΠΡΠΎΠ΅ΠΊΡΡΡ OpenBSD Π΅ ΠΎΡΠ½ΠΎΠ²Π°Π½ ΠΎΡ Π’Π΅ΠΎ Π΄Π΅ Π Π°Π°Π΄Ρ (Theo de Raadt) ΠΏΡΠ΅Π· 1995 Π³. ΡΠ»Π΅Π΄ ΠΊΠΎΠ½ΡΠ»ΠΈΠΊΡ Ρ ΡΠ°Π·ΡΠ°Π±ΠΎΡΡΠΈΡΠΈΡΠ΅ Π½Π° NetBSD, Π² ΡΠ΅Π·ΡΠ»ΡΠ°Ρ Π½Π° ΠΊΠΎΠΉΡΠΎ Π΄ΠΎΡΡΡΠΏΡΡ Π½Π° Π’Π΅ΠΎ Π΄ΠΎ CVS ΡΠ΅ΠΏΠΎΠ·ΠΈΡΠΎΡΠΈΡ Π½Π° NetBSD Π΅ Π±Π»ΠΎΠΊΠΈΡΠ°Π½. Π‘Π»Π΅Π΄ ΡΠΎΠ²Π° Π’Π΅ΠΎ Π΄Π΅ Π Π°Π°Π΄Ρ ΠΈ Π³ΡΡΠΏΠ° ΡΡΠΌΠΈΡΠ»Π΅Π½ΠΈΡΠΈ ΡΡΠ·Π΄Π°Π²Π°Ρ Π½Π° Π±Π°Π·Π°ΡΠ° Π½Π° Π΄ΡΡΠ²ΠΎΡΠΎ Ρ ΠΈΠ·Ρ ΠΎΠ΄Π΅Π½ ΠΊΠΎΠ΄ Π½Π° NetBSD Π½ΠΎΠ²Π° ΠΎΡΠ²ΠΎΡΠ΅Π½Π° ΠΎΠΏΠ΅ΡΠ°ΡΠΈΠΎΠ½Π½Π° ΡΠΈΡΡΠ΅ΠΌΠ°, ΡΠΈΠΉΡΠΎ ΠΎΡΠ½ΠΎΠ²Π½ΠΈ ΡΠ΅Π»ΠΈ Π·Π° ΡΠ°Π·Π²ΠΈΡΠΈΠ΅ ΡΠ° ΠΏΡΠ΅Π½ΠΎΡΠΈΠΌΠΎΡΡ (ΠΏΠΎΠ΄Π΄ΡΡΠΆΠ°Ρ ΡΠ΅ 13 Ρ Π°ΡΠ΄ΡΠ΅ΡΠ½ΠΈ ΠΏΠ»Π°ΡΡΠΎΡΠΌΠΈ), ΡΡΠ°Π½Π΄Π°ΡΡΠΈΠ·Π°ΡΠΈΡ, ΠΊΠΎΡΠ΅ΠΊΡΠ½Π° ΡΠ°Π±ΠΎΡΠ°, Π°ΠΊΡΠΈΠ²Π½Π° ΡΠΈΠ³ΡΡΠ½ΠΎΡΡ ΠΈ ΠΈΠ½ΡΠ΅Π³ΡΠΈΡΠ°Π½ΠΈ ΠΊΡΠΈΠΏΡΠΎΠ³ΡΠ°ΡΡΠΊΠΈ ΡΡΠ΅Π΄ΡΡΠ²Π°. Π Π°Π·ΠΌΠ΅ΡΡΡ Π½Π° ΠΏΡΠ»Π½ΠΈΡ ΠΈΠ½ΡΡΠ°Π»Π°ΡΠΈΠΎΠ½Π΅Π½ ISO ΠΎΠ±ΡΠ°Π· Π½Π° Π±Π°Π·ΠΎΠ²Π°ΡΠ° ΡΠΈΡΡΠ΅ΠΌΠ° OpenBSD 6.9 Π΅ 544 MB.
ΠΡΠ²Π΅Π½ ΡΠ°ΠΌΠ°ΡΠ° ΠΎΠΏΠ΅ΡΠ°ΡΠΈΠΎΠ½Π½Π° ΡΠΈΡΡΠ΅ΠΌΠ°, ΠΏΡΠΎΠ΅ΠΊΡΡΡ OpenBSD Π΅ ΠΈΠ·Π²Π΅ΡΡΠ΅Π½ ΡΡΡ ΡΠ²ΠΎΠΈΡΠ΅ ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½ΡΠΈ, ΠΊΠΎΠΈΡΠΎ ΡΠ° ΠΏΠΎΠ»ΡΡΠΈΠ»ΠΈ ΡΠ°Π·ΠΏΡΠΎΡΡΡΠ°Π½Π΅Π½ΠΈΠ΅ Π² Π΄ΡΡΠ³ΠΈ ΡΠΈΡΡΠ΅ΠΌΠΈ ΠΈ ΡΠ΅ Π΄ΠΎΠΊΠ°Π·Π°Π»ΠΈ ΠΊΠ°ΡΠΎ Π΅Π΄Π½ΠΈ ΠΎΡ Π½Π°ΠΉ-ΡΠΈΠ³ΡΡΠ½ΠΈΡΠ΅ ΠΈ ΠΊΠ°ΡΠ΅ΡΡΠ²Π΅Π½ΠΈ ΡΠ΅ΡΠ΅Π½ΠΈΡ. Π‘ΡΠ΅Π΄ ΡΡΡ ΡΠ°: LibreSSL (ΡΠΎΡΠΊ Π½Π° OpenSSL), OpenSSH, ΠΏΠ°ΠΊΠ΅ΡΠ½ΠΈΡΡ ΡΠΈΠ»ΡΡΡ PF, Π΄Π΅ΠΌΠΎΠ½ΠΈΡΠ΅ Π·Π° ΠΌΠ°ΡΡΡΡΡΠΈΠ·Π°ΡΠΈΡ OpenBGPD ΠΈ OpenOSPFD, NTP-ΡΡΡΠ²ΡΡΡΡ OpenNTPD, ΠΏΠΎΡΠ΅Π½ΡΠΊΠΈΡΡ ΡΡΡΠ²ΡΡ OpenSMTPD, ΠΌΡΠ»ΡΠΈΠΏΠ»Π΅ΠΊΡΠΎΡΡΡ Π½Π° ΡΠ΅ΠΊΡΡΠΎΠ² ΡΠ΅ΡΠΌΠΈΠ½Π°Π» (Π°Π½Π°Π»ΠΎΠ³ Π½Π° GNU screen) tmux, Π΄Π΅ΠΌΠΎΠ½ΡΡ identd Ρ ΡΠ΅Π°Π»ΠΈΠ·Π°ΡΠΈΡ Π½Π° ΠΏΡΠΎΡΠΎΠΊΠΎΠ»Π° IDENT, BSDL-Π°Π»ΡΠ΅ΡΠ½Π°ΡΠΈΠ²Π° Π½Π° ΠΏΠ°ΠΊΠ΅ΡΠ° GNU groff β mandoc, ΠΏΡΠΎΡΠΎΠΊΠΎΠ» Π·Π° ΠΎΡΠ³Π°Π½ΠΈΠ·ΠΈΡΠ°Π½Π΅ Π½Π° ΠΎΡΠΊΠ°Π·ΠΎΡΡΡΠΎΠΉΡΠΈΠ²ΠΈ ΡΠΈΡΡΠ΅ΠΌΠΈ CARP (Common Address Redundancy Protocol), Π»Π΅ΠΊ http-ΡΡΡΠ²ΡΡ, ΡΡΠΈΠ»ΠΈΡΠ° Π·Π° ΡΠΈΠ½Ρ ΡΠΎΠ½ΠΈΠ·Π°ΡΠΈΡ Π½Π° ΡΠ°ΠΉΠ»ΠΎΠ²Π΅ OpenRSYNC.
ΠΡΠ½ΠΎΠ²Π½ΠΈ ΠΏΠΎΠ΄ΠΎΠ±ΡΠ΅Π½ΠΈΡ:
- Π Π΄ΡΠ°ΠΉΠ²Π΅ΡΠ° softraid Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ ΡΠ΅ΠΆΠΈΠΌ RAID1C Ρ ΡΠ΅Π°Π»ΠΈΠ·Π°ΡΠΈΡ Π½Π° ΡΠΎΡΡΡΠ΅ΡΠ΅Π½ RAID1 Ρ ΠΊΡΠΈΠΏΡΠΈΡΠ°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ.
- ΠΠΊΠ»ΡΡΠ΅Π½ΠΈ ΡΠ° Π΄Π²Π° Π½ΠΎΠ²ΠΈ ΡΠΎΠ½ΠΎΠ²ΠΈ ΠΏΡΠΎΡΠ΅ΡΠ° β dhcpleased ΠΈ resolvd, ΠΊΠΎΠΈΡΠΎ ΡΠ°Π±ΠΎΡΡΡ Π·Π°Π΅Π΄Π½ΠΎ Ρ slaacd ΠΈ unwind Π·Π° Π°Π²ΡΠΎΠΌΠ°ΡΠΈΡΠ½Π° Π½Π°ΡΡΡΠΎΠΉΠΊΠ° Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈΡΠ΅ ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡΠΈ ΠΈ ΠΎΠΏΡΠ΅Π΄Π΅Π»ΡΠ½Π΅ Π½Π° ΠΈΠΌΠ΅Π½Π° Π² DNS. Π dhcpleased Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ ΠΏΡΠΎΡΠΎΠΊΠΎΠ»ΡΡ DHCP Π·Π° ΠΏΠΎΠ»ΡΡΠ°Π²Π°Π½Π΅ Π½Π° IP Π°Π΄ΡΠ΅ΡΠΈ, Π° Π² resolvd Π΅ ΠΎΡΠΈΠ³ΡΡΠ΅Π½ΠΎ ΡΠΏΡΠ°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° ΡΡΠ΄ΡΡΠΆΠ°Π½ΠΈΠ΅ΡΠΎ Π½Π° resolv.conf Π½Π° Π±Π°Π·Π°ΡΠ° Π½Π° Π΄Π°Π½Π½ΠΈ Π·Π° ΠΈΠΌΠ΅Π½Π° Π½Π° ΡΡΡΠ²ΡΡΠΈ, ΠΏΠΎΠ»ΡΡΠ΅Π½ΠΈ ΠΎΡ dhcpleased, slaacd ΠΈ Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈ ΠΊΠ°ΡΠΎ umb.
- ΠΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π½Π°ΡΠ°Π»Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΡΡΡΡΠΎΠΉΡΡΠ²Π° Apple Ρ ΠΏΡΠΎΡΠ΅ΡΠΎΡ M1. ΠΠΊΠ»ΡΡΠΈΡΠ΅Π»Π½ΠΎ Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ΠΎ ΡΠ°Π·ΠΏΠΎΠ·Π½Π°Π²Π°Π½Π΅ Π½Π° arm64 ΡΠ΄ΡΠ° Apple Icestorm/Firestorm ΠΈ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° Π±Π΅Π·ΠΆΠΈΡΠ½ΠΈ ΡΠΈΠΏΠΎΠ²Π΅ BCM4378, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΈ Π² SoC Apple M1.
- ΠΠΎΠ΄ΠΎΠ±ΡΠ΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ° Π½Π° ΠΏΠ»Π°ΡΡΠΎΡΠΌΠ°ΡΠ° powerpc64, ΡΠ°Π·Π²ΠΈΠ²Π°Π½Π° Π·Π° 64-Π±ΠΈΡΠΎΠ²ΠΈ ΡΠΈΡΡΠ΅ΠΌΠΈ Π½Π° Π±Π°Π·Π°ΡΠ° Π½Π° ΠΏΡΠΎΡΠ΅ΡΠΎΡΠΈ POWER8 ΠΈ POWER9. Π ΡΡΠ°Π²Π½Π΅Π½ΠΈΠ΅ Ρ ΠΏΡΠ΅Π΄ΠΈΡΠ½ΠΎΡΠΎ ΠΈΠ·Π΄Π°Π½ΠΈΠ΅ Π·Π° powerpc64 Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΌΠ΅Ρ Π°Π½ΠΈΠ·ΠΌΠ° Π·Π° Π·Π°ΡΠΈΡΠ° RETGUARD, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π΄ΡΠ°ΠΉΠ²Π΅Ρ astfb Π·Π° ΡΡΠ΅ΠΉΠΌΠ±ΡΡΠ΅ΡΠ° Aspeed BMC, ΡΠ΅ΡΠ΅Π½ΠΈ ΡΠ° ΠΏΡΠΎΠ±Π»Π΅ΠΌΠΈΡΠ΅ Ρ ΡΠ°Π±ΠΎΡΠ°ΡΠ° Π½Π° Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈΡΠ΅ radeondrm ΠΈ amdgpu Π½Π° ΡΠΈΡΡΠ΅ΠΌΠΈ Ρ GPU AMD, Π² ΡΠ±ΠΎΡΠΊΠΈΡΠ΅ Π½Π° ΡΠ΄ΡΠΎΡΠΎ Π·Π° ram-Π΄ΠΈΡΠΊ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡΡΠ° Π·Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΎ Π·Π°ΡΠ΅ΠΆΠ΄Π°Π½Π΅, Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° Π΅Π½Π΅ΡΠ³ΠΈΠΉΠ½ΠΈ ΡΠ΅ΠΆΠΈΠΌΠΈ Π·Π° CPU POWER9, Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° ΠΈΠ·ΠΊΠ»ΡΡΠ΅Π½ΠΈΡ, Π³Π΅Π½Π΅ΡΠΈΡΠ°Π½ΠΈ ΠΏΡΠΈ ΠΎΠΏΠ΅ΡΠ°ΡΠΈΠΈ Ρ ΠΏΠ»Π°Π²Π°ΡΠ° Π·Π°ΠΏΠ΅ΡΠ°Ρ, ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° IPMI Π·Π° ΡΠΈΡΡΠ΅ΠΌΠΈ PowerNV.
- ΠΠ° ΠΏΠ»Π°ΡΡΠΎΡΠΌΠΈΡΠ΅ ARM64 Π΅ ΠΎΡΠΈΠ³ΡΡΠ΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° CPU Cortex-A78AE, Cortex-X1 ΠΈ Neoverse V1, ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ΠΈ ΡΠ° ΠΎΠΏΡΠΈΠΌΠΈΠ·ΠΈΡΠ°Π½ΠΈ Π·Π° ARM64 Π²Π°ΡΠΈΠ°Π½ΡΠΈ Π½Π° ΠΈΠ·Π²ΠΈΠΊΠ²Π°Π½ΠΈΡΡΠ° copyin, copyout ΠΈ kcopy, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ Π΄ΡΠ°ΠΉΠ²Π΅Ρ cryptox Π·Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΊΡΠΈΠΏΡΠΎΡΠ°Π·ΡΠΈΡΠ΅Π½ΠΈΡΡΠ° ARMv8, ΠΊΠ°ΠΊΡΠΎ ΠΈ Π΄ΡΠ°ΠΉΠ²Π΅Ρ smmu Π·Π° RM System MMU Ρ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° Guard Page. ΠΠΎΠ΄ΠΎΠ±ΡΠ΅Π½a Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ° Π½Π° ΡΡΡΡΠΎΠΉΡΡΠ²Π°ΡΠ° Raspberry Pi, Rock Pi N10, NanoPi ΠΈ Pinebook Pro.
- Π Π΄ΡΠ°ΠΉΠ²Π΅ΡΠ° video Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½ sysctl-ΠΏΠ°ΡΠ°ΠΌΠ΅ΡΡΡ kern.video.record, ΠΊΠΎΠΉΡΠΎ ΠΏΠΎΠ΄ΠΎΠ±Π½ΠΎ Π½Π° kern.audio.record ΡΠΏΡΠ°Π²Π»ΡΠ²Π° Π°ΠΊΡΠΈΠ²ΠΈΡΠ°Π½Π΅ΡΠΎ Π½Π° ΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ΡΠΎ Π½Π° ΠΏΡΠ°Π·Π΅Π½ ΠΎΠ±ΡΠ°Π· ΠΏΡΠΈ ΠΎΠΏΠΈΡΠΈ Π·Π° Π·Π°ΠΏΠΈΡ Π½Π° Π²ΠΈΠ΄Π΅ΠΎ (Π·Π° ΡΠ°Π·ΡΠ΅ΡΠ°Π²Π°Π½Π΅ Π½Π° Π·Π°ΠΏΠΈΡΠ° Π΅ Π½Π΅ΠΎΠ±Ρ ΠΎΠ΄ΠΈΠΌΠΎ Π΄Π° ΡΠ΅ ΠΏΡΠΎΠΌΠ΅Π½ΠΈ ΡΡΠΎΠΉΠ½ΠΎΡΡΡΠ° Π½Π° 1). ΠΠ° ΠΏΡΠΎΡΠ΅ΡΠΈΡΠ΅ Π΅ ΡΠ°Π·ΡΠ΅ΡΠ΅Π½ΠΎ ΠΌΠ½ΠΎΠ³ΠΎΠΊΡΠ°ΡΠ½ΠΎ ΠΎΡΠ²Π°ΡΡΠ½Π΅ Π½Π° ΡΡΡΡΠΎΠΉΡΡΠ²ΠΎΡΠΎ video (ΡΠ΅ΡΠ°Π²Π° ΠΏΡΠΎΠ±Π»Π΅ΠΌΠΈΡΠ΅ Ρ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ΡΠΎ Π½Π° ΡΠ΅Π±ΠΊΠ°ΠΌΠ΅ΡΠ°ΡΠ° Π² Firefox ΠΈ BigBlueButton).
- ΠΠΎΠ±Π°Π²Π΅Π½ΠΈ ΡΠ° ΡΠΎΡΠΊΠΈ Π·Π° ΠΏΡΠΎΡΠ»Π΅Π΄ΡΠ²Π°Π½Π΅ Π½Π° ΠΈΠ·Π²ΠΈΠΊΠ²Π°Π½ΠΈΡΡΠ° malloc ΠΈ free, ΠΏΠΎΠ·Π²ΠΎΠ»ΡΠ²Π°ΡΠΈ ΡΡΠ΅Π· dt ΠΈ btrace Π΄Π° ΡΠ΅ ΠΏΡΠΎΡΠ»Π΅Π΄ΡΠ²Π° ΡΠ²ΡΡΠ·Π°Π½Π°ΡΠ° Ρ ΡΠ°Π·ΠΏΡΠ΅Π΄Π΅Π»Π΅Π½ΠΈΠ΅ΡΠΎ Π½Π° ΠΏΠ°ΠΌΠ΅ΡΡΠ° Π°ΠΊΡΠΈΠ²Π½ΠΎΡΡ. Π btrace Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΎΠΏΡΠΈΡ β-nβ Π·Π° ΠΏΠ°ΡΡΠΈΠ½Π³ Π½Π° ΠΏΡΠΎΠ³ΡΠ°ΠΌΠ°ΡΠ° Π±Π΅Π· ΠΈΠ·Π²ΡΡΡΠ²Π°Π½Π΅ Π½Π° ΠΊΠ°ΠΊΠ²ΠΈΡΠΎ ΠΈ Π΄Π° Π±ΠΈΠ»ΠΎ Π΄Π΅ΠΉΡΡΠ²ΠΈΡ.
- ΠΠΎΠ΄ΠΎΠ±ΡΠ΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ° Π½Π° ΠΌΠ½ΠΎΠ³ΠΎΠΏΡΠΎΡΠ΅ΡΠΎΡΠ½ΠΈ ΡΠΈΡΡΠ΅ΠΌΠΈ (SMP). ΠΡ ΠΎΠ±ΡΠ°ΡΠ° Π±Π»ΠΎΠΊΠΈΡΠΎΠ²ΠΊΠ° Π½Π° ΡΠ΄ΡΠΎΡΠΎ Π΅ ΠΈΠ·Π²Π΅Π΄Π΅Π½Π° ΡΠ΅Π°Π»ΠΈΠ·Π°ΡΠΈΡΡΠ° Π½Π° UNIX-ΡΠΎΠΊΠ΅ΡΠΈΡΠ΅, Π΄ΠΎΠ±Π°Π²Π΅Π½ Π΅ ΠΎΠ±Ρ mutex Π·Π° ΡΠ΅ΡΠΈΠ°Π»ΠΈΠ·Π°ΡΠΈΡ Π½Π° ΠΎΠΏΠ΅ΡΠ°ΡΠΈΠΈΡΠ΅ Ρ msgbuf, ΠΏΡΠ΅Π²Π΅Π΄Π΅Π½ Π΅ Π² mp-safe ΡΠ΅ΠΆΠΈΠΌ ΠΈΠ·Π²ΠΈΠΊΠ²Π°Π½Π΅ΡΠΎ Π½Π° uvm_pagealloc, ΠΏΡΠ΅ΠΌΠ°Ρ Π½Π°ΡΠΈ ΡΠ° Π±Π»ΠΎΠΊΠΈΡΠΎΠ²ΠΊΠΈΡΠ΅ ΠΏΡΠΈ ΠΈΠ·Π²ΠΈΠΊΠ²Π°Π½ΠΈΡΡΠ° getppid ΠΈ sendsyslog.
- ΠΠΎΡΠΈΠ³ΠΈΡΠ°Π½ΠΈ ΡΠ° ΠΏΡΠΎΠ±Π»Π΅ΠΌΠΈΡΠ΅ Π² ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½ΡΠΈΡΠ΅ DRM (Direct Rendering Manager), Π² ΡΠΎΠ²Π° ΡΠΈΡΠ»ΠΎ ΡΠ° ΠΎΡΡΡΡΠ°Π½Π΅Π½ΠΈ ΡΡΠΈΠ²ΠΎΠ²Π΅ΡΠ΅ Π² Π΄ΡΠ°ΠΉΠ²Π΅ΡΠ° radeondrm Π½Π° ΡΠΈΡΡΠ΅ΠΌΠΈΡΠ΅ Powerbook5/6 ΠΈ RV350, ΡΡΡΠ°Π½ΠΎΠ²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° DRI3 Π² Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈΡΠ΅ amdgpu ΠΈ ati, Π·Π° ΡΡΠ²ΠΌΠ΅ΡΡΠΈΠΌΠΎΡΡ Ρ Linux Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ΠΎ ΡΡΠ·Π΄Π°Π²Π°Π½Π΅ΡΠΎ Π½Π° ΡΡΡΡΠΎΠΉΡΡΠ²Π° Π² ΠΊΠ°ΡΠ°Π»ΠΎΠ³Π° /dev/dri/.
- ΠΠ½Π΅ΡΠ΅Π½ΠΈ ΡΠ° ΠΏΠΎΠ΄ΠΎΠ±ΡΠ΅Π½ΠΈΡ Π² Ρ ΠΈΠΏΠ΅ΡΠ²ΠΈΠ·ΠΎΡΠ° VMM. Π Π±Π΅ΠΊΠ΅Π½Π΄Π° Π·Π° ΡΠΏΡΠ°Π²Π»Π΅Π½ΠΈΠ΅ Π½Π° Π²ΠΈΡΡΡΠ°Π»Π½ΠΈΡΠ΅ ΠΌΠ°ΡΠΈΠ½ΠΈ vmd Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° Π·Π°ΡΠ΅ΠΆΠ΄Π°Π½Π΅ Π½Π° ΠΊΠΎΠΌΠΏΡΠ΅ΡΠΈΡΠ°Π½ΠΈ RAM-Π΄ΠΈΡΠΊΠΎΠ²Π΅.
- ΠΠ½Π΅ΡΠ΅Π½ΠΈ ΡΠ° ΠΏΠΎΠ΄ΠΎΠ±ΡΠ΅Π½ΠΈΡ Π² Π·Π²ΡΠΊΠΎΠ²Π°ΡΠ° ΠΏΠΎΠ΄ΡΠΈΡΡΠ΅ΠΌΠ°. ΠΡΠ΅Π΄ΠΎΡΡΠ°Π²Π΅Π½Π° Π΅ Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΠΎΡΠ΄Π΅Π»Π½ΠΎ Π·Π°ΠΊΡΠ΅ΠΏΠ²Π°Π½Π΅ Π½Π° Π·Π²ΡΠΊΠΎΠ²ΠΈΡΠ΅ ΡΡΡΡΠΎΠΉΡΡΠ²Π° sndio ΡΠ°ΠΌΠΎ Π·Π° Π²ΡΠ·ΠΏΡΠΎΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ ΠΈ ΡΠ°ΠΌΠΎ Π·Π° Π·Π°ΠΏΠΈΡ. Π sndiod Π΅ Π·Π°Π΄Π΅ΠΉΡΡΠ²Π°Π½ Π½ΠΈΡΠΊΠΎΡΠ΅ΡΡΠΎΡΠ΅Π½ ΡΠΈΠ»ΡΡΡ Ρ ΠΊΡΠ°ΠΉΠ½Π° ΠΈΠΌΠΏΡΠ»ΡΠ½Π° Ρ Π°ΡΠ°ΠΊΡΠ΅ΡΠΈΡΡΠΈΠΊΠ° (ΠΠΠ₯-ΡΠΈΠ»ΡΡ) ΠΎΡΠΌΠΈΡ ΡΠ΅Π΄, ΠΊΠΎΠΉΡΠΎ ΠΏΠΎΠ·Π²ΠΎΠ»ΡΠ²Π° Π΄Π° ΡΠ΅ ΠΎΡΡΡΡΠ°Π½ΡΡ ΡΡΠΌΠΎΠ²Π΅ΡΠ΅ ΠΎΡ Π½Π°Π»ΠΎΠΆΠ΅Π½ΠΈΡΠ΅ ΡΠΏΠ΅ΠΊΡΡΠΈ ΠΏΡΠΈ ΡΠ΅ΡΠ΅ΠΌΠΏΠ»ΠΈΡΠ°Π½Π΅. ΠΠΎ ΠΏΠΎΠ΄ΡΠ°Π·Π±ΠΈΡΠ°Π½Π΅ ΡΡΠ½ΠΊΡΠΈΡΡΠ° Π·Π° Π°Π²ΡΠΎΠΌΠ°ΡΠΈΡΠ½ΠΎ Π½Π°ΠΌΠ°Π»ΡΠ²Π°Π½Π΅ Π½Π° Π·Π²ΡΠΊΠ°, ΠΊΠΎΠ³Π°ΡΠΎ Π½ΠΎΠ²Π° ΠΏΡΠΎΠ³ΡΠ°ΠΌΠ° Π·Π°ΠΏΠΎΡΠ½Π΅ Π²ΡΠ·ΠΏΡΠΎΠΈΠ·Π²Π΅ΠΆΠ΄Π°Π½Π΅ (autovolume), Π΅ ΠΈΠ·ΠΊΠ»ΡΡΠ΅Π½Π°, Π° ΡΡΠΎΠΉΠ½ΠΎΡΡΡΠ° ΠΏΠΎ ΠΏΠΎΠ΄ΡΠ°Π·Π±ΠΈΡΠ°Π½Π΅ Π·Π° Π½ΠΈΠ²ΠΎΡΠΎ Π½Π° Π·Π²ΡΠΊΠ° Π΅ 127. Π Π°Π·ΡΠ΅ΡΠ΅Π½ΠΎ Π΅ ΠΌΠΈΠΊΡΠΈΡΠ°Π½Π΅ Π½Π° Π·Π²ΡΠΊΠ° ΠΎΡ Π°Π»ΡΠ΅ΡΠ½Π°ΡΠΈΠ²Π½ΠΈ ΡΡΡΡΠΎΠΉΡΡΠ²Π°, ΡΠ°Π·Π»ΠΈΡΠ½ΠΈ ΠΏΠΎ Π½ΠΈΠ²ΠΎΡΠΎ Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠ°Π½Π°ΡΠ° ΡΡΠ½ΠΊΡΠΈΠΎΠ½Π°Π»Π½ΠΎΡΡ Π² sndiod.
- ΠΠΎ ΠΏΠΎΠ΄ΡΠ°Π·Π±ΠΈΡΠ°Π½Π΅ Π΅ Π°ΠΊΡΠΈΠ²ΠΈΡΠ°Π½ΠΎ ΠΈΠ·Π³ΡΠ°ΠΆΠ΄Π°Π½Π΅ΡΠΎ ΠΈ ΠΈΠ½ΡΡΠ°Π»Π°ΡΠΈΡΡΠ° Π½Π° ΠΎΡΠ»Π°Π΄ΡΠΈΠΊΠ° LLDB.
- ΠΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΎΠ±ΡΠ°Π±ΠΎΡΡΠΈΠΊΠ° logger Π² rcctl, rc.subr ΠΈ rc.d, ΠΊΠΎΠ΅ΡΠΎ ΠΏΠΎΠ·Π²ΠΎΠ»ΡΠ²Π° ΠΎΡΠ³Π°Π½ΠΈΠ·ΠΈΡΠ°Π½Π΅ Π½Π° Π»ΠΎΠ³ΠΎΠ²Π΅ΡΠ΅ ΠΎΡ ΡΠΎΠ½ΠΎΠ²ΠΈΡΠ΅ ΠΏΡΠΎΡΠ΅ΡΠΈ, ΠΈΠ·ΠΏΡΠ°ΡΠ°ΡΠΈ Π΄Π°Π½Π½ΠΈ Π² stdout/stderr.
- ΠΠ° ΡΡΡΠΏΠ°Π΄ΠΎΠ²Π΅ Π΅ ΠΏΡΠ΅Π΄ΠΎΡΡΠ°Π²Π΅Π½Π° Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° Π½Π°ΡΡΡΠΎΠΉΠΊΠ° Π½Π° ΠΏΠΎΠ΄ΡΠ΅Π΄Π±Π°ΡΠ° Π½Π° Π±ΡΡΠΎΠ½ΠΈΡΠ΅ ΡΡΠ΅Π· wsconsctl. Π wscons Π΅ ΠΏΠΎΠ΄ΠΎΠ±ΡΠ΅Π½Π° ΠΎΠ±ΡΠ°Π±ΠΎΡΠΊΠ°ΡΠ° Π½Π° Π΅Π΄Π½ΠΎΠ²ΡΠ΅ΠΌΠ΅Π½Π½ΠΈ Π΄ΠΎΠΊΠΎΡΠ²Π°Π½ΠΈΡ.
- ΠΠ° ARM64 ΡΡΡΡΠΎΠΉΡΡΠ²Π° Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° APM Π·Π° ΠΏΠΎΠ»ΡΡΠ°Π²Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ Π·Π° ΠΊΠΎΠ½ΡΡΠΌΠ°ΡΠΈΡ Π½Π° Π΅Π½Π΅ΡΠ³ΠΈΡ ΠΈ Π·Π°ΡΡΠ΄ Π½Π° Π±Π°ΡΠ΅ΡΠΈΡΡΠ°. ΠΠ° ΠΎΠ³ΡΠ°Π½ΠΈΡΠ°Π²Π°Π½Π΅ Π½Π° Π΄ΠΎΡΡΡΠΏΠ° Π½Π° ΠΏΡΠΎΡΠ΅ΡΠ° apmd Π΄ΠΎ ΡΠ°ΠΉΠ»ΠΎΠ²Π°ΡΠ° ΡΠΈΡΡΠ΅ΠΌΠ° Π΅ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ΠΎ ΠΏΠΎΠ²ΠΈΠΊΠ²Π°Π½Π΅ΡΠΎ unveil.
- Π Π°Π·ΡΠΈΡΠ΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ° Π½Π° Ρ Π°ΡΠ΄ΡΠ΅Ρ. ΠΠΎΠ±Π°Π²Π΅Π½ΠΈ ΡΠ° Π½ΠΎΠ²ΠΈ Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈ acpige (Π·Π° ΠΎΠ±ΡΠ°Π±ΠΎΡΠΊΠ° Π½Π° ACPI ΡΡΠ±ΠΈΡΠΈΡ, ΠΊΠ°ΡΠΎ Π½Π°ΡΠΈΡΠΊΠ°Π½Π΅ Π½Π° Π±ΡΡΠΎΠ½Π° Π·Π° Π·Π°Ρ ΡΠ°Π½Π²Π°Π½Π΅), pchgpio (Π·Π° GPIO ΠΊΠΎΠ½ΡΡΠΎΠ»Π΅ΡΠΈ, ΠΊΠΎΠΈΡΠΎ ΡΠ΅ Π½Π°ΠΌΠΈΡΠ°Ρ Π½Π° ΡΡΠ²ΡΠ΅ΠΌΠ΅Π½Π½ΠΈΡΠ΅ Intel PCH), ujoy (Π·Π° ΠΈΠ³ΡΠΎΠ²ΠΈ ΠΊΠΎΠ½ΡΡΠΎΠ»Π΅ΡΠΈ), uhidpp (Π·Π° Logitech HID++ ΡΡΡΡΠΎΠΉΡΡΠ²Π°). ΠΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° AMD Vi ΠΈ Intel VTD IOMMU ΡΠ°Π·ΡΠΈΡΠ΅Π½ΠΈΡ Π·Π° ΠΈΠ·ΠΎΠ»Π°ΡΠΈΡ Π½Π° PCI ΡΡΡΡΠΎΠΉΡΡΠ²Π° ΠΈ Π±Π»ΠΎΠΊΠΈΡΠ°Π½Π΅ Π½Π° Π½Π΅ΠΏΡΠ°Π²ΠΈΠ»Π΅Π½ Π΄ΠΎΡΡΡΠΏ Π΄ΠΎ ΠΏΠ°ΠΌΠ΅ΡΡΠ°. ΠΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΊΠΎΠΌΠΏΡΡΡΠΈ Lynloong LM9002/9003 ΠΈ LM9013. Π Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈΡΠ΅ pcamux ΠΈ imxiic Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ACPI.
- ΠΠΎΠ΄ΠΎΠ±ΡΠ΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ° Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈ Π°Π΄Π°ΠΏΡΠ΅ΡΠΈ: mvpp (SFP+ ΠΈ 10G Π·Π° Marvel Armada Ethernet), mvneta (1000base-x ΠΈ 2500base-x), mvsw (Marvel SOHO ΠΊΠΎΠΌΡΡΠ°ΡΠΎΡΠΈ), rge (ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° Wake on LAN), Netgear ProSecure UTM25. ΠΠ° Π±Π΅Π·ΠΆΠΈΡΠ½ΠΈΡΠ΅ Π΄ΡΠ°ΠΉΠ²Π΅ΡΠΈ iwm, iwn ΠΈ athn Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° RA (802.11n Tx Rate Adaptation). Π Π±Π΅Π·ΠΆΠΈΡΠ½ΠΈΡ ΡΡΠ΅ΠΊ Π΅ ΠΎΡΠΈΠ³ΡΡΠ΅Π½ Π°Π²ΡΠΎΠΌΠ°ΡΠΈΡΠ΅Π½ ΠΈΠ·Π±ΠΎΡ Π½Π° ΡΠ΅ΠΆΠΈΠΌΠΈ 11a/b/g/n/ac ΠΏΡΠΈ ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ² ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡ Π² ΡΠ΅ΠΆΠΈΠΌ ΡΠΎΡΠΊΠ° Π·Π° Π΄ΠΎΡΡΡΠΏ.
- Π ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈΡ ΡΡΠ΅ΠΊ Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ Π΄ΡΠ°ΠΉΠ²Π΅Ρ veb (Virtual Ethernet Bridge). Π Π΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π΅ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΌΠΎΠ½ΠΈΡΠΎΡΠΈΠ½Π³, ΠΏΡΠΈ ΠΊΠΎΡΡΠΎ ΠΏΠ°ΠΊΠ΅ΡΠΈΡΠ΅, ΠΈΠ΄Π²Π°ΡΠΈ Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈΡ ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡ, Π½Π΅ ΡΠ΅ ΠΏΡΠ΅Π΄Π°Π²Π°Ρ Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈΡ ΡΡΠ΅ΠΊ Π·Π° ΠΎΠ±ΡΠ°Π±ΠΎΡΠΊΠ°, Π½ΠΎ ΠΌΠΎΠ³Π°Ρ Π΄Π° ΡΠ΅ ΠΏΡΠΈΠ»Π°Π³Π°Ρ ΠΌΠ΅Ρ Π°Π½ΠΈΠ·ΠΌΠΈ Π·Π° Π°Π½Π°Π»ΠΈΠ· Π½Π° ΡΡΠ°ΡΠΈΠΊΠ°, ΠΊΠ°ΡΠΎ BPF. ΠΠΎΠ±Π°Π²Π΅Π½ Π΅ Π½ΠΎΠ² ΡΠΈΠΏ ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈ ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡΠΈ β etherbridge. ΠΡΠΈΠ³ΡΡΠ΅Π½Π° Π΅ Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡΡΠ° (ΠΊΠΎΠΌΠ°Π½Π΄Π° route sourceaddr) Π·Π° ΠΏΡΠ΅Π½Π°ΠΏΠΈΡΠ²Π°Π½Π΅ Π½Π° ΠΈΠ·Ρ ΠΎΠ΄ΡΡΠΈΡ IP Π°Π΄ΡΠ΅ΡΠΈ Π°Π΄ΡΠ΅Ρ Π·Π° ΠΏΡΠΎΠ³ΡΠ°ΠΌΠΈ, Π·Π°ΠΎΠ±ΠΈΠΊΠ°Π»ΡΠΉΠΊΠΈ ΡΡΠ°Π½Π΄Π°ΡΡΠ½ΠΈΡ Π°Π»Π³ΠΎΡΠΈΡΡΠΌ Π·Π° ΠΈΠ·Π±ΠΎΡ Π½Π° Π°Π΄ΡΠ΅Ρ. ΠΡΠΈΠ³ΡΡΠ΅Π½ΠΎ Π΅ Π°Π²ΡΠΎΠΌΠ°ΡΠΈΡΠ½ΠΎ ΠΏΠΎΠ²Π΄ΠΈΠ³Π°Π½Π΅ Π½Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈΡΠ΅ ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡΠΈ ΠΏΡΠΈ Π²ΠΊΠ»ΡΡΠ²Π°Π½Π΅ Π½Π° ΡΠ΅ΠΆΠΈΠΌΠ° Π·Π° Π°Π²ΡΠΎΠ½Π°ΡΡΡΠΎΠΉΠΊΠ° (AUTOCONF4 ΠΈ AUTOCONF6).
- Π ΠΈΠ½ΡΡΠ°Π»Π°ΡΠΎΡΠ° Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π΄ΠΎΡΡΠ°Π²ΠΊΠ° Π½Π° ΠΊΠΎΠΌΠΏΡΠ΅ΡΠΈΡΠ°Π½ΠΎ ΠΈΠ·ΠΎΠ±ΡΠ°ΠΆΠ΅Π½ΠΈΠ΅ Π½Π° ram-Π΄ΠΈΡΠΊ (bsd.rd) Π½Π° Π²ΡΠΈΡΠΊΠΈ ΠΏΠ»Π°ΡΡΠΎΡΠΌΠΈ, ΠΊΠΎΠΈΡΠΎ ΠΏΠΎΠ΄Π΄ΡΡΠΆΠ°Ρ ΠΏΠΎΠ΄ΠΎΠ±Π΅Π½ ΡΠΈΠΏ Π·Π°ΡΠ΅ΠΆΠ΄Π°Π½Π΅.
- Π Π΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½ Π΅ ΠΈΠ·Ρ ΠΎΠ΄ ΡΡΠ΅Π· syslog Π½Π° ΠΏΡΠ΅Π΄ΡΠΏΡΠ΅ΠΆΠ΄Π΅Π½ΠΈΠ΅ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π² printf ΠΏΠΎΠ΄ΠΌΡΠ½Π° Π½Π° ΡΠΎΡΠΌΠ°ΡΠΈΡΠ°ΡΠΈ Π½ΠΈΠ·ΠΎΠ²Π΅ Β«%nΒ».
- Π Π΄Π΅ΠΌΠΎΠ½Π° Π½Π° ΠΌΠ°ΡΡΡΡΡΠΈΠ·Π°ΡΠΈΡ OpenBGPD Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° ΠΏΡΠΎΡΠΎΠΊΠΎΠ»Π° RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). ΠΠ° ΠΏΠΎΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° ΠΎΡΠ½ΠΎΠ²Π½Π° ΠΈΠ½ΡΠΎΡΠΌΠ°ΡΠΈΡ Π·Π° RTR-ΡΠ΅ΡΠΈΠΈΡΠ΅ Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΊΠΎΠΌΠ°Π½Π΄Π° Β«bgpctl show rtrΒ».
- ΠΠ·Π²ΡΡΡΠ΅Π½Π° Π΅ ΡΠ΅ΡΡΡΡΠΊΡΡΡΠΈΠ·Π°ΡΠΈΡ Π½Π° ΠΊΠΎΠ΄Π° ospfd ΠΈ ospf6d Ρ ΡΠ΅Π» ΡΠ½ΠΈΡΠΈΠΊΠ°ΡΠΈΡ Ρ Π΄ΡΡΠ³ΠΈ Π΄Π΅ΠΌΠΎΠ½ΠΈ Π½Π° ΠΌΠ°ΡΡΡΡΡΠΈΠ·Π°ΡΠΈΡ ΠΈ ΠΎΠΏΡΠΎΡΡΡΠ²Π°Π½Π΅ Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ°ΡΠ°. ΠΠ°Π»Π°Π³Π°Π½Π΅ Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° ΠΌΡΠ΅ΠΆΠΎΠ²ΠΈ ΠΈΠ½ΡΠ΅ΡΡΠ΅ΠΉΡΠΈ Π² ΡΠ΅ΠΆΠΈΠΌ ΡΠΎΡΠΊΠ°-ΡΠΎΡΠΊΠ°.
- ΠΠ³ΡΠ°Π΄Π΅Π½ΠΈΡΡ HTTP-ΡΠ΅ΡΠ²Π΅Ρ httpd ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ° Π½ΠΎΠ²ΠΈ ΠΎΠΏΡΠΈΠΈ Β«location (found|notfound)Β» Π·Π° ΠΏΡΠΎΠ²Π΅ΡΠΊΠ° Π½Π° ΡΡΡΠ΅ΡΡΠ²ΡΠ²Π°Π½Π΅ΡΠΎ Π½Π° ΡΠ΅ΡΡΡΡΠΈ.
- Π ΡΡΠΈΠ»ΠΈΡΠ°ΡΠ° rpki-client Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΏΡΠΎΡΠΎΠΊΠΎΠ»Π° RRDP (The RPKI Repository Delta Protocol, RFC 8182). Π Π΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π΅ Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΡΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° ΠΏΠΎΠ²Π΅ΡΠ΅ ΠΎΡ Π΅Π΄ΠΈΠ½ URI Π² ΡΠ°ΠΉΠ»Π° TAL.
- Π ΡΡΠΈΠ»ΠΈΡΠ°ΡΠ° dig Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° RFC 8914 (Extended DNS Error) ΠΈ RFC 8976 (ZONEMD).
- Π dhclient Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΡΠΊΠ°Π·Π²Π°Π½Π΅ Π½Π° ΠΎΠΏΡΠΈΠΈ Π² ΡΠ°ΠΉΠ»ΠΎΠ²Π΅ΡΠ΅ hostname.if, ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°ΠΉΠΊΠΈ ΡΠ΅Π΄ΠΎΠ²Π΅ Β«dhcpΒ».
- Π Π΄Π΅ΠΌΠΎΠ½Π° snmpd Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° ΠΏΡΠ»Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΏΡΠ΅ΠΎΠ±ΡΠ°Π·ΡΠ²Π°Π½Π΅ΡΠΎ Trapv1 Π² Trapv2 (RFC 3584). Π snmpd.conf ΡΠ° Π΄ΠΎΠ±Π°Π²Π΅Π½ΠΈ Π½ΠΎΠ²ΠΈ ΠΊΠ»ΡΡΠΎΠ²ΠΈ Π΄ΡΠΌΠΈ read, write ΠΈ notify. Π ΡΡΠΈΠ»ΠΈΡΠ°ΡΠ° snmp Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΈΠ·Π±ΡΠΎΡΠ²Π°Π½ΠΈΡ SMI.
- Π DNS ΡΠ΅Π·ΠΎΠ»Π²Π΅ΡΠ° unwind Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° DNS64 ΠΈ ΠΏΡΠΈΠ΅ΠΌΠ°Π½Π΅ Π½Π° Π²ΡΡΠ·ΠΊΠΈ ΡΡΠ΅Π· TCP-ΠΏΠΎΡΡ.
- Π ΡΡΠΈΠ»ΠΈΡΠ°ΡΠ° ftp Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π·Π° ΠΏΠΎΡΡΠΎΡΠ½Π½ΠΈ ΠΏΡΠ΅Π½Π°ΡΠΎΡΠ²Π°Π½ΠΈΡ (RFC 7538) ΠΈ Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΠΈΠ·ΠΏΡΠ°ΡΠ°Π½Π΅ Π½Π° Π·Π°Π³Π»Π°Π²ΠΊΠ°ΡΠ° If-Modified-Since ΠΏΡΠΈ ΠΈΠ·ΠΏΡΠ°ΡΠ°Π½Π΅ Π½Π° Π·Π°ΠΏΠΈΡΠ²Π°Π½ΠΈΡ ΠΏΠΎ HTTP/HTTPS.
- Π OpenSMTPD Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΎΠΏΡΠΈΡ Β«-aΒ» Π·Π° ΠΈΠ·Π²ΡΡΡΠ²Π°Π½Π΅ Π½Π° Π°ΡΡΠ΅Π½ΡΠΈΠΊΠ°ΡΠΈΡ ΠΏΡΠ΅Π΄ΠΈ ΠΈΠ·ΠΏΡΠ°ΡΠ°Π½Π΅ΡΠΎ Π½Π° ΡΡΠΎΠ±ΡΠ΅Π½ΠΈΠ΅. Π‘ΡΠ΅Π΄ΡΡΠ²Π°ΡΠ° Π·Π° ΠΊΡΠΈΠΏΡΠΈΡΠ°Π½Π΅ ΡΠ° ΠΏΡΠ΅ΠΌΠ΅ΡΡΠ΅Π½ΠΈ Π½Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° Π±ΠΈΠ±Π»ΠΈΠΎΡΠ΅ΠΊΠ°ΡΠ° libtls. Π ΡΠ»ΡΡΠ°ΡΠΈΡΠ΅ ΡΠΎΠΊΠ΅ΡΠΈ Π·Π° TLS Π΅ ΡΠ΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° Π½Π°ΡΡΡΠΎΠΉΠΊΠ° Π½Π° Π½ΡΠΊΠΎΠ»ΠΊΠΎ ΡΠ΅ΡΡΠΈΡΠΈΠΊΠ°ΡΠ°, ΠΊΠΎΠΈΡΠΎ ΡΠ΅ ΠΈΠ·Π±ΠΈΡΠ°Ρ Π² Π·Π°Π²ΠΈΡΠΈΠΌΠΎΡΡ ΠΎΡ ΠΈΠΌΠ΅ΡΠΎ Π΄ΠΎΠΌΠ΅ΠΉΠ½ (SNI).
- Π LibreSSL Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄ΡΡΠΆΠΊΠ° Π½Π° ΠΏΡΠΎΡΠΎΠΊΠΎΠ»Π° DTLSv1.2. Π Π΅Π°Π»ΠΈΠ·ΠΈΡΠ°Π½Π° Π΅ Π²ΡΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ Π·Π° ΠΊΠΎΠΌΠΏΠΈΠ»ΠΈΡΠ°Π½Π΅ ΡΠ°ΠΌΠΎ Π½Π° libtls (ββenable-libtls-onlyβ) Π±Π΅Π· libcrypto ΠΈ libssl.
- ΠΠ±Π½ΠΎΠ²Π΅Π½ Π΅ ΠΏΠ°ΠΊΠ΅ΡΡΡ OpenSSH. ΠΠΎΠ΄ΡΠΎΠ±Π΅Π½ ΠΎΠ±Π·ΠΎΡ Π½Π° ΠΏΠΎΠ΄ΠΎΠ±ΡΠ΅Π½ΠΈΡΡΠ° ΠΌΠΎΠΆΠ΅ Π΄Π° ΡΠ΅ Π²ΠΈΠ΄ΠΈ ΡΡΠΊ: OpenSSH 8.5, OpenSSH 8.6.
- ΠΡΠΎΡΡ Π½Π° ΠΏΠΎΡΡΠΎΠ²Π΅ΡΠ΅ Π·Π° Π°ΡΡ
ΠΈΡΠ΅ΠΊΡΡΡΠ°ΡΠ° AMD64 Π΅ 11310, Π·Π° aarch64 β 10943, Π·Π° i386 β 10468. ΠΠ΅ΠΆΠ΄Ρ Π²Π΅ΡΡΠΈΠΈΡΠ΅ Π½Π° ΠΏΡΠΈΠ»ΠΎΠΆΠ΅Π½ΠΈΡΡΠ° Π² ΠΏΠΎΡΡΠΎΠ²Π΅ΡΠ΅: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 ΠΈ ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.
ΠΠ±Π½ΠΎΠ²Π΅Π½ΠΈ ΡΠ° ΠΊΠΎΠΌΠΏΠΎΠ½Π΅Π½ΡΠΈΡΠ΅ ΠΎΡ ΡΡΠ΅ΡΠΈ ΡΡΡΠ°Π½ΠΈ, Π²ΠΊΠ»ΡΡΠ΅Π½ΠΈ Π² OpenBSD 6.9:
- ΠΡΠ°ΡΠΈΡΠ½ΠΈΡΡ ΡΡΠ΅ΠΊ Xenocara, Π±Π°Π·ΠΈΡΠ°Π½ Π½Π° X.Org 7.7 Ρ xserver 1.20.10 + ΠΏΠ°ΡΠΎΠ²Π΅, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
- LLVM/Clang 10.0.1 (+ ΠΏΠ°ΡΠΊΠΈ)
- GCC 4.2.1 (+ ΠΏΠ°ΡΠΎΠ²Π΅) ΠΈ 3.3.6 (+ ΠΏΠ°ΡΠΎΠ²Π΅)
- Perl 5.32.1 (+ ΠΏΠ°ΡΠΎΠ²Π΅)
- NSD 4.3.6
- Unbound 1.13.1
- Ncurses 5.7
- Binutils 2.17 (+ ΠΏΠ°ΡΠΎΠ²Π΅)
- Gdb 6.3 (+ ΠΏΠ°Ρ)
- Awk 18.12.2020
- Expat 2.2.10
Π ΠΈΠ·Π»ΠΈΠ·Π°Π½Π΅ΡΠΎ Π½Π° Π²Π΅ΡΡΠΈΡ OpenBSD 6.9 Π΅ ΠΏΠΎΡΠ²Π΅ΡΠ΅Π½Π° Π½ΠΎΠ²Π°ΡΠ° ΠΏΠ΅ΡΠ΅Π½ Β«Vetera NovisΒ».
ΠΠ·ΡΠΎΡΠ½ΠΈΠΊ: opennet.ru
