ИздаванС Π½Π° OpenSSL 3.2.0 с клиСнтска ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° QUIC

Π‘Π»Π΅Π΄ осСм мСсСца Ρ€Π°Π·Ρ€Π°Π±ΠΎΡ‚ΠΊΠ°, Π΅ създадСно ΠΈΠ·Π΄Π°Π½ΠΈΠ΅ Π½Π° Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠ°Ρ‚Π° OpenSSL 3.2.0 с рСализация Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΠΈΡ‚Π΅ SSL/TLS ΠΈ Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° OpenSSL 3.2 Ρ‰Π΅ сС ΠΎΡΡŠΡ‰Π΅ΡΡ‚Π²ΡΠ²Π° Π΄ΠΎ 23 Π½ΠΎΠ΅ΠΌΠ²Ρ€ΠΈ 2025 Π³ΠΎΠ΄ΠΈΠ½Π°. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° ΠΏΡ€Π΅Π΄ΠΈΡˆΠ½ΠΈΡ‚Π΅ вСрсии OpenSSL 3.1 ΠΈ 3.0 LTS Ρ‰Π΅ ΠΏΡ€ΠΎΠ΄ΡŠΠ»ΠΆΠΈ Π΄ΠΎ ΠΌΠ°Ρ€Ρ‚ 2025 Π³ΠΎΠ΄ΠΈΠ½Π° ΠΈ сСптСмври 2026 Π³ΠΎΠ΄ΠΈΠ½Π° ΡΡŠΠΎΡ‚Π²Π΅Ρ‚Π½ΠΎ. ΠŸΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ°Ρ‚Π° Π½Π° вСрсия 1.1.1 ΠΏΡ€ΠΈΠΊΠ»ΡŽΡ‡ΠΈ ΠΏΡ€Π΅Π· сСптСмври Ρ‚Π°Π·ΠΈ Π³ΠΎΠ΄ΠΈΠ½Π°. ΠšΠΎΠ΄ΡŠΡ‚ Π½Π° ΠΏΡ€ΠΎΠ΅ΠΊΡ‚Π° сС разпространява ΠΏΠΎΠ΄ лицСнзия Apache 2.0.

Основни нововъвСдСния в OpenSSL 3.2.0:

  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ клиСнтска ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° QUIC (RFC 9000), ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½ ΠΊΠ°Ρ‚ΠΎ транспорт Π² ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° HTTP/3. РСализацията Π²ΠΊΠ»ΡŽΡ‡Π²Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅ Π½Π° мноТСство ΠΏΠΎΡ‚ΠΎΡ†ΠΈ ΠΏΡ€Π΅Π· Π΅Π΄ΠΈΠ½ ΠΊΠ°Π½Π°Π». ΠšΠΎΠΌΠΏΠΎΠ½Π΅Π½Ρ‚ΠΈΡ‚Π΅ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° QUIC Π½Π° ΡΡŠΡ€Π²ΡŠΡ€ΠΈ Ρ‰Π΅ Π±ΡŠΠ΄Π°Ρ‚ Π²ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΈ Π² ΠΈΠ·Π»ΠΈΠ·Π°Π½Π΅Ρ‚ΠΎ Π½Π° OpenSSL 3.3, ΠΊΠΎΠ΅Ρ‚ΠΎ ΠΏΠ»Π°Π½ΠΈΡ€Π°Ρ‚ Π΄Π° ΠΏΡƒΠ±Π»ΠΈΠΊΡƒΠ²Π°Ρ‚ Π½Π°ΠΉ-късно Π½Π° 30 Π°ΠΏΡ€ΠΈΠ» 2024 Π³ΠΎΠ΄ΠΈΠ½Π°.

    QUIC прСдставлява надстройка Π²ΡŠΡ€Ρ…Ρƒ ΠΏΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»Π° UDP, която ΠΏΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° мултиплСксиранС Π½Π° мноТСство Π²Ρ€ΡŠΠ·ΠΊΠΈ ΠΈ осигурява ΠΌΠ΅Ρ‚ΠΎΠ΄ΠΈ Π·Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅, Π΅ΠΊΠ²ΠΈΠ²Π°Π»Π΅Π½Ρ‚Π½ΠΈ Π½Π° TLS/SSL. ΠŸΡ€ΠΎΡ‚ΠΎΠΊΠΎΠ»ΡŠΡ‚ Π΅ създадСн ΠΏΡ€Π΅Π· 2013 Π³ΠΎΠ΄ΠΈΠ½Π° ΠΎΡ‚ Google ΠΊΠ°Ρ‚ΠΎ Π°Π»Ρ‚Π΅Ρ€Π½Π°Ρ‚ΠΈΠ²Π° Π½Π° комбинацията TCP+TLS Π·Π° ΡƒΠ΅Π±, Ρ€Π΅ΡˆΠ°Π²Π°Ρ‰Π° ΠΏΡ€ΠΎΠ±Π»Π΅ΠΌΠΈΡ‚Π΅ с Π΄ΡŠΠ»Π³ΠΎΡ‚ΠΎ Π²Ρ€Π΅ΠΌΠ΅ Π·Π° установяванС ΠΈ ΡΡŠΠ³Π»Π°ΡΡƒΠ²Π°Π½Π΅ Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠΈ Π² TCP ΠΈ Π΅Π»ΠΈΠΌΠΈΠ½ΠΈΡ€Π°Ρ‰Π° Π·Π°ΠΊΡŠΡΠ½Π΅Π½ΠΈΡΡ‚Π° ΠΏΡ€ΠΈ Π·Π°Π³ΡƒΠ±Π° Π½Π° ΠΏΠ°ΠΊΠ΅Ρ‚ΠΈ ΠΏΠΎ Π²Ρ€Π΅ΠΌΠ΅ Π½Π° ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ.

  • Π’ TLS Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈΠ΅Ρ‚ΠΎ Π·Π° компрСсиранС Π½Π° сСртификати Π½Π° Π΅Ρ‚Π°ΠΏΠ° Π½Π° ΡΡŠΠ³Π»Π°ΡΡƒΠ²Π°Π½Π΅ Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠΈΡ‚Π΅ (RFC 8879), ΠΊΠΎΠ΅Ρ‚ΠΎ позволява ускоряванС Π½Π° установяванСто Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠ°Ρ‚Π°, Ρ‚ΡŠΠΉ ΠΊΠ°Ρ‚ΠΎ голямата част ΠΎΡ‚ Ρ‚Ρ€Π°Ρ„ΠΈΠΊΠ° ΠΏΠΎ Π²Ρ€Π΅ΠΌΠ΅ Π½Π° ΡΡŠΠ³Π»Π°ΡΡƒΠ²Π°Π½Π΅Ρ‚ΠΎ ΠΈΠ΄Π²Π° ΠΎΡ‚ ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° Π΄Π°Π½Π½ΠΈ Π·Π° сСртификати. ΠŸΠΎΠ΄Π΄ΡŠΡ€ΠΆΠ° сС компрСсиранС с ΠΏΠΎΠΌΠΎΡ‰Ρ‚Π° Π½Π° Π±ΠΈΠ±Π»ΠΈΠΎΡ‚Π΅ΠΊΠΈΡ‚Π΅ zlib, zstd ΠΈ Brotli.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Π΄Π΅Ρ‚Π΅Ρ€ΠΌΠΈΠ½ΠΈΡ€Π°Π½ Π²Π°Ρ€ΠΈΠ°Π½Ρ‚ Π½Π° Ρ†ΠΈΡ„Ρ€ΠΎΠ²ΠΈ подписи ECDSA (Deterministic ECDSA, RFC 6979), ΠΏΡ€ΠΈ ΠΊΠΎΠΉΡ‚ΠΎ вмСсто случайна послСдоватСлност ΠΏΡ€ΠΈ Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅Ρ‚ΠΎ Π½Π° подписа сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π° Ρ…Π΅Ρˆ HMAC-SHA256 ΠΎΡ‚ личния ΠΊΠ»ΡŽΡ‡ ΠΈ тСкста Π½Π° подписваното ΡΡŠΠΎΠ±Ρ‰Π΅Π½ΠΈΠ΅, ΠΊΠΎΠ΅Ρ‚ΠΎ позволява Π²ΠΈΠ½Π°Π³ΠΈ Π΄Π° сС ΠΏΠΎΠ»ΡƒΡ‡Π°Π²Π° Π΅Π΄ΠΈΠ½ ΠΈ ΡΡŠΡ‰ подпис ΠΏΡ€ΠΈ Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ ΠΎΠΏΠ΅Ρ€Π°Ρ†ΠΈΠΈ ΠΏΠΎ подписванС, Π½ΠΎ Π½Π΅ позволява ΠΈΠ·Ρ‚ΠΈΡ‡Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ, ΠΊΠΎΠΈΡ‚ΠΎ Π±ΠΈΡ…Π° ΠΌΠΎΠ³Π»ΠΈ Π΄Π° сС ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Ρ‚ Π·Π° ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ΠΈΠ΅ Π½Π° личния ΠΊΠ»ΡŽΡ‡ (личният ΠΊΠ»ΡŽΡ‡ ΠΌΠΎΠΆΠ΅ Π΄Π° бъдС ΠΎΡ‚ΠΊΡ€ΠΈΡ‚, Π°ΠΊΠΎ ΠΏΠΎΠ½Π΅ Π΄Π²Π° подписа Π·Π° Ρ€Π°Π·Π»ΠΈΡ‡Π½ΠΈ Π΄Π°Π½Π½ΠΈ са Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½ΠΈ с повтаряща сС случайна послСдоватСлност).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Ρ€Π°Π·ΡˆΠΈΡ€Π΅Π½ΠΈ Π²Π°Ρ€ΠΈΠ°Π½Ρ‚ΠΈ Π½Π° Ρ†ΠΈΡ„Ρ€ΠΎΠ²ΠΈ подписи с ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ ΠΊΠ»ΡŽΡ‡ Ed25519 ΠΈ Ed448: Ed25519ctx, Ed25519ph ΠΈ Ed448ph (RFC 8032).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Ρ€Π΅ΠΆΠΈΠΌΠ° Π½Π° ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ AES-GCM-SIV (RFC 8452), ΠΊΠΎΠΉΡ‚ΠΎ ΡΡŠΡ‡Π΅Ρ‚Π°Π²Π° висока производитСлност Π½Π° Ρ€Π΅ΠΆΠΈΠΌΠ° GCM (Galois/Counter Mode) с устойчивост Π½Π° Ρ‚Π΅Ρ‡ΠΎΠ²Π΅ ΠΏΡ€ΠΈ ΠΏΠΎΠ²Ρ‚ΠΎΡ€Π½Π° ΡƒΠΏΠΎΡ‚Ρ€Π΅Π±Π° Π½Π° ΠΏΡ€ΠΎΠΈΠ·Π²ΠΎΠ»Π΅Π½ ΠΊΠΎΠ΄ nonce.
  • Π Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π΅ функция Π·Π° Π³Π΅Π½Π΅Ρ€ΠΈΡ€Π°Π½Π΅ Π½Π° ΠΊΠ»ΡŽΡ‡ Argon2 (RFC 9106), която ΠΏΡ€Π΅Π· 2015 Π³ΠΎΠ΄ΠΈΠ½Π° спСчСли конкурса Π·Π° Ρ„ΡƒΠ½ΠΊΡ†ΠΈΠΈ Π·Π° Ρ…Π΅ΡˆΠΈΡ€Π°Π½Π΅ Π½Π° ΠΏΠ°Ρ€ΠΎΠ»ΠΈ. Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° ΠΏΡƒΠ» ΠΎΡ‚ ΠΏΠΎΡ‚ΠΎΡ†ΠΈ.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Ρ…ΠΈΠ±Ρ€ΠΈΠ΄Π½ΠΎ ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅, Π±Π°Π·ΠΈΡ€Π°Π½ΠΎ Π½Π° ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠ° HPKE (Hybrid Public Key Encryption, RFC 9180), ΠΊΠΎΠΉΡ‚ΠΎ ΡΡŠΡ‡Π΅Ρ‚Π°Π²Π° простотата Π½Π° ΠΏΡ€Π΅Π΄Π°Π²Π°Π½Π΅ Π½Π° ΠΊΠ»ΡŽΡ‡Π° Π² ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅Ρ‚ΠΎ с ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ ΠΊΠ»ΡŽΡ‡ ΠΈ високата производитСлност Π½Π° симСтричното ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Π½Π΅ (Π΄Π°Π½Π½ΠΈΡ‚Π΅ сС ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π°Ρ‚ с Π±ΡŠΡ€Π· симСтричСн ΠΊΠ»ΡŽΡ‡, Π° самият ΠΊΠ»ΡŽΡ‡ сС ΠΊΡ€ΠΈΠΏΡ‚ΠΈΡ€Π° с Π±Π°Π²Π΅Π½ асимСтричСн ΠΌΠ΅Ρ‚ΠΎΠ΄).
  • Π’ TLS Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚Ρ‚Π° Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° "сурови" (raw) ΠΎΡ‚ΠΊΡ€ΠΈΡ‚ΠΈ ΠΊΠ»ΡŽΡ‡ΠΎΠ²Π΅ (RFC 7250).
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΠΌΠ΅Ρ…Π°Π½ΠΈΠ·ΠΌΠ° Π·Π° Π±ΡŠΡ€Π·ΠΎ отварянС Π½Π° TCP-соСдинСния (TFO β€” TCP Fast Open, RFC 7413), ΠΊΠΎΠΉΡ‚ΠΎ позволява намаляванС Π½Π° ΡΡ‚ΡŠΠΏΠΊΠΈΡ‚Π΅ Π·Π° установяванС Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠ°, ΠΊΠ°Ρ‚ΠΎ ΠΊΠΎΠΌΠ±ΠΈΠ½ΠΈΡ€Π° Π² Π΅Π΄Π½ΠΎ исканС ΠΏΡŠΡ€Π²ΠΈΡ‚Π΅ ΠΈ Π²Ρ‚ΠΎΡ€ΠΈΡ‚Π΅ ΡΡ‚ΡŠΠΏΠΊΠΈ Π½Π° класичСския 3-ΡΡ‚ΡŠΠΏΠΊΠΎΠ² процСс Π½Π° установяванС Π½Π° ΡΠ²ΡŠΡ€Π·Π°Π½ΠΎΡΡ‚ ΠΈ позволява ΠΈΠ·ΠΏΡ€Π°Ρ‰Π°Π½Π΅ Π½Π° Π΄Π°Π½Π½ΠΈ Π² Π½Π°Ρ‡Π°Π»Π΅Π½ Π΅Ρ‚Π°ΠΏ Π½Π° установяванС Π½Π° Π²Ρ€ΡŠΠ·ΠΊΠ°Ρ‚Π°.
  • Π’ TLS Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° ΡΠ²ΡŠΡ€Π·Π°Π½ΠΈ схСми Π·Π° Ρ†ΠΈΡ„Ρ€ΠΎΠ²ΠΈ подписи, позволяващи ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅Ρ‚ΠΎ Π½Π° външни Ρ€Π΅Π°Π»ΠΈΠ·Π°Ρ†ΠΈΠΈ Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ, Π½Π°ΠΏΡ€ΠΈΠΌΠ΅Ρ€, Π·Π° ΠΏΡ€ΠΈΠ»Π°Π³Π°Π½Π΅ Π½Π° Π°Π»Π³ΠΎΡ€ΠΈΡ‚ΠΌΠΈ устойчиви Π½Π° ΠΏΠΎΠ΄Π±ΠΈΡ€Π°Π½Π΅ с ΠΊΠ²Π°Π½Ρ‚ΠΎΠ²ΠΈ ΠΊΠΎΠΌΠΏΡŽΡ‚Ρ€ΠΈ Π² TLS.
  • Π’ TLS 1.3 Π΅ Π΄ΠΎΠ±Π°Π²Π΅Π½Π° ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° Π·Π°Ρ‰ΠΈΡ‚Π΅Π½ΠΈ Π΅Π»ΠΈΠΏΡ‚ΠΈΡ‡Π½ΠΈ ΠΊΡ€ΠΈΠ²ΠΈ Brainpool.
  • Π”ΠΎΠ±Π°Π²Π΅Π½Π° Π΅ ΠΏΠΎΠ΄Π΄Ρ€ΡŠΠΆΠΊΠ° Π½Π° процСсорни инструкции SM4-XTS.
  • На ΠΏΠ»Π°Ρ‚Ρ„ΠΎΡ€ΠΌΠ°Ρ‚Π° Windows Π΅ Ρ€Π΅Π°Π»ΠΈΠ·ΠΈΡ€Π°Π½Π° Π²ΡŠΠ·ΠΌΠΎΠΆΠ½ΠΎΡΡ‚ Π·Π° ΠΈΠ·ΠΏΠΎΠ»Π·Π²Π°Π½Π΅ Π½Π° систСмното Ρ…Ρ€Π°Π½ΠΈΠ»ΠΈΡ‰Π΅ Π½Π° ΠΊΠΎΡ€Π΅Π½ΠΎΠ²ΠΈ сСртификати (ΠΏΠΎ ΠΏΠΎΠ΄Ρ€Π°Π·Π±ΠΈΡ€Π°Π½Π΅ Π΅ ΠΈΠ·ΠΊΠ»ΡŽΡ‡Π΅Π½ΠΎ). Π—Π° Π΄ΠΎΡΡ‚ΡŠΠΏ Π΄ΠΎ сСртификатитС Π² Ρ…Ρ€Π°Π½ΠΈΠ»ΠΈΡ‰Π΅Ρ‚ΠΎ Π½Π° Windows Π΅ ΠΏΡ€Π΅Π΄Π»ΠΎΠΆΠ΅Π½ URI "org.openssl.winstore://".

Π˜Π·Ρ‚ΠΎΡ‡Π½ΠΈΠΊ: opennet.ru

ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ πŸ”₯ ΠšΡƒΠΏΠ΅Ρ‚Π΅ Π½Π°Π΄Π΅ΠΆΠ΄Π΅Π½ хостинг Π·Π° сайтовС със Π·Π°Ρ‰ΠΈΡ‚Π° ΠΎΡ‚ DDoS, VPS ΠΈ VDS ΡΡŠΡ€Π²ΡŠΡ€ΠΈ | ProHoster