Категория: Блог

Отворен код на услугата за проверка на пароли HaveIBeenPwned

Трой Хънт (Troy Hunt) отвори изходните кодове на услугата за проверка на компрометирани пароли «Have I Been Pwned?» (haveibeenpwned.com), която проверява база данни с 11.2 милиарда акаунта, хакнати в резултат на атаки срещу 538 сайта. Първоначално идеята за отваряне на проекта беше обявена през август миналата година, но процесът се проточи и кодът бе публикуван едва сега. Кодът на услугата е написан на […]

Mozilla обобщи плановете си за поддръжка на третата версия на манефеста на Chrome в Firefox

Компанията Mozilla публикува план за внедряване на третата версия на манефеста на Chrome в Firefox, която определя възможностите и ресурсите, предоставяни на добавките. Третата версия на манефеста беше критикувана за нарушаване на работата на много добавки за блокиране на нежелано съдържание и осигуряване на безопасност. В Firefox възнамеряват да реализират почти всички възможности и ограничения на новия манефест, включително декларативния API за филтриране на съдържанието (declarativeNetRequest), […]

Протоколът QUIC получи статус на предложен стандарт

Комитетът IETF (Internet Engineering Task Force), който се занимава с развитието на протоколи и архитектура на интернет, завърши оформянето на RFC за протокола QUIC и публикува свързаните спецификации със следните идентификатори: RFC 8999 (независими от версия свойства на протокола), RFC 9000 (транспорт върху UDP), RFC 9001 (TLS криптиране на канала за свързване QUIC) и RFC 9002 (управление на претоварване и определяне на загуба на пакети при предаване на данни). […]

Компанията Virtuozzo публикува дистрибутив VzLinux, насочен към заместване на CentOS 8

Компанията Virtuozzo (бивше подразделение на компанията Parallels), която разработва софтуер за виртуализация на сървъри на базата на отворени проекти, започна публично разпространение на дистрибуцията VzLinux, която по-рано се е използвала като основна операционна система за разработваната от компанията платформа за виртуализация и различни търговски продукти. Отсега нататък VzLinux стана достъпен за всички желаещи и се позиционира като замяна за CentOS 8, готова за производствени внедрения. За изтегляне […]

Издаване на дистрибуцията Simply Linux 9.1

Компания Базальт СПО обяви за излизането на дистрибуцията Simply Linux 9.1, изградена върху деветата платформа ALT. Продуктът се разпространява в рамките на лицензионен договор, който не прехвърля правото за разпространение на дистрибуцията, но позволява неограничено използване на системата от физически и юридически лица. Дистрибуцията се предлага в версии за архитектурите x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (бета) и може […]

Публикувана СУБД immudb 1.0, осигуряваща защита срещу изкривяване на данни

Представен е значителен релийз на СУБД immudb 1.0, гарантираща неизменност и запазване на всички данни, добавени някога, както и предоставяща защита от извършване на промени с обратна сила и даваща възможност за криптографско доказателство за владение на данните. Първоначално проектът се развива като специализирано NoSQL хранилище, манипулиращо данни в формат ключ/стойност, но от версия 1.0 immudb се позиционира като пълноценна СУБД с поддръжка на SQL. Код […]

Достъпен е дистрибуцията AlmaLinux 8.4, продължаваща развитието на CentOS 8

Представен е релийз на дистрибуцията AlmaLinux 8.4, синхронизирана с дистрибуцията Red Hat Enterprise Linux 8.4. Версиите са подготвени за архитектура x86_64 под формата на стартиращо (709 МБ), минимално (1.9 ГБ) и пълно изображение (9.8 ГБ). В близко бъдеще се планира също да бъдат публикувани версии за архитектура ARM. Дистрибуцията е призната за готова за производствени внедрения и е напълно идентична с RHEL по функционалност, за […]

Релийз на дистрибуцията Oracle Linux 8.4

Компанията Oracle публикува релиз на дистрибуцията Oracle Linux 8.4, създадена на базата на пакетната база Red Hat Enterprise Linux 8.4. За неограничено изтегляне се разпространява инсталационен iso-образ, с размер 8.6 ГБ, подготвен за архитектурите x86_64 и ARM64 (aarch64). За Oracle Linux е предоставен неограничен и безплатен достъп до yum-репозитория с бинарни актуализации на пакети с поправки (errata) и проблеми […]

Инцидент с загуба на контрол над каналите в IRC мрежата FreeNode

Новата екипа на IRC мрежата FreeNode изрази жалба относно инцидента от вчера, който беше възприет от някои общности като завладяване на техните IRC канали. Например, проекти като Ubuntu, Gentoo, HardenedBSD, LibreELEC, FSFE и Void Linux обявиха напускането си от FreeNode поради загубата на контрол над своите канали. След напускането на администрацията, която основа новата мрежа Libera.Chat заради конфликта с собственика на домейна, някои отворени […]

Издание на Chrome 91

Компанията Google представи изданието на уеб браузъра Chrome 91. В същото време е налично стабилно издание на свободния проект Chromium, който стои в основата на Chrome. Браузерът Chrome се отличава с използването на логотипи на Google, система за изпращане на уведомления при срив, модули за възпроизвеждане на защитено видеосъдържание (DRM), система за автоматично инсталиране на актуализации и предаване на RLZ параметри при търсене. Следващото издание на Chrome 92 е планирано за 20 юли. Основните промени […]

Издание на пакетния филтър nftables 0.9.9

Обявено е изданието на пакетния филтър nftables 0.9.9, който унифицира интерфейсите за филтриране на пакети за IPv4, IPv6, ARP и мрежови мостове (намерен да замени iptables, ip6table, arptables и ebtables). В същото време е публикувано издание на свързаната библиотека libnftnl 1.2.0, предоставяща нискоуровнево API за взаимодействие с подсистемата nf_tables. Необходимите промени за работа на nftables 0.9.9 са включени в ядрото на Linux 5.13-rc1. В пакета […]

Издание на дистрибутива OSGeo-Live 14.0 с подбрана колекция от географски информационни системи

Представен е дистрибутивът OSGeo-Live 14.0, разработван от неправителствената организация OSGeo с цел да предостави бърз достъп до различни отворени географски информационни системи, без необходимост от инсталация. Дистрибутивът е построен на базата на пакети от Lubuntu. Размерът на образа за изтегляне е 4.4 ГБ (amd64, както и образ за виртуализации като VirtualBox, VMWare, KVM и др.). Включени са около 50 отворени приложения […]

Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри 🔥 Купете надежден хостинг за сайтове със защита от DDoS, VPS и VDS сървъри | ProHoster