Google и команда разработчиков Ubuntu анонисировали приложения на Flutter для десктопных Linux систем

К настоящему времени более 500 000 разработчиков во всем мире используют Flutter — фреймворк с открытым исходным кодом от Google, предназначенный для создания мобильных приложений. Данная технология часто преподносится как замена React Native. До недавнего времени Flutter SDK был доступен на Linux только в качестве решения для разработки приложений для других платформ. Новый Flutter SDK позволяет разрабатывать приложения для Linux систем.

Сборка приложений для Linux с Flutter

«Мы рады объявить о выпуске альфа-версии Flutter для Linux. Данный релиз был подготовлен нами совместно с Canonical, издателем Ubuntu, самого популярного в мире дистрибутива Linux для настольных компьютеров», — написал Крис Селлс из Google в своем блоге.

Еще в прошлом году Google заявляла, что хочет портировать программное обеспечение для сборки Flutter на настольные платформы. Теперь, благодаря сотрудничеству с Ubuntu Team, у разработчиков появилась возможность создавать не только мобильные приложения, но и приложения для самой Ubuntu.

Между тем, Google заверяет, что приложения, разработанные с помощью Flutter для десктопных Linux систем будут предоставлять весь доступный нативным приложениям функционал благодаря обширной переработки движка Flutter.

Так, например, Dart, язык программирования, лежащий в основе Flutter, теперь может быть использован для полной интеграции с возможностями, предоставляемыми десктопным рабочим столом.

Наряду с командой Google в разработке участвует и команда Canonical, представители которой заявили, что будут работать над улучшением поддержки Linux и обеспечивать паритет функций Flutter SDK с другими платформами.

Разработчики предлагают оценить новые возможности Flutter на примере Flokk Contacts — простого приложения для управления контактами.

Установка Flutter SDK в Ubuntu

Flutter SDK доступен в Snap Store. Однако после его установки для добавления новых возможностей необходимо выполнить следующие комманды:

flutter channel dev

flutter upgrade

flutter config —enable-linux-desktop

Кроме того, вероятно вам понадобится установить пакет flutter-gallery, который также доступен в Snap Store.

Источник: linux.org.ru

Добавить комментарий