Локальная root-уязвимость в pam-python

В предоставляемом проектом pam-python PAM-модуле, позволяющем подключать модули аутентификации на языке Python, выявлена уязвимость (CVE-2019-16729), дающая возможность повысить свои привилегии в системе. При использовании уязвимой версии pam-python (по умолчанию не устанавливается), локальный пользователь может получить доступ с правами root, путём манипуляций с обрабатываемыми в Python по умолчанию переменными окружения (например, можно инициировать сохранение файла с байткодом для перезаписи системных файлов).

Уязвимость присутствует в последнем стабильном выпуске 1.0.6, предлагаемом с августа 2016 года. Проблема выявлена в ходе аудита PAM-модуля pam-python, проведённого разработчиками из команды openSUSE Security Team, и уже устранена в обновлении 1.0.7. Статус обновления пакетов с pam-python можно отследить на следующих страницах: Debian, Ubuntu, SUSE/openSUSE. В Fedora и RHEL модуль не поставляется.

Источник: opennet.ru

Добавить комментарий