Уязвимость в драйвере GPU Intel для Linux

В драйвере GPU Intel (i915) выявлена уязвимость (CVE-2022-4139), которая может привести к повреждению памяти или утечке данных из памяти ядра. Проблема проявляется начиная с ядра Linux 5.4 и затрагивает интегрированные и дискретные GPU Intel 12 поколения, включая семейства Tiger Lake, Rocket Lake, Alder Lake, DG1, Raptor Lake, DG2, Arctic Sound и Meteor Lake.

Проблема вызвана логической ошибкой, из-за которой видеодрайвер некорректно сбрасывает буфера TLB со стороны GPU на некотором оборудовании. В определённых случаях сброс TLB не происходил вообще. Некорректный сброс буферов TLB может привести к возможности обращения процесса при помощи GPU к страницам физической памяти которые не принадлежат данному процессу, что можно использовать для чтения чужих данных или повреждения памяти в постороннем процессе. Пока не определено, можно ли использовать уязвимость для прицельного повреждения памяти в желаемых адресах.

Источник: opennet.ru

Добавить комментарий