Byla vydána knihovna nghttp3 1.0 s implementací protokolu HTTP/3

První stabilní vydání projektu nghttp3, které vyvíjí knihovnu v jazyce C s realizací protokolu HTTP/3, je nyní k dispozici. Vyvinutý variant této knihovny pro protokol HTTP/2 se používá jako základ modulu mod_http2, který je součástí http serveru Apache. Výsledky projektu jsou také využity v nástroji Curl. Kód knihovny je distribuován pod licencí MIT.

Standard HTTP/3 určuje použití protokolu QUIC (Quick UDP Internet Connections) jako transportního prostředku pro HTTP/2. QUIC je nadstavbou nad protokolem UDP, která podporuje multiplexování několika připojení a poskytuje metody šifrování ekvivalentní TLS/SSL. Protokol byl vytvořen v roce 2013 společností Google jako alternativa k TCP+TLS pro web, čímž řeší problémy s vysokou dobou nastavení a vyjednávání připojení v TCP a eliminuje latence při ztrátě paketů během přenosu dat.

V nghttp3 je k dispozici nezávislá implementace specifikací RFC 9114 (HTTP/3 na protokolu QUIC), RFC 920 (technologie komprese hlaviček QPACK), RFC 9220 (přenos WebSockets přes HTTP/3) a RFC 9218 (rozšiřitelný mechanismus pro řízení priorit při odesílání odpovědí na klientské žádosti). Knihovna není závislá na určitých stacích QUIC a podporuje provoz na různých implementacích transportního protokolu QUIC. Projekt také vyvíjí vlastní implementaci protokolu QUIC - ngtcp2, která je používána jako defaultní. Jako backendy pro šifrování dat v ngtcp2 jsou podporovány quictls, GnuTLS, BoringSSL, Picotls a wolfSSL. Současně s nghttp3 1.0 byl také vydán první stabilní release ngtcp2 1.0.

Zdroj: opennet.ru

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster