Rubrika: Novinky internetu

Byl zpřístupněn kód služby pro kontrolu hesel HaveIBeenPwned.

Troy Hunt otevřel zdrojové kódy služby pro kontrolu kompromitovaných hesel „Have I Been Pwned?“ (haveibeenpwned.com), která prověřuje databázi 11,2 miliard účtů ukradených při hacks 538 webových stránek. Původně bylo oznámeno záměr otevřít kód projektu v srpnu loňského roku, ale proces se protáhl a kód byl publikován teprve nyní. Kód služby je napsán v […]

Mozilla shrnula plány na podporu třetí verze manifestu Chrome ve Firefoxu

Společnost Mozilla zveřejnila plán realizace ve Firefoxu třetí verze manifestu Chrome, který určuje možnosti a zdroje poskytované rozšířením. Třetí verze manifestu byla kritizována kvůli narušení funkce mnoha rozšíření pro blokaci nežádaného obsahu a zajištění bezpečnosti. V Firefoxu mají v plánu implementovat téměř všechny možnosti a omezení nového manifestu, včetně deklarativního API pro filtrování obsahu (declarativeNetRequest), […]

Protokol QUIC získal status navrhovaného standardu

Výbor IETF (Internet Engineering Task Force), který se zabývá vývojem protokolů a architektury internetu, dokončil formulaci RFC pro protokol QUIC a publikoval související specifikace pod identifikátory RFC 8999 (vlastnosti protokolu nezávislé na verzi), RFC 9000 (transport přes UDP), RFC 9001 (TLS šifrování komunikačního kanálu QUIC) a RFC 9002 (řízení přetížení a určení ztráty paketů při přenosu dat). […]

Společnost Virtuozzo vydala distribuci VzLinux, zaměřenou na náhradu CentOS 8.

Společnost Virtuozzo (dříve divize společnosti Parallels), vyvíjející serverový software pro virtualizaci na základě otevřených projektů, zahájila veřejné distribuce disku VzLinux, který byl dříve používán jako základní operační systém pro vyvíjenou platformu virtualizace a různé komerční produkty. Od této chvíle je VzLinux k dispozici všem zájemcům a je prezentován jako náhrada za CentOS 8, připravený pro pracovní nasazení. K dispozici ke stažení […]

Vydání distribuce Simply Linux 9.1

Společnost Bazalt SPO oznámila vydání disku Simply Linux 9.1, postaveného na deváté platformě ALT. Produkt je distribuován na základě licenční smlouvy, která nepřenáší právo na distribuci disku, ale umožňuje bez omezení používat systém fyzickým a právnickým osobám. Disk je dodáván v sestavách pro architektury x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) a může […]

Byla zveřejněna databázová SDB immudb 1.0, která zajišťuje ochranu před zkreslením dat.

Byl uveden důležitý vydání databázového systému immudb 1.0, který zajišťuje neměnnost a uchování všech dat, která byla kdy přidána, a také poskytuje ochranu před zpětnými změnami a umožňuje kryptografický důkaz o vlastnictví dat. Projekt byl původně vyvinut jako specializované NoSQL úložiště manipulující s daty v klíč/hodnota formátu, ale od vydání 1.0 je immudb pozicováno jako plnohodnotná databáze s podporou SQL. Kód […]

Distribuce AlmaLinux 8.4 je nyní k dispozici, pokračující ve vývoji CentOS 8

Bylo uvedeno vydání distribuce AlmaLinux 8.4, synchronizované s distribucí Red Hat Enterprise Linux 8.4. Sestavy jsou připraveny pro architekturu x86_64 ve formě bootovatelného (709 MB), minimálního (1,9 GB) a plného obrazu (9,8 GB). V blízké době se plánuje také uvolnění sestav pro architekturu ARM. Distribuce je uznána za připravenou pro pracovní zavedení a je plně identická s RHEL co do funkcionality, za […]

Vydání distribuce Oracle Linux 8.4

Společnost Oracle zveřejnila vydání distribuce Oracle Linux 8.4, která byla vytvořena na základě balíčkové základny Red Hat Enterprise Linux 8.4. Ke stažení bez omezení je k dispozici instalační ISO obraz o velikosti 8,6 GB, připravený pro architektury x86_64 a ARM64 (aarch64). Pro Oracle Linux je otevřen neomezený a bezplatný přístup k yum repozitáři s binárními aktualizacemi balíčků s opravami chyb (errata) a problémy […]

Incident se ztrátou kontroly nad kanály v IRC síti FreeNode

Nový tým IRC sítě FreeNode vyjádřil lítost nad incidentem, který se odehrál včera a který byl některými komunitami vnímán jako převzetí jejich IRC kanálů. Například projekty Ubuntu, Gentoo, HardenedBSD, LibreELEC, FSFE a Void Linux oznámily odchod z FreeNode kvůli ztrátě kontroly nad svými kanály. Po odchodu týmu administrátorů, kteří založili novou síť Libera.Chat kvůli konfliktu s majitelem domén, řada otevřených […]

Verze Chrome 91

Společnost Google představila vydání webového prohlížeče Chrome 91. Současně je k dispozici stabilní vydání svobodného projektu Chromium, které tvoří základ Chrome. Prohlížeč Chrome se vyznačuje používáním loga Google, systémem odesílání oznámení v případě pádu, moduly pro přehrávání chráněného video obsahu (DRM), systémem automatické instalace aktualizací a přenášením RLZ parametrů při vyhledávání. Další vydání Chrome 92 je naplánováno na 20. července. Hlavní změny […]

Vydání paketového filtru nftables 0.9.9

Byl vydán balíček filtrování nftables 0.9.9, který unifikuje rozhraní pro filtraci paketů pro IPv4, IPv6, ARP a síťové mosty (zaměřený na nahrazení iptables, ip6tables, arptables a ebtables). Současně byl vydán doprovodný knihovní balíček libnftnl 1.2.0, který poskytuje nízkoúrovňové API pro interakci se subsystémem nf_tables. Změny nezbytné pro provoz vydání nftables 0.9.9 byly zahrnuty do jádra Linux 5.13-rc1. V balíčku […]

Vydání distribuce OSGeo-Live 14.0 se sbírkou geografických informačních systémů

Byl představen vydání distribuce OSGeo-Live 14.0, který vyvíjí nezisková organizace OSGeo s cílem poskytnout rychlé seznámení s různými otevřenými geografickými informačními systémy bez nutnosti jejich instalace. Distribuce je postavena na balíčkové základně Lubuntu. Velikost bootovacího obrazu je 4,4 GB (amd64, a také obraz pro virtualizační systémy VirtualBox, VMWare, KVM atd.). Obsahuje přibližně 50 otevřených aplikací […]

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster