Implementace kryptografických algoritmů GOST v jazyce Java

Byla publikována knihovna crypto-gost s implementací kryptografických algoritmů GOST v jazyce Java, která nevyžaduje žádné další závislosti. Na rozdíl od implementací algoritmů GOST v knihovně Bouncy Castle, nabízí crypto-gost zvýšený výkon šifrování algoritmem 'Kuznechik', řeší některé bezpečnostní problémy a poskytuje jednoduché obálky, které nevyžadují hluboké znalosti kryptografie. Kód je poskytován pod vlastní povolovací licencí, která umožňuje šíření, modifikaci a vytváření odvozených děl bez omezení.

Podporované algoritmy:

  • GOST R 34.11-2012 (RFC 6986) — hashovací funkce 'Streebog' 256 a 512 bitů.
  • GOST R 34.12-2015 — bloková šifrovací funkce 'Kuznechik', klíč 256 bitů.
  • GOST R 34.13-2015 — režimy šifrování CBC, CFB, CTR (GAMMA), OFB; autentizace (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektronický podpis 256 a 512 bitů.
  • HMAC-Streebog (RFC 7836, HMAC-Streebog-256 a HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-režim pro Kuznechik (RFC 9058). Kompatibilní s OpenSSL.
  • SCrypt (RFC 7914) — funkce pro generování klíče na základě hesla.

Zdroj: opennet.ru

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster