Byl vydán FreeBSD 12.3, který je publikován pro architektury amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 a armv6, armv7 a aarch64. Dále byly připraveny obrazy pro virtualizační systémy (QCOW2, VHD, VMDK, raw) a cloudová prostředí Amazon EC2. Vydání FreeBSD 13.1 se očekává na jaře 2022.
Hlavní novinky:
- Byl přidán skript /etc/rc.final, který se spouští v poslední fázi po dokončení všech uživatelských procesů.
- V balíkovém filtru ipfw byla poskytnuta příkaz dnctl pro správu nastavení systému omezení provozu dummynet.
- Byla přidána sysctl kern.crypto pro správu kryptosystemu jádra, stejně jako ladící sysctl debug.uma_reclaim.
- Byla přidána sysctl net.inet.tcp.tolerate_missing_ts, která umožňuje TCP pakety bez časových razítek (možnost timestamp, RFC 1323/RFC 7323).
- V jádru GENERIC pro architekturu amd64 byla zahrnuta volba COMPAT_LINUXKPI a aktivován ovladač mlx5en (NVIDIA Mellanox ConnectX-4/5/6).
- Do bootloaderu byla přidána možnost zavádění operačního systému z ramdisku a také byla realizována podpora ZFS možností com.delphix:bookmark_written a com.datto:bookmark_v2.
- Do knihovny fetch byla přidána podpora pro prokxy FTP přes HTTPS.
- V balíčkovém správci pkg pro příkazy „bootstrap“ a „add“ byl implementován příznak „-r“ pro určení repozitáře. Bylo zajištěno využití proměnných prostředí z souboru pkg.conf.
- V utilitě growfs se objevila možnost práce se souborovými systémy připojenými v režimu čtení a zápisu.
- V utilitě etcupdate byl implementován režim pro vrácení změn pro obnovení jednoho nebo několika souborů. Přidán příznak „-D“ pro určení cílového adresáře. Byla zajištěna extrakce dat s použitím dočasného adresáře a byla přidána podpora pro zpracování SIGINT.
- V utilitě freebsd-update a freebsd-version byl přidán příznak „-j“ pro podporu jail-okolí.
- Utilitu cpuset lze nyní použít v jail-okolí pro změnu parametrů dceřiných jail.
- V utilitě cmp byly přidány možnosti: „-b“ (—print-bytes) pro výstup odlišujících se bytů, „-i“ (—ignore-initial) pro ignorování určitého počtu počátečních bytů, „-n“ (—bytes) pro omezení počtu porovnávaných bytů.
- V utilitě daemon se objevil příznak „-H“ pro zpracování SIGHUP a znovuotevření souboru, do kterého se provádí výstup (přidáno pro podporu newsyslog).
- V utilitě fstyp při uvedení příznaku „-l“ bylo zajištěno určení a zobrazení souborových systémů exFAT.
- V nástroji mergemaster byla implementována podpora symbolických odkazů během aktualizace.
- Do nástroje newsyslog byla přidána přepínač „E“ pro vypnutí rotace prázdných logů.
- V nástroji tcpdump přibyla možnost dekódování paketů na rozhraních pfsync.
- Do nástroje top byla přidána filtrační příkaz „/“ pro zobrazení pouze procesů nebo argumentů odpovídajících zadanému řetězci.
- Do unzip byla přidána podpora archivů chráněných heslem.
- Byla vylepšena podpora hardwaru. Byly přidány identifikátory PCI zařízení pro AHCI řadiče ASMedia ASM116x a I2C řadiče Intel Gemini Lake. Implementována byla podpora síťových adaptérů Mikrotik 10/25G a bezdrátových karet Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Byl přidán nový ovladač igc pro ethernetové řadiče Intel I225 2.5G/1G/100MB/10MB.
- Netgraph uzel ng_bridge byl přizpůsoben pro SMP systémy. V uzlu ng_nat byla přidána podpora CGN (Carrier Grade NAT, RFC 6598). Byla poskytnuta možnost substituce uzlu ng_source do libovolné části Netgraph sítě.
- V ovladači rctl, který se používá pro omezení zdrojů, byla přidána možnost nastavit omezení spotřeby zdrojů na hodnotu 0.
- Do rozhraní vlan byla přidána podpora systému prioritizace provozu a správy šířky pásma ALTQ.
- V ovladačích amdtemp a amdsmn byla implementována podpora CPU Zen 3 „Vermeer“ a APU Ryzen 4000 (Zen 2, „Renoir“).
- Byly aktualizovány verze aplikací třetích stran zahrnutých v základním systému: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Nástroj unzip byl synchronizován s kódovou základnou NetBSD.
Zdroj: opennet.ru
