Vydání http serveru Lighttpd 1.4.65

Byl vydán lehký HTTP server lighttpd 1.4.65, který se snaží kombinovat vysoký výkon, bezpečnost, standardní shodu a flexibilitu konfigurace. Lighttpd je vhodný pro nasazení na vysoce zatížených systémech a klade důraz na nízkou spotřebu paměti a CPU. V této nové verzi bylo uvedeno 173 změn. Kód projektu je napsán v jazyce C a je šířen pod licencí BSD.

Hlavní novinky:

  • Byla přidána podpora WebSocketů nad HTTP/2 a implementován RFC 8441, který popisuje mechanismus pro zahájení protokolu WebSocket v jednom vlákně v rámci HTTP/2 spojení.
  • Byl realizován rozšířený systém správy priorit, který umožňuje klientovi ovlivnit prioritu přenášených serverem odpovědí (RFC 9218) a řídit priority při přesměrování požadavků. Pro HTTP/2 byla zajištěna podpora rámce PRIORITY_UPDATE.
  • V konfiguraci lighttpd.conf byla přidána podpora podmínkových shod vázaných na začátek (=^) a konec (=$) řetězce. Tyto jednoduché řetězcové kontroly jsou mnohem rychlejší než regulární výrazy a jsou dostatečné pro mnohé jednoduché kontroly.
  • V mod_webdav byla přidána podpora pro částečné operace PUT (které pokrývají část dat pomocí hlavičky Range). Pro aktivaci lze použít volbu ‘webdav.opts += (“partial-put-copy-modify” => “enable”).
  • V mod_accesslog byla přidána volba ‘accesslog.escaping = ‘json’’.
  • V mod_deflate byla přidána podpora pro sestavení s libdeflate.
  • Byl zrychlen přenos těla požadavku přes HTTP/2.
  • Výchozí hodnota parametru server.max-keep-alive-requests byla změněna z 100 na 1000.
  • V seznamu MIME typů byl ‘application/javascript’ nahrazen ‘text/javascript’ (RFC 9239).

Do budoucna je plánováno zavedení přísnějších šifrovacích nastavení pro TLS a výchozí deaktivaci zastaralých šifer. Nastavení CipherString bude změněno z ‘HIGH’ na ‘EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384’. Také jsou plánovány k odstranění zastaralé možnosti TLS: ssl.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. Bude pokračováno v úklidu mini-modulů, které mohou být nahrazeny flexibilnější Lua implementací mod_magnet. Konkrétně se plánuje odstranění modulů mod_evasive, mod_secdownload, mod_uploadprogress a mod_usertrack.

Zdroj: opennet.ru

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster