Vydání OpenBSD 6.9

Byla vydána verze svobodného multiplatformního UNIX-like operačního systému OpenBSD 6.9. Je to 50. vydání projektu, který letos oslaví 26 let. Projekt OpenBSD byl založen Theo de Raadtem v roce 1995 po konfliktu s vývojáři NetBSD, který vedl k zablokování přístupu k CVS repozitáři NetBSD. Po tom Theo de Raadt spolu se skupinou nadšenců vytvořil na základě zdrojových textů NetBSD nový otevřený operační systém, jehož hlavními cíli byly přenositelnost (podporovány 13 hardwarových platforem), standardizace, správná funkčnost, aktivní bezpečnost a integrované kryptografické nástroje. Velikost kompletní instalační ISO obrazu základního systému OpenBSD 6.9 je 544 MB.

Kromě samotného operačního systému je projekt OpenBSD známý svými komponenty, které se rozšířily do dalších systémů a prokázaly se jako jedny z nejbezpečnějších a nejkvalitnějších řešení. Mezi ně patří: LibreSSL (fork OpenSSL), OpenSSH, paketový filtr PF, směrovací démoni OpenBGPD a OpenOSPFD, NTP server OpenNTPD, poštovní server OpenSMTPD, multiplexor textového terminálu (analog GNU screen) tmux, démon identd s implementací protokolu IDENT, BSDL alternativa k balíku GNU groff — mandoc, protokol pro organizaci odolných systémů CARP (Common Address Redundancy Protocol), lehký http server, nástroj pro synchronizaci souborů OpenRSYNC.

Hlavní vylepšení:

  • V ovladači softraid byl přidán režim RAID1C s realizací programového RAID1 s šifrováním dat.
  • Byly přidány dva nové pozadí procesy — dhcpleased a resolvd, které spolupracují se slaacd a unwind pro automatické nastavení síťových rozhraní a určení názvů v DNS. V dhcpleased je implementován protokol DHCP pro získávání IP adres a v resolvd je zajištěno řízení obsahu resolv.conf na základě údajů o serverech názvů získaných od dhcpleased, slaacd a ovladačů jako je umb.
  • Byla přidána počáteční podpora zařízení Apple s procesorem M1. To zahrnuje rozpoznávání arm64-jader Apple Icestorm/Firestorm a přidání podpory bezdrátových čipů BCM4378, které se používají v SoC Apple M1.
  • Zlepšena podpora platformy powerpc64 vyvinuté pro 64-bitové systémy na bázi procesorů POWER8 a POWER9. Ve srovnání s předchozím vydáním byla pro powerpc64 zavedena podpora mechanizmu ochrany RETGUARD, přidán ovladač astfb pro frame buffer Aspeed BMC, vyřešeny problémy s fungováním ovladačů radeondrm a amdgpu na systémech s GPU AMD, do jádrové sestavy pro ramdisk byla přidána možnost síťového zavádění, přidána podpora režimů úspory energie CPU POWER9 a podpora výjimek generovaných při operacích s plovoucí desetinou, byla implementována podpora IPMI pro systémy PowerNV.
  • Pro platformy ARM64 je zajištěna podpora CPU Cortex-A78AE, Cortex-X1 a Neoverse V1, byly realizovány optimalizované varianty volání copyin, copyout a kcopy specifické pro ARM64, přidán ovladač cryptox pro podporu krypto rozšíření ARMv8, stejně jako ovladač smmu pro RM System MMU s podporou Guard Page. Byla vylepšena podpora zařízení Raspberry Pi, Rock Pi N10, NanoPi a Pinebook Pro.
  • Do ovladače video byl přidán sysctl parametr kern.video.record, který analogicky k kern.audio.record řídí zapnutí výstupu prázdného obrázku při pokusu o zachycení videa (pro možné zachycení je třeba změnit hodnotu na 1). Procesům je povoleno opakované otevírání zařízení video (řeší problémy s používáním webkamer v prohlížeči Firefox a BigBlueButton).
  • Byly přidány tracepointy pro volání malloc a free, což umožňuje sledovat aktivitu spojenou s přidělováním paměti pomocí dt a btrace. Do btrace byla přidána volba '-n' pro analýzu programu bez provádění jakýchkoliv akcí.
  • Byla vylepšena podpora vícero procesorových systémů (SMP). Byla uvolněna implementace UNIX socketů z celkové blokace jádra, přidán společný mutex pro serializaci operací s msgbuf, volání uvm_pagealloc bylo převedeno na mp-safe, a byly odstraněny blokace z volání getppid a sendsyslog.
  • Byly opraveny problémy v komponentách DRM (Direct Rendering Manager), včetně vyřešení pádů v ovladači radeondrm na systémech Powerbook5/6 a RV350, zabezpečena podpora DRI3 v ovladačích amdgpu a ati, pro kompatibilitu s Linuxem bylo realizováno vytvoření zařízení v adresáři /dev/dri/.
  • Byla provedena vylepšení ve hypervizoru VMM. V backendu pro správu virtuálních strojů vmd byla přidána podpora bootování ze zkomprimovaných RAM-disků.
  • Byla vylepšena zvuková subsystém. Byla poskytnuta možnost samostatného přiřazení zvukových zařízení sndio pouze pro přehrávání a pouze pro záznam. V sndiod byl implementován nízkofrekvenční filtr s konečnou impulsní charakteristikou (KIH filtr) osmé řádu, který umožnil zbavit se šumu způsobeného překrýváním spekter při vzorkování. Výchozí možnost automatického snížení hlasitosti, když nová aplikace začíná přehrávání (autovolume), je ve výchozím nastavení zakázána, úroveň hlasitosti je nastavena na 127. Míchání zvuku z alternativních zařízení s různou úrovní podporované funkčnosti v sndiod je povoleno.
  • Ve výchozím nastavení je povolena kompilace a instalace debuggeru LLDB.
  • Byla přidána podpora loggeru v rcctl, rc.subr a rc.d, což umožňuje organizaci výstupu logů z backgroundových procesů, které posílají data do stdout/stderr.
  • Pro touchpady byla přidána možnost nastavení rozložení tlačítek pomocí wsconsctl. V wscons byla vylepšena obsluha současných dotyků.
  • Pro zařízení ARM64 byla implementována možnost použití APM pro získání dat o spotřebě energie a stavu baterie. Pro omezení přístupu procesu apmd k souborovému systému byl použit systémový hovor unveil.
  • Byla rozšířena podpora hardwaru. Byly přidány nové ovladače acpige (pro zpracování událostí ACPI, jako je stisknutí tlačítka napájení), pchgpio (pro GPIO ovladače moderních Intel PCH), ujoy (pro herní ovladače), uhidpp (pro zařízení Logitech HID++). Byla přidána podpora rozšíření AMD Vi a Intel VTD IOMMU pro izolaci PCI zařízení a blokování nesprávného přístupu k paměti. Byla přidána podpora počítačů Lynloong LM9002/9003 a LM9013. Ovladače pcamux a imxiic byly vylepšeny o podporu ACPI.
  • Byla vylepšena podpora síťových adaptérů: mvpp (SFP+ a 10G pro Marvel Armada Ethernet), mvneta (1000base-x a 2500base-x), mvsw (Marvel SOHO switche), rge (podpora Wake on LAN), Netgear ProSecure UTM25. Pro bezdrátové ovladače iwm, iwn a athn byla přidána podpora RA (802.11n Tx Rate Adaptation). V bezdrátovém stacku byla zavedena automatická volba režimů 11a/b/g/n/ac při používání síťového rozhraní jako přístupového bodu.
  • V síťovém stacku byl implementován ovladač veb (Virtuální Ethernet Bridge). Byla zavedena podpora monitorovacího režimu, ve kterém příchozí paketové data na síťovém rozhraní nejsou předána pro zpracování, ale mohou být analyzována pomocí mechanismů jako BPF. Přidán nový typ síťových rozhraní — etherbridge. Byla zavedena možnost přepsání zdrojové adresy (příkaz route sourceaddr) pro programy, mimo standardní algoritmus výběru adresy. IP adres Zajištěno automatické spuštění síťových rozhraní při zapnutí režimu automatického nastavení (AUTOCONF4 a AUTOCONF6).
  • V instalátoru byla implementována dodávka komprimovaného obrazu ramdisku (bsd.rd) na všech platformách, které podporují takové spuštění.
  • Byla zavedena výstupní zpráva přes syslog varující o použití formátovacího zástupného znaku "%n" v printf.
  • Démonu routování OpenBGPD byla přidána podpora protokolu RTR (Resource Public Key Infrastructure (RPKI) to Router Protocol). Pro zobrazení základních informací o RTR relacích byla přidána příkaz „bgpctl show rtr“.
  • Byla provedena restrukturalizace kódu ospfd a ospf6d s cílem jejich unifikace s ostatními démony routování a zjednodušení údržby. Byla zavedena podpora síťových rozhraní v režimu bod-bod.
  • Ve vestavěném HTTP serveru httpd byly implementovány nové možnosti „location (found|notfound)“ pro kontrolu existence zdrojů.
  • Do nástroje rpki-client byla přidána podpora protokolu RRDP (The RPKI Repository Delta Protocol, RFC 8182). Byla realizována možnost uvedení více než jednoho URI v souboru TAL.
  • Do nástroje dig byla přidána podpora RFC 8914 (Extended DNS Error) a RFC 8976 (ZONEMD).
  • Do dhclient byla přidána možnost uvádění možností v souborech hostname.if pomocí řádků „dhcp“.
  • V démonu snmpd byla implementována plná podpora převodu Trapv1 na Trapv2 (RFC 3584). Do snmpd.conf byla přidána nová klíčová slova read, write a notify. Do nástroje snmp byla přidána podpora enumerací SMI.
  • Do DNS resolveru unwind byla přidána podpora DNS64 a příjmu připojení přes TCP port.
  • Do nástroje ftp byla přidána podpora trvalých přesměrování (RFC 7538) a možnost odesílání hlavičky If-Modified-Since při odesílání požadavků přes HTTP/HTTPS.
  • Do OpenSMTPD byla přidána možnost „-a“ pro provádění autentizace před odesláním zprávy. Šifrovací prostředky byly převedeny na použití knihovny libtls. Ve naslouchajících socketech pro TLS byla implementována možnost nastavení více certifikátů, vybíraných podle názvu domény (SNI).
  • Do LibreSSL byla přidána podpora protokolu DTLSv1.2. Byla implementována možnost sestavení pouze libtls („--enable-libtls-only“) bez libcrypto a libssl.
  • Byl aktualizován balíček OpenSSH. Podrobný přehled vylepšení můžete vidět zde: OpenSSH 8.5, OpenSSH 8.6.
  • Počet portů pro architekturu AMD64 činil 11310, pro aarch64 — 10943, pro i386 — 10468. Mezi verzemi aplikací v portech: Xfce 4.16, Asterisk 18.3.0, Chromium 90.0.4430.72, FFmpeg 4.3.2, GCC 8.4.0, GNOME 3.38, Go 1.16.2, KDE Applications 20.12.3, Krita 4.4.3, LLVM/Clang 10.0.1, LibreOffice 7.0.5.2, Lua 5.3.6, MariaDB 10.5.9, Firefox 88.0 a ESR 78.10.0, Thunderbird 78.10.0, Node.js 12.16.1, PHP 8.0.3, Postfix 3.5.10, PostgreSQL 13.2, Python 3.9.2, Ruby 3.0.1, Rust 1.51.0.

    Byly aktualizovány komponenty od třetích stran zahrnuté ve verzi OpenBSD 6.9:

    • Grafický stack Xenocara na bázi X.Org 7.7 s xserver 1.20.10 + opravy, freetype 2.10.4, fontconfig 2.12.4, Mesa 20.0.8, xterm 367, xkeyboard-config 2.20, fonttosfnt 1.2.1.
    • LLVM/Clang 10.0.1 (+ patche)
    • GCC 4.2.1 (+ patche) a 3.3.6 (+ patche)
    • Perl 5.32.1 (+ patche)
    • NSD 4.3.6
    • Unbound 1.13.1
    • Ncurses 5.7
    • Binutils 2.17 (+ patche)
    • Gdb 6.3 (+ patche)
    • Awk 18.12.2020
    • Expat 2.2.10

K vydání verze OpenBSD 6.9 je připravena nová píseň „Vetera Novis“.

Zdroj: opennet.ru

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster