Rubrika: Blog

Vydání OpenRGB 0.6, nástroje pro správu zařízení s RGB podsvícením

Byl vydán nový OpenRGB 0.6, svobodný nástroj pro správu zařízení s RGB osvětlením. Balíček podporuje základní desky ASUS, Gigabyte, ASRock a MSI s RGB systémem pro osvětlení skříní, paměťové moduly s osvětlením od ASUS, Patriot, Corsair a HyperX, grafické karty ASUS Aura/ROG, MSI GeForce, Sapphire Nitro a Gigabyte Aorus, různé ovladače LED pásek (ThermalTake, Corsair, NZXT Hue+), […]

Pro jazyk D byl představen runtime pro programování mikrokontrolérů.

Dylan Graham představil lehký runtime LWDR pro programování v jazyce D na mikrokontrolerech vybavených operačními systémy reálného času (RTOS). Aktuální verze je zaměřena na mikrokontrolery ARM Cortex-M. Vývoj nemá za cíl pokrýt všechny možnosti jazyka D, ale poskytuje základní nástroje. Alokace paměti je prováděna ručně (new / delete), garbage collector není implementován, ale jsou k dispozici různé hooky pro […]

Vydání aplikačního serveru NGINX Unit 1.24.0

Byl vydán server aplikací NGINX Unit 1.24, který rozvíjí řešení pro spuštění webových aplikací v různých programovacích jazycích (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js a Java). Pod NGINX Unit může být současně provozováno několik aplikací v různých programovacích jazycích, jejichž spouštěcí parametry lze dynamicky měnit bez nutnosti úpravy konfiguračních souborů a restartování. Kód […]

Vydání Electron 13.0.0, platformy pro vytváření aplikací na bázi motoru Chromium.

Bylo připraveno vydání platformy Electron 13.0.0, která poskytuje samostatný rámec pro vývoj multiplatformních uživatelských aplikací, využívající komponenty Chromium, V8 a Node.js jako základ. Významná změna čísla verze je spojena s aktualizací na kódovou základnu Chromium 91, platformu Node.js 14.16 a JavaScript engine V8 9.1. Mezi změnami v novém vydání: Přidáno vlastnost process.contextIsolated pro určení vykonávání aktuální […]

Vydání knihovny PCRE2 10.37

Bylo vydáno vydání knihovny PCRE2 10.37, která poskytuje sadu funkcí v jazyce C pro implementaci regulárních výrazů a prostředky pro shodování vzorů (pattern matching), které jsou syntaxí a sémantikou blízké regulárním výrazům jazyka Perl 5. PCRE2 představuje přepracovanou verzi původní knihovny PCRE s nekompatibilním API a rozšířenými možnostmi. Knihovnu vyvinuli vývojáři poštovního serveru Exim a je distribuována […]

Microsoft vydal balíčkovací manažer Windows Package Manager 1.0, podobný apt a dnf.

Společnost Microsoft zveřejnila vydání správce balíčků Windows Package Manager 1.0 (winget), který poskytuje nástroje pro instalaci aplikací prostřednictvím příkazové řádky. Kód je napsán v jazyce C++ a šíří se pod licencí MIT. Balíčky se instalují z repozitáře podporovaného komunitou. Na rozdíl od instalace programů z katalogu Microsoft Store, winget umožňuje instalaci aplikací bez nadbytečné marketingové strategie a […]

Verze správce balíčků Pacman 6.0 a instalátoru Archinstall 2.2.0

Byla vydána nová verze správce balíčků Pacman 6.0.0 a instalátoru Archinstall 2.2.0, které se používají v distribuci Arch Linux. Hlavní změny v Pacman 6.0: Přidána podpora stahování souborů ve více paralelních vláknech. Implementováno zobrazení řádku s indikací postupu stahování dat. Chcete-li zakázat indikátor postupu v pacman.conf, můžete zadat volbu „—noprogressbar“. Zajištěno automatické přeskočení zrcadel, ke kterým se […]

Byl zpřístupněn kód služby pro kontrolu hesel HaveIBeenPwned.

Troy Hunt otevřel zdrojové kódy služby pro kontrolu kompromitovaných hesel „Have I Been Pwned?“ (haveibeenpwned.com), která prověřuje databázi 11,2 miliard účtů ukradených při hacks 538 webových stránek. Původně bylo oznámeno záměr otevřít kód projektu v srpnu loňského roku, ale proces se protáhl a kód byl publikován teprve nyní. Kód služby je napsán v […]

Mozilla shrnula plány na podporu třetí verze manifestu Chrome ve Firefoxu

Společnost Mozilla zveřejnila plán realizace ve Firefoxu třetí verze manifestu Chrome, který určuje možnosti a zdroje poskytované rozšířením. Třetí verze manifestu byla kritizována kvůli narušení funkce mnoha rozšíření pro blokaci nežádaného obsahu a zajištění bezpečnosti. V Firefoxu mají v plánu implementovat téměř všechny možnosti a omezení nového manifestu, včetně deklarativního API pro filtrování obsahu (declarativeNetRequest), […]

Protokol QUIC získal status navrhovaného standardu

Výbor IETF (Internet Engineering Task Force), který se zabývá vývojem protokolů a architektury internetu, dokončil formulaci RFC pro protokol QUIC a publikoval související specifikace pod identifikátory RFC 8999 (vlastnosti protokolu nezávislé na verzi), RFC 9000 (transport přes UDP), RFC 9001 (TLS šifrování komunikačního kanálu QUIC) a RFC 9002 (řízení přetížení a určení ztráty paketů při přenosu dat). […]

Společnost Virtuozzo vydala distribuci VzLinux, zaměřenou na náhradu CentOS 8.

Společnost Virtuozzo (dříve divize společnosti Parallels), vyvíjející serverový software pro virtualizaci na základě otevřených projektů, zahájila veřejné distribuce disku VzLinux, který byl dříve používán jako základní operační systém pro vyvíjenou platformu virtualizace a různé komerční produkty. Od této chvíle je VzLinux k dispozici všem zájemcům a je prezentován jako náhrada za CentOS 8, připravený pro pracovní nasazení. K dispozici ke stažení […]

Vydání distribuce Simply Linux 9.1

Společnost Bazalt SPO oznámila vydání disku Simply Linux 9.1, postaveného na deváté platformě ALT. Produkt je distribuován na základě licenční smlouvy, která nepřenáší právo na distribuci disku, ale umožňuje bez omezení používat systém fyzickým a právnickým osobám. Disk je dodáván v sestavách pro architektury x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) a může […]

Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery 🔥 Koupit spolehlivý hosting pro webové stránky s ochranou proti DDoS, VPS VDS servery | ProHoster