Udgivelsen af FreeBSD 12.3

FreeBSD 12.3 er blevet frigivet og er tilgængelig for arkitekturerne amd64, i386, powerpc, powerpc64, powerpcspe, sparc64 samt armv6, armv7 og aarch64. Der er desuden forberedt billeder til virtualiseringssystemer (QCOW2, VHD, VMDK, raw) og cloud-miljøer som Amazon EC2. FreeBSD 13.1 forventes at blive udgivet i foråret 2022.

Nøgleinnovationer:

  • En script /etc/rc.final er blevet tilføjet, som kører i den sidste fase af processen efter alle brugerprocesser er afsluttet.
  • I ipfw-filterpakken er der tilføjet en dnctl-kommando til at administrere indstillingerne for dummynet trafikbegrænsningssystem.
  • Der er tilføjet sysctl kern.crypto til at styre kernelens krypteringssystem samt en debug sysctl debug.uma_reclaim.
  • Der er tilføjet sysctl net.inet.tcp.tolerate_missing_ts, som tillader TCP-pakker uden tidsstempler (timestamp option, RFC 1323/RFC 7323).
  • I GENERIC-kernen for arkitekturen amd64 er COMPAT_LINUXKPI muligheden blevet inkluderet, og mlx5en-driveren (NVIDIA Mellanox ConnectX-4/5/6) er aktiveret.
  • Bootloaderen har nu mulighed for at starte operativsystemet fra en ramdisk, og der er implementeret support til ZFS-mulighederne com.delphix:bookmark_written og com.datto:bookmark_v2.
  • Biblioteket fetch har fået tilføjet support til FTP-proxyrouting over HTTPS.
  • I pakkehåndteringssystemet pkg for kommandoerne "bootstrap" og "add" er der implementeret flaget "-r" til angivelse af repository. Brug af miljøvariabler fra pkg.conf-filen er sikret.
  • I growfs-værktøjet er der nu mulighed for at arbejde med filsystemer monteret i skrivebeskyttet tilstand.
  • I etcupdate-værktøjet er der implementeret en tilstandsretur til at gendanne en eller flere filer. Flaget "-D" er tilføjet til angivelse af målmappe. Det er sikret, at data kan udtrækkes ved brug af en midlertidig mappe, og der er tilføjet håndtering af SIGINT.
  • I værktøjerne freebsd-update og freebsd-version er flaget "-j" tilføjet for at supportere jail-miljøer.
  • cpuset-værktøjet kan nu anvendes i jail-miljøer til at ændre parametre for underliggende jail.
  • cmp-værktøjet har fået tilføjet valgmuligheder: "-b" (—print-bytes) til at vise de forskellige bytes, "-i" (—ignore-initial) til at ignorere et bestemt antal indledende bytes, "-n" (—bytes) til at begrænse antallet af sammenlignede bytes.
  • daemon-værktøjet har fået et flag "-H" til behandling af SIGHUP og genåbning af filen, hvori outputtet skal skrives (tilføjet for at understøtte newsyslog).
  • I fstyp-værktøjet giver flaget "-l" mulighed for at identificere og vise exFAT-filsystemer.
  • I værktøjet mergemaster er der implementeret støtte til håndtering af symbolske links under opdatering.
  • I værktøjet newsyslog er der tilføjet en "E"-flag for at deaktivere rotation af tomme logs.
  • I værktøjet tcpdump er det nu muligt at dekode pakker på pfsync interfaces.
  • I værktøjet top er der tilføjet en filterkommando "\/" for kun at vise processer eller argumenter, der matcher den angivne streng.
  • I unzip er der tilføjet understøttelse af adgangskodebeskyttede arkiver.
  • Forbedret hardwareunderstøttelse. Der er tilføjet PCI-enheds-id'er for AHCI-controllere fra ASMedia ASM116x og I2C-controllere fra Intel Gemini Lake. Understøttelse er tilføjet for netværksadaptere fra Mikrotik 10/25G og trådløse kort fra Intel Killer Wireless-AC 1550i, Mercusys MW150US, TP-Link Archer T2U v3, D-Link DWA-121, D-Link DWA-130 rev F1, ASUS USB-N14. Ny driver igc til ethernet-controllere fra Intel I225 2.5G/1G/100MB/10MB er tilføjet.
  • Netgraph-noden ng_bridge er tilpasset til SMP-systemer. Noden ng_nat har fået tilføjet støtte for CGN (Carrier Grade NAT, RFC 6598). Der er mulighed for at indsætte ng_source noden i enhver del af Netgraph-netværket.
  • I rctl-driveren, der bruges til at begrænse ressourcer, er der tilføjet mulighed for at sætte en ressourceforbrugsgrænse til 0.
  • I vlan-interfacet er der tilføjet støtte til trafikprioritering og kapacitetsstyring via ALTQ.
  • I driverne amdtemp og amdsmn er der implementeret support for CPU Zen 3 "Vermeer" og APU Ryzen 4000 (Zen 2, "Renoir").
  • Versionerne af de eksterne applikationer i grundsystemet er opdateret: awk 20210221, bc 5.0.0, less 581.2, Libarchive 3.5.1, OpenPAM Tabebuia, OpenSSL 1.1.1l, SQLite3 3.35.5, TCSH 6.22.04, Subversion 1.14.1, nvi 2.2.0-3bbdfe4. Værktøjet unzip er synkroniseret med koden fra NetBSD.

Kilde: opennet.ru

Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere 🔥 Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere | ProHoster