Efter otte måneders udvikling er versionen af OpenSSL 3.2.0 frigivet, som implementerer SSL/TLS-protokoller og forskellige krypteringsalgoritmer. Understøttelsen af OpenSSL 3.2 vil fortsætte indtil den 23. november 2025. Understøttelsen af de tidligere versioner OpenSSL 3.1 og 3.0 LTS vil vare indtil marts 2025 og september 2026 henholdsvis. Understøttelsen af version 1.1.1 ophører i september i år. Projektkoden distribueres under Apache 2.0-licensen.
De vigtigste nyheder i OpenSSL 3.2.0:
- Klientstøtte til QUIC-protokollen (RFC 9000) er tilføjet, som bruges som transport i HTTP/3-protokollen. Implementeringen inkluderer blandt andet muligheden for at transmittere flere strømme gennem en enkelt kommunikationskanal. Komponenterne til brug af QUIC på servere vil være inkluderet i OpenSSL 3.3, som forventes at blive offentliggjort senest den 30. april 2024.
QUIC er en overbygning på UDP-protokollen, der understøtter multiplexing af flere forbindelser og giver krypteringsmetoder, der er ækvivalente med TLS/SSL. Protokollen blev skabt i 2013 af Google som et alternativ til TCP+TLS-kombinationen for web, der løser problemerne med lang oprettelsestid og forhandlingsforbindelser i TCP og eliminerer forsinkelser ved pakktab under datatransmission.
- I TLS er understøttelse af en udvidelse til komprimering af certifikater under forbindelsesforhandling (RFC 8879) implementeret, hvilket gør det muligt at accelerere oprettelsen af forbindelsen, da en stor del af trafikmængden under forbindelsesforhandlingerne bruges til transmission af certifikatdata. Komprimering understøttes ved hjælp af zlib-, zstd- og Brotli-biblioteker.
- Understøttelse af den deterministiske variant af digitale signaturer, ECDSA (Deterministic ECDSA, RFC 6979), er tilføjet, hvor en hash HMAC-SHA256 af den private nøgle og den skrifte meddelsetekst bruges i stedet for en tilfældig sekvens til signaturgenerering. Dette sikrer, at der altid opnås den samme signatur i forskellige signaturoperationer, men forhindrer lækage af data, som kan bruges til at bestemme den private nøgle (den private nøgle kan bestemmes, hvis der er mindst to signaturer for forskellige data, der er genereret ved hjælp af en gentagen tilfældig sekvens).
- Understøttelse af udvidede varianter af digitale signaturer med offentlig nøgle Ed25519 og Ed448: Ed25519ctx, Ed25519ph og Ed448ph (RFC 8032) er tilføjet.
- Støtte til AES-GCM-SIV krypteringsmetoden (RFC 8452) er tilføjet, som kombinerer den høje ydeevne fra GCM (Galois/Counter Mode) med modstandsdygtighed over for lækager ved genbrug af tilfældige nonce-koder.
- Funktionen til generering af Argon2-nøgler (RFC 9106), som vandt konkurrencen om hash-funktioner til adgangskoder i 2015, er blevet implementeret. Muligheden for at bruge tråd-pooler er tilføjet.
- Støtte til hybrid kryptering baseret på HPKE (Hybrid Public Key Encryption, RFC 9180) mekanismen er tilføjet, som kombinerer enkelheden ved nøgleoverførsel i offentlig nøglekryptering med den høje ydeevne af symmetrisk kryptering (data krypteres med en hurtig symmetrisk nøgle, mens selve nøglen krypteres med en langsommere asymmetrisk metode).
- Muligheden for at bruge "rå" (raw) offentlige nøgler i TLS (RFC 7250) er blevet implementeret.
- Support for hurtig åbning af TCP-forbindelser (TFO — TCP Fast Open, RFC 7413) er tilføjet, hvilket gør det muligt at reducere antallet af trin i forbindelseetableringen ved at kombinere det første og andet trin i den klassiske 3-trins handshake-proces til én anmodning, hvilket muliggør afsendelse af data i begyndelsen af forbindelseetableringen.
- Støtte til udskiftelige digitale underskriftsordninger i TLS, der gør det muligt at bruge tredjepartsimplementeringer af algorithmer, for eksempel til brug af algoritmer modstandsdygtige over for angreb fra kvantecomputere i TLS, er blevet implementeret.
- I TLS 1.3 er støtte til beskyttede elliptiske kurver fra Brainpool blevet tilføjet.
- Støtte til SM4-XTS processorinstruktioner er tilføjet.
- På Windows-platformen er det blevet muligt at bruge det systemlagrede rodcertifikatlager (som standard deaktiveret). For at tilgå certifikaterne i Windows-lageret er URI’en 'org.openssl.winstore://'.
Kilde: opennet.ru
