Implementering af kryptografiske algoritmer i GOST på Java.

Crypto-gost-biblioteket er offentliggjort med implementering af GOST-kryptoalgoritmer i Java, uden brug af ekstra afhængigheder. I modsætning til implementeringen af GOST-algoritmer fra biblioteket Castle Bouncy Castle, tilbyder crypto-gost højere ydeevne ved kryptering med "Græshoppe"-algoritmen, løser specifikke sikkerhedsproblemer og giver enkle wrappers, der ikke kræver dybdegående viden om kryptografi. Koden leveres under en egen tilladelseslicens, der tillader distribution, ændring og oprettelse af afledte værker uden begrænsninger.

Understøttede algoritmer:

  • GOST R 34.11-2012 (RFC 6986) — hash-funktion "Stribog" 256 og 512 bit.
  • GOST R 34.12-2015 — blokkrypter "Græshoppe", nøgle 256 bit.
  • GOST R 34.13-2015 — krypteringsmetoder CBC, CFB, CTR (GAMMA), OFB; autentificering (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektronisk underskrift 256 og 512 bit.
  • HMAC-Stribog (RFC 7836, HMAC-Streebog-256 og HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-tilstand for Græshoppe (RFC 9058). Kompatibel med OpenSSL.
  • SCrypt (RFC 7914) — funktion til at generere nøgler baseret på adgangskode.

Kilde: opennet.ru

Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere 🔥 Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere | ProHoster