Kategori: Internettet Nyheder

Koden til tjenesten HaveIBeenPwned er åbnet

Troy Hunt har åbnet kildekoden til tjenesten Have I Been Pwned? (haveibeenpwned.com), der kontrollerer en database med 11,2 milliarder konti, der er blevet kompromitteret efter angreb på 538 websteder. Oprindeligt blev det annonceret i august sidste år, at koden til projektet ville blive åbnet, men processen blev forsinket, og koden blev først offentliggjort nu. Tjenestens code er skrevet i […]

Mozilla har opsummeret planer for at understøtte den tredje version af Chrome-manifestet i Firefox

Mozilla har offentliggjort en plan for implementeringen af den tredje version af Chrome-manifestet i Firefox, som definerer de muligheder og ressourcer, der er tilgængelige for udvidelser. Den tredje version af manifestet er blevet kritiseret for at forstyrre mange udvidelsers funktioner til blokering af uønsket indhold og sikring af sikkerhed. I Firefox har de til hensigt at implementere næsten alle muligheder og begrænsninger fra det nye manifest, herunder et deklarativt API til filtrering af indhold (declarativeNetRequest), […]

QUIC-protokollen er blevet anerkendt som et foreslået standard

IETF (Internet Engineering Task Force), der arbejder med udviklingen af internetprotokoller og -arkitektur, har afsluttet oprettelsen af RFC for QUIC-protokollen og offentliggjort de tilhørende specifikationer med ID'erne RFC 8999 (versionsuafhængige protokol egenskaber), RFC 9000 (transport over UDP), RFC 9001 (TLS-kryptering af QUIC-forbindelsen) og RFC 9002 (overbelastningsstyring og pakke-tab definition under datatransmission). […]

Virtuozzo har offentliggjort distributionen VzLinux, der er rettet mod at erstatte CentOS 8

Virksomheden Virtuozzo (tidligere en del af Parallels), der udvikler serversoftware til virtualisering baseret på åbne projekter, er begyndt offentlig distribution af VzLinux, som tidligere blev brugt som grundlæggende operativsystem for den virtualiseringsplatform, der udvikles af virksomheden, samt forskellige kommercielle produkter. VzLinux er nu tilgængelig for alle og positioneres som en erstatning for CentOS 8, klar til arbejdsimplementeringer. Til download […]

Udgivelsen af distributionen Simply Linux 9.1

Virksomheden Basalt SPO har annonceret udgivelsen af distributionen Simply Linux 9.1, der er bygget på den niende ALT-platform. Produktet distribueres under en licensaftale, der ikke overfører distributionsretten, men som tillader ubegrænset brug af systemet for både fysiske og juridiske personer. Distributionen leveres i samlinger til arkitekturer x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) og kan […]

Immudb 1.0-databasen er udgivet, som sikrer beskyttelse mod datamanipulation.

En betydelig udgivelse af immudb 1.0-databasen er præsenteret, som garanterer uforanderlighed og bevarelse af alle tidligere tilføjede data, samt sikrer beskyttelse mod retroaktive ændringer og giver mulighed for kryptografisk bevis for ejerskab af data. Projektet udviklede sig oprindeligt som et specialiseret NoSQL-lager, der manipulerede data i nøgle/værdi-format, men fra version 1.0 positioneres immudb som en fuldgyldig database med SQL-understøttelse. Koden […]

AlmaLinux 8.4-distributionen er tilgængelig, hvilket fortsætter udviklingen af CentOS 8.

Udgivelsen af AlmaLinux 8.4-distributionen er præsenteret, synkroniseret med Red Hat Enterprise Linux 8.4-distributionen. Bygningerne er forberedt til x86_64-arkitektur i form af en bootbar (709 MB), minimal (1,9 GB) og fuld afbildning (9,8 GB). Snart planlægges der også at offentliggøre bygninger til ARM-arkitektur. Distributionen er anerkendt som klar til produktionsimplementeringer og er fuldstændig identisk med RHEL i funktionalitet, da […]

Udgivelsen af Oracle Linux 8.4-distributionen.

Oracle har offentliggjort udgivelsen af Oracle Linux 8.4-distributionen, baseret på Red Hat Enterprise Linux 8.4-pakkegrundlag. En installations-iso med ubegrænset adgang til download, som er 8,6 GB i størrelse, er tilgængelig for x86_64 og ARM64 (aarch64) arkitekturer. Oracle Linux har ubegribtryg adgang til yum-repositoriet med binære opdateringspakker til fejlfinding (errata) og problemer […]

Hændelse med tab af kontrol over kanaler i IRC-netværket FreeNode.

Det nye team i IRC-netværket FreeNode har udtrykt beklagelse over den hændelse, der fandt sted i går, og som blev opfattet af nogle samfund som en overtagelse af deres IRC-kanaler. For eksempel har projekterne Ubuntu, Gentoo, HardenedBSD, LibreELEC, FSFE og Void Linux meldt sig ud fra FreeNode på grund af tab af kontrol over deres kanaler. Efter udtræden af administratorteamet, der dannede det nye netværk Libera.Chat på grund af konflikt med domæneejeren, har nogle åbne […]

Chrome 91-udgivelsen.

Google har præsenteret udgivelsen af webbrowseren Chrome 91. Samtidig er den stabile version af det frie projekt Chromium tilgængelig, som fungerer som basis for Chrome. Chrome-browseren adskiller sig ved brugen af Googles logoer, et system til at sende underretninger ved nedbrud, moduler til afspilning af beskyttet videoinhold (DRM), et automatisk opdateringssystem samt overførsel af RLZ-parametre under søgning. Den næste udgivelse, Chrome 92, er planlagt til den 20. juli. De vigtigste ændringer […]

Udgivelsen af paketfilteret nftables 0.9.9

Udgivelsen af paketfilteret nftables 0.9.9 er offentliggjort, som enheder pakker filtreringsgrænseflader for IPv4, IPv6, ARP og netværksbroer (med henblik på at erstatte iptables, ip6tables, arptables og ebtables). Samtidig er udgivelsen af den tilknyttede biblioteksfunktion libnftnl 1.2.0 offentliggjort, som tilbyder et lavniveau API til interaktion med nf_tables subsystemet. De nødvendige ændringer for nftables 0.9.9 er inkluderet i kernen Linux 5.13-rc1. I pakken […]

Udgivelsen af OSGeo-Live 14.0-distroen med en samling af geoinformationssystemer

Udgivelsen af OSGeo-Live 14.0-distributionen er præsenteret, som udvikles af den non-profit organisation OSGeo med det formål at give mulighed for hurtigt at udforske forskellige åbne geografiske informationssystemer uden behov for installation. Distributionen er bygget på en pakke af Lubuntu. Størrelsen på den bootbare billede er 4,4 GB (amd64, samt et billede til virtualiseringssystemer såsom VirtualBox, VMWare, KVM osv.). Den indeholder omkring 50 åbne applikationer […]

Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere 🔥 Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere | ProHoster