Kategori: Blog

Udgivelse af OpenRGB 0.6, værktøjet til styring af enheder med RGB-belysning

Den nye version af OpenRGB 0.6 er blevet offentliggjort, et gratis værktøj til kontrol af RGB-oplyste enheder. Pakken understøtter bundkort fra ASUS, Gigabyte, ASRock og MSI med RGB-understøttelse til kabinelys, hukommelsesmoduler med belysning fra ASUS, Patriot, Corsair og HyperX, grafikkort fra ASUS Aura/ROG, MSI GeForce, Sapphire Nitro og Gigabyte Aorus, samt forskellige LED-strimmel controllere (ThermalTake, Corsair, NZXT Hue+), […]

For language D, a runtime for programming microcontrollers is presented.

Dylan Graham har præsenteret et letvægts runtime kaldet LWDR til programmering i D-sproget for mikrocontrollere udstyret med et realtidsoperativsystem (RTOS). Den nuværende version er målrettet ARM Cortex-M mikrocontrollere. Udviklingen sigter ikke mod at dække alle D's funktioner, men giver grundlæggende værktøjer. Hukommelsesfordelingen sker manuelt (new / delete), garbage collection er ikke implementeret, men der er en række hooks til […]

Udgivelsen af applikationsserveren NGINX Unit 1.24.0

Udgivelsen af applikationsserveren NGINX Unit 1.24 har fundet sted, hvor løsningen til at køre web-applikationer på forskellige programmeringssprog (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js og Java) udvikles. NGINX Unit kan køre flere applikationer på forskellige programmeringssprog samtidigt, hvor startparametrene kan ændres dynamisk uden at ændre konfigurationsfiler og genstart. Koden […]

Udgivelsen af Electron 13.0.0, platformen til opbygning af applikationer baseret på Chromium-motoren

Udgivelsen af Electron platformen 13.0.0 er klar, som giver et selvstændigt framework til at udvikle tværs platform brugerapplikationer, der bruger komponenter fra Chromium, V8 og Node.js som grundlag. Den betydelige ændring i versionsnummeret er forbundet med opdateringen til Chromium 91-kodebasen, Node.js 14.16-platformen og JavaScript- motoren V8 9.1. Blandt ændringerne i den nye udgivelse: Tilføjet egenskaben process.contextIsolated for at bestemme udførelsen af den aktuelle […]

Udgivelsen af biblioteket PCRE2 10.37

Udgivelsen af biblioteket PCRE2 10.37 er klar, som tilbyder et sæt funktioner i C-sproget med implementering af regulære udtryk og mønstermatching, der er tæt på syntaks og semantik af regulære udtryk i Perl 5. PCRE2 er en redesignet implementering af det oprindelige PCRE bibliotek med et ikke-kompatibelt API og udvidede funktioner. Biblioteket er baseret på udviklerne af mailsystemet Exim og distribueres […]

Microsoft har udgivet Windows Package Manager 1.0, en pakkeadministrator der ligner apt og dnf.

Microsoft har offentliggjort udgivelsen af Windows Package Manager 1.0 (winget), som giver værktøjer til installation af applikationer ved hjælp af kommandolinjen. Koden er skrevet i C++ og distribueres under MIT-licensen. Pakkerne installeres fra et repository, der støttes ved hjælp af fællesskabet. I modsætning til installation af programmer fra Microsoft Store giver winget mulighed for at installere applikationer uden unødvendig marketing og […]

Udgivelserne af pakkehåndtereren Pacman 6.0 og installationsprogrammet Archinstall 2.2.0

Der er nye udgivelser af pakkehåndtereren Pacman 6.0.0 og installationsprogrammet Archinstall 2.2.0, der anvendes i distributionen Arch Linux. De vigtigste ændringer i Pacman 6.0: Understøttelse af download af filer i flere parallelle tråde er blevet tilføjet. Der er implementeret en linje, der viser downloadens fremdrift. For at deaktivere fremdriftsindikatoren kan man angive indstillingen «—noprogressbar» i pacman.conf. Automatisk spring over af spejle er sikret, når man tilgår dem […]

Koden til tjenesten HaveIBeenPwned er åbnet

Troy Hunt har åbnet kildekoden til tjenesten Have I Been Pwned? (haveibeenpwned.com), der kontrollerer en database med 11,2 milliarder konti, der er blevet kompromitteret efter angreb på 538 websteder. Oprindeligt blev det annonceret i august sidste år, at koden til projektet ville blive åbnet, men processen blev forsinket, og koden blev først offentliggjort nu. Tjenestens code er skrevet i […]

Mozilla har opsummeret planer for at understøtte den tredje version af Chrome-manifestet i Firefox

Mozilla har offentliggjort en plan for implementeringen af den tredje version af Chrome-manifestet i Firefox, som definerer de muligheder og ressourcer, der er tilgængelige for udvidelser. Den tredje version af manifestet er blevet kritiseret for at forstyrre mange udvidelsers funktioner til blokering af uønsket indhold og sikring af sikkerhed. I Firefox har de til hensigt at implementere næsten alle muligheder og begrænsninger fra det nye manifest, herunder et deklarativt API til filtrering af indhold (declarativeNetRequest), […]

QUIC-protokollen er blevet anerkendt som et foreslået standard

IETF (Internet Engineering Task Force), der arbejder med udviklingen af internetprotokoller og -arkitektur, har afsluttet oprettelsen af RFC for QUIC-protokollen og offentliggjort de tilhørende specifikationer med ID'erne RFC 8999 (versionsuafhængige protokol egenskaber), RFC 9000 (transport over UDP), RFC 9001 (TLS-kryptering af QUIC-forbindelsen) og RFC 9002 (overbelastningsstyring og pakke-tab definition under datatransmission). […]

Virtuozzo har offentliggjort distributionen VzLinux, der er rettet mod at erstatte CentOS 8

Virksomheden Virtuozzo (tidligere en del af Parallels), der udvikler serversoftware til virtualisering baseret på åbne projekter, er begyndt offentlig distribution af VzLinux, som tidligere blev brugt som grundlæggende operativsystem for den virtualiseringsplatform, der udvikles af virksomheden, samt forskellige kommercielle produkter. VzLinux er nu tilgængelig for alle og positioneres som en erstatning for CentOS 8, klar til arbejdsimplementeringer. Til download […]

Udgivelsen af distributionen Simply Linux 9.1

Virksomheden Basalt SPO har annonceret udgivelsen af distributionen Simply Linux 9.1, der er bygget på den niende ALT-platform. Produktet distribueres under en licensaftale, der ikke overfører distributionsretten, men som tillader ubegrænset brug af systemet for både fysiske og juridiske personer. Distributionen leveres i samlinger til arkitekturer x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) og kan […]

Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere 🔥 Køb pålidelig webhosting med DDoS-beskyttelse, VPS VDS-servere | ProHoster