{"id":111732,"date":"2023-11-24T15:10:17","date_gmt":"2023-11-24T13:10:17","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic"},"modified":"2023-11-24T15:10:17","modified_gmt":"2023-11-24T13:10:17","slug":"vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","status":"publish","type":"post","link":"https:\/\/prohoster.info\/da\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","title":{"rendered":"Udgivelsen af OpenSSL 3.2.0 med klientsupport for QUIC-protokollen","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Efter otte m\u00e5neders udvikling er versionen af OpenSSL 3.2.0 frigivet, som implementerer SSL\/TLS-protokoller og forskellige krypteringsalgoritmer. Underst\u00f8ttelsen af OpenSSL 3.2 vil forts\u00e6tte indtil den 23. november 2025. Underst\u00f8ttelsen af de tidligere versioner OpenSSL 3.1 og 3.0 LTS vil vare indtil marts 2025 og september 2026 henholdsvis. Underst\u00f8ttelsen af version 1.1.1 oph\u00f8rer i september i \u00e5r. Projektkoden distribueres under Apache 2.0-licensen.    <\/p>\n<p>De vigtigste nyheder i OpenSSL 3.2.0:   <\/p>\n<ul>\n<li class=\"l\"> Klientst\u00f8tte til QUIC-protokollen (RFC 9000) er tilf\u00f8jet, som bruges som transport i HTTP\/3-protokollen. Implementeringen inkluderer blandt andet muligheden for at transmittere flere str\u00f8mme gennem en enkelt kommunikationskanal. Komponenterne til brug af QUIC p\u00e5 <a class=\"wpil_keyword_link\" href=\"https:\/\/prohoster.info\/da\/server\/dts-gdansk\/\"   title=\"servere\" data-wpil-keyword-link=\"linked\"  data-wpil-monitor-id=\"4541\">servere<\/a> vil v\u00e6re inkluderet i OpenSSL 3.3, som forventes at blive offentliggjort senest den 30. april 2024.\n<p>QUIC er en overbygning p\u00e5 UDP-protokollen, der underst\u00f8tter multiplexing af flere forbindelser og giver krypteringsmetoder, der er \u00e6kvivalente med TLS\/SSL. Protokollen blev skabt i 2013 af Google som et alternativ til TCP+TLS-kombinationen for web, der l\u00f8ser problemerne med lang oprettelsestid og forhandlingsforbindelser i TCP og eliminerer forsinkelser ved pakktab under datatransmission.       <\/p>\n<li class=\"l\"> I TLS er underst\u00f8ttelse af en udvidelse til komprimering af certifikater under forbindelsesforhandling (RFC 8879) implementeret, hvilket g\u00f8r det muligt at accelerere oprettelsen af forbindelsen, da en stor del af trafikm\u00e6ngden under forbindelsesforhandlingerne bruges til transmission af certifikatdata. Komprimering underst\u00f8ttes ved hj\u00e6lp af zlib-, zstd- og Brotli-biblioteker.\n<li class=\"l\"> Underst\u00f8ttelse af den deterministiske variant af digitale signaturer, ECDSA (Deterministic ECDSA, RFC 6979), er tilf\u00f8jet, hvor en hash HMAC-SHA256 af den private n\u00f8gle og den skrifte meddelsetekst bruges i stedet for en tilf\u00e6ldig sekvens til signaturgenerering. Dette sikrer, at der altid opn\u00e5s den samme signatur i forskellige signaturoperationer, men forhindrer l\u00e6kage af data, som kan bruges til at bestemme den private n\u00f8gle (den private n\u00f8gle kan bestemmes, hvis der er mindst to signaturer for forskellige data, der er genereret ved hj\u00e6lp af en gentagen tilf\u00e6ldig sekvens).\n<li class=\"l\"> Underst\u00f8ttelse af udvidede varianter af digitale signaturer med offentlig n\u00f8gle Ed25519 og Ed448: Ed25519ctx, Ed25519ph og Ed448ph (RFC 8032) er tilf\u00f8jet.\n<li class=\"l\"> St\u00f8tte til AES-GCM-SIV krypteringsmetoden (RFC 8452) er tilf\u00f8jet, som kombinerer den h\u00f8je ydeevne fra GCM (Galois\/Counter Mode) med modstandsdygtighed over for l\u00e6kager ved genbrug af tilf\u00e6ldige nonce-koder.\n<li class=\"l\"> Funktionen til generering af Argon2-n\u00f8gler (RFC 9106), som vandt konkurrencen om hash-funktioner til adgangskoder i 2015, er blevet implementeret. Muligheden for at bruge tr\u00e5d-pooler er tilf\u00f8jet.\n<li class=\"l\"> St\u00f8tte til hybrid kryptering baseret p\u00e5 HPKE (Hybrid Public Key Encryption, RFC 9180) mekanismen er tilf\u00f8jet, som kombinerer enkelheden ved n\u00f8gleoverf\u00f8rsel i offentlig n\u00f8glekryptering med den h\u00f8je ydeevne af symmetrisk kryptering (data krypteres med en hurtig symmetrisk n\u00f8gle, mens selve n\u00f8glen krypteres med en langsommere asymmetrisk metode).\n<li class=\"l\"> I TLS er der mulighed for at bruge \"r\u00e5\" (raw) offentlige n\u00f8gler (RFC 7250).\n<li class=\"l\"> Der er tilf\u00f8jet st\u00f8tte til mekanismen til hurtig \u00e5bning af TCP-forbindelser (TFO \u2014 TCP Fast Open, RFC 7413), som reducerer antallet af trin til oprettelse af forbindelse ved at kombinere det f\u00f8rste og andet trin i den klassiske 3-trins proces for forbindelsesforhandling i \u00e9n anmodning og giver mulighed for at sende data i det indledende trin af forbindelsesoprettelsen.\n<li class=\"l\"> St\u00f8tte til udskiftelige digitale underskriftsordninger i TLS, der g\u00f8r det muligt at bruge tredjepartsimplementeringer af algorithmer, for eksempel til brug af algoritmer modstandsdygtige over for angreb fra kvantecomputere i TLS, er blevet implementeret.\n<li class=\"l\"> I TLS 1.3 er st\u00f8tte til beskyttede elliptiske kurver fra Brainpool blevet tilf\u00f8jet.\n<li class=\"l\"> St\u00f8tte til SM4-XTS processorinstruktioner er tilf\u00f8jet.\n<li class=\"l\"> P\u00e5 Windows-platformen er der mulighed for at bruge det systembaserede lager af rodcertifikater (som standard deaktiveret). For at tilg\u00e5 certifikaterne i Windows-lageret er der foresl\u00e5et en URI \"org.openssl.winstore:\/\/\".     <\/ul>\n<p>Kilde: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60174\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u043f\u0440\u043e\u0448\u043b\u044b\u0445 \u0432\u0435\u0442\u043e\u043a OpenSSL 3.1 \u0438 3.0 LTS \u043f\u0440\u043e\u0434\u043b\u0438\u0442\u0441\u044f \u0434\u043e \u043c\u0430\u0440\u0442\u0430 2025 \u0433\u043e\u0434\u0430 \u0438 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u044f 2026 \u0433\u043e\u0434\u0430 \u0441\u043e\u043e\u0442\u0432\u0435\u0442\u0441\u0442\u0432\u0435\u043d\u043d\u043e. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 \u0432\u0435\u0442\u043a\u0438 1.1.1 \u043f\u0440\u0435\u043a\u0440\u0430\u0449\u0435\u043d\u0430 \u0432 \u0441\u0435\u043d\u0442\u044f\u0431\u0440\u0435 \u044d\u0442\u043e\u0433\u043e \u0433\u043e\u0434\u0430. \u041a\u043e\u0434 \u043f\u0440\u043e\u0435\u043a\u0442\u0430 [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-111732","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/da\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"da_DK\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/da\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-11-24T13:10:17+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Udgivelsen af OpenSSL 3.2.0 med klientst\u00f8tte til QUIC-protokollen | ProHoster","description":"Efter otte m\u00e5neders udvikling er OpenSSL 3.2.0 biblioteket blevet udgivet med implementering af SSL\/TLS protokoller og forskellige krypteringsalgoritmer. Support for OpenSSL 3.2 vil blive opretholdt indtil 23. november 2025.","canonical_url":"https:\/\/prohoster.info\/da\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"da_DK","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0412\u044b\u043f\u0443\u0441\u043a OpenSSL 3.2.0 \u0441 \u043a\u043b\u0438\u0435\u043d\u0442\u0441\u043a\u043e\u0439 \u043f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u043e\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u0430 QUIC | ProHoster","og:description":"\u041f\u043e\u0441\u043b\u0435 \u0432\u043e\u0441\u044c\u043c\u0438 \u043c\u0435\u0441\u044f\u0446\u0435\u0432 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u043a\u0438 \u0441\u0444\u043e\u0440\u043c\u0438\u0440\u043e\u0432\u0430\u043d \u0440\u0435\u043b\u0438\u0437 \u0431\u0438\u0431\u043b\u0438\u043e\u0442\u0435\u043a\u0438 OpenSSL 3.2.0 \u0441 \u0440\u0435\u0430\u043b\u0438\u0437\u0430\u0446\u0438\u0435\u0439 \u043f\u0440\u043e\u0442\u043e\u043a\u043e\u043b\u043e\u0432 SSL\/TLS \u0438 \u0440\u0430\u0437\u043b\u0438\u0447\u043d\u044b\u0445 \u0430\u043b\u0433\u043e\u0440\u0438\u0442\u043c\u043e\u0432 \u0448\u0438\u0444\u0440\u043e\u0432\u0430\u043d\u0438\u044f. \u041f\u043e\u0434\u0434\u0435\u0440\u0436\u043a\u0430 OpenSSL 3.2 \u0431\u0443\u0434\u0435\u0442 \u043e\u0441\u0443\u0449\u0435\u0441\u0442\u0432\u043b\u044f\u0442\u044c\u0441\u044f \u0434\u043e 23 \u043d\u043e\u044f\u0431\u0440\u044f 2025 \u0433\u043e\u0434\u0430.","og:url":"https:\/\/prohoster.info\/da\/blog\/news\/vypusk-openssl-3-2-0-s-klientskoj-podderzhkoj-protokola-quic","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-11-24T13:10:17+00:00","article:modified_time":"2023-11-24T13:10:17+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts\/111732","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/comments?post=111732"}],"version-history":[{"count":1,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts\/111732\/revisions"}],"predecessor-version":[{"id":164419,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts\/111732\/revisions\/164419"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/media?parent=111732"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/categories?post=111732"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/tags?post=111732"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}