{"id":112077,"date":"2023-12-08T15:10:14","date_gmt":"2023-12-08T13:10:14","guid":{"rendered":"https:\/\/prohoster.info\/blog\/novosti-interneta\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp"},"modified":"2023-12-08T15:10:14","modified_gmt":"2023-12-08T13:10:14","slug":"avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","status":"publish","type":"post","link":"https:\/\/prohoster.info\/da\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","title":{"rendered":"GnuPGs grundl\u00e6gger etablerede LibrePGP, en fork af OpenPGP-standarden","gt_translate_keys":[{"key":"rendered","format":"text"}]},"content":{"rendered":"<p>Werner Koch, hovedudvikler og skaber af GnuPG (GNU Privacy Guard)-projektet, etablerede LibrePGP-projektet, der fokuserer p\u00e5 udviklingen af en opdateret specifikation som et alternativ til OpenPGP-standarden. Forken blev oprettet som svar p\u00e5 \u00e6ndringer, der var planlagt af IETF-arbejdsgruppen til den n\u00e6ste opdatering af OpenPGP-specifikationen (RFC-4880), som Koch fandt problematiske med hensyn til at bevare kompatibilitet og sikkerhed. De udviklere, der st\u00f8ttede fork, herunder dem fra GnuPG, RNP (OpenPGP-implementeringen fra Thunderbird) og Gpg4win, frygter, at de planlagte \u00e6ndringer vil v\u00e6re skadelige for eksisterende anvendelser baseret p\u00e5 OpenPGP, hvor brugerne forventer stabilitet i specifikationen p\u00e5 lang sigt og ikke er villige til at tolerere \u00e6ndringer, der bryder kompatibiliteten.    <\/p>\n<p>LibrePGP inkluderer nyttige forbedringer, som har v\u00e6ret under udvikling de seneste \u00e5r til den kommende version af OpenPGP-specifikationen, men udelukker samtidig \u00e6ndringer, der negativt p\u00e5virker sikringen af kompatibilitet. For eksempel, sammenlignet med den nuv\u00e6rende standard RFC-4880, accepterer LibrePGP f\u00f8lgende funktioner:  <\/p>\n<ul>\n<li class=\"l\"> Support for krypteringsalgoritmen Camellia (RFC-5581),\n<li class=\"l\"> Udvielser af ECC (Elliptic Curve Cryptography) for OpenPGP (RFC-6637).\n<li class=\"l\"> Obligatorisk st\u00f8tte til SHA2-256 hashes (SHA-1 og MD5 er blevet kategoriseret som ikke anbefalet, og muligheden for at dekryptere data uden integritetsverifikation er blevet set som helt for\u00e6ldet).\n<li class=\"l\"> For\u00f8gelse af st\u00f8rrelsen p\u00e5 kontrolaftryk (fingerprint) til 256 bit.\n<li class=\"l\"> Support for digitale signaturordninger som EdDSA og elliptiske kurver BrainpoolP256r1, BrainpoolP384r1, BrainpoolP512r1, Ed25519, Curve25519, Ed488 og X448.\n<li class=\"l\"> Support for algoritmen CRYSTALS-Kyber, der er modstandsdygtig over for kvantecomputere.\n<li class=\"l\"> Support for autentificeret krypteringsoperationer i OCB-formatet (Offset codebook mode).\n<li class=\"l\"> Implementering af den femte version af formatspecifikationen for digitale signaturer med metadata-beskyttelse.\n<li class=\"l\"> Support for udvidede underpakker med digitale signaturer.  <\/ul>\n<p>Hovedelementer i kritikken af den nye OpenPGP-specifikation:  <\/p>\n<ul>\n<li class=\"l\"> IETF-arbejdsgruppen fors\u00f8gte i stedet for en gradvis inkrementel opdatering af specifikationen at genopfinde standarden og foretage v\u00e6sentlige \u00e6ndringer, som bryder kompatibiliteten.\n<li class=\"l\"> P\u00e5tvungen st\u00f8tte for symmetrisk krypteringsmetode GCM (Galois\/Counter Mode), som er vanskelig at implementere korrekt, samtidig med at OCB (Offset Codebook Mode) ignoreres, hvis patentet for denne er udl\u00f8bet for flere \u00e5r siden.\n<li class=\"l\"> Tilf\u00f8jelse af valgfri pakker med tilf\u00e6ldig supplerende fyld for at beskytte mod trafik-analyse. If\u00f8lge skaberne af LibrePGP udg\u00f8r s\u00e5danne pakker med ukontrollerbart initialt tilf\u00e6ldigt fyld en trussel ved muligheden for at oprette skjulte datakanaler og omg\u00e5 systemer til forebyggelse af datal\u00e6k. Tidligere blev ideen om at inkludere supplerende fyld afvist, da det blev anset for at v\u00e6re et emne p\u00e5 applikationsniveau snarere end krypteringsniveau.\n<li class=\"l\"> Anvendelse af et modificeret ECDH-krypteringsskema (\u00e6ndring i OID-format), i stedet for at bruge den allerede beskrevet metode i RFC-6637 og implementeret i PGP og GnuPG.\n<li class=\"l\"> Fjernelse af nogle anvendte funktioner, s\u00e5som den klassiske metode til at tilbagekalde n\u00f8gler, flaget &#171;m&#187; for at markere MIME-data og flaget &#171;t&#187; til at adskille tekstdata fra bin\u00e6re (i stedet for flaget &#171;t&#187; er flaget &#171;u&#187; for tekst i UTF-8-encoding blevet introduceret).\n<li class=\"l\"> Afvisning af at inkludere beskyttelse af metadata i den nye signaturformat, hvilket betyder at man kan \u00e6ndre filnavnet uden at bryde signaturen.\n<li class=\"l\"> Den tvivlsomme mulighed for at tilf\u00f8je &#171;salt&#187; til underskrifter (Salted signature) for at \u00f8ge beskyttelsen mod pr\u00e6fiks-kollisionsangreb. V\u00e6rdien med salt kan bruges som en uafbrudt skjult kanal til at sende 32 byte data i underskriften.\n<li class=\"l\"> Skiftet i standarden mod prim\u00e6r brug til online kommunikation, hvilket ignorerer behovene for langtidsholdbare data.  <\/ul>\n<p>Tilh\u00e6ngere af OpenPGP har allerede offentliggjort kritik af kritikken. Hvis der ikke findes et kompromis, kan det f\u00f8re til stigende uoverensstemmelser i implementeringerne af OpenPGP\/LibrePGP. Delvist for at l\u00f8se dette problem har udviklerne af OpenPGP sikret den femte version af signaturformatet i en kompatibel form med LibrePGP og er g\u00e5et videre til at arbejde p\u00e5 den sjette version.<br \/>\n<br \/>Kilde: <a content=\"nofollow\" rel=\"nofollow\" href=\"https:\/\/www.opennet.ru\/opennews\/art.shtml?num=60256\">opennet.ru<\/a> <\/p>","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"excerpt":{"rendered":"<p>\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP. \u0424\u043e\u0440\u043a \u0431\u044b\u043b \u0441\u043e\u0437\u0434\u0430\u043d \u0432 \u043e\u0442\u0432\u0435\u0442 \u043d\u0430 \u0438\u0437\u043c\u0435\u043d\u0435\u043d\u0438\u044f, \u043d\u0430\u043c\u0435\u0447\u0435\u043d\u043d\u044b\u0435 \u0440\u0430\u0431\u043e\u0447\u0435\u0439 \u0433\u0440\u0443\u043f\u043f\u043e\u0439 IETF \u0434\u043b\u044f \u0432\u043d\u0435\u0441\u0435\u043d\u0438\u044f \u0432 \u0441\u043b\u0435\u0434\u0443\u044e\u0449\u0435\u0435 \u043e\u0431\u043d\u043e\u0432\u043b\u0435\u043d\u0438\u0435 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438 OpenPGP (RFC-4880) \u0438 \u0432\u043e\u0441\u043f\u0440\u0438\u043d\u044f\u0442\u044b\u0435 \u041a\u043e\u0445\u043e\u043c \u043a\u0430\u043a \u0441\u043e\u043c\u043d\u0438\u0442\u0435\u043b\u044c\u043d\u044b\u0435 \u0441 \u0442\u043e\u0447\u043a\u0438 \u0437\u0440\u0435\u043d\u0438\u044f \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u044f \u0441\u043e\u0432\u043c\u0435\u0441\u0442\u0438\u043c\u043e\u0441\u0442\u0438 \u0438 \u043e\u0431\u0435\u0441\u043f\u0435\u0447\u0435\u043d\u0438\u044f [&hellip;]<\/p>\n","protected":false,"gt_translate_keys":[{"key":"rendered","format":"html"}]},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[702],"tags":[],"class_list":["post-112077","post","type-post","status-publish","format-standard","hentry","category-news"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 5.0.3 - aioseo.com -->\n\t<meta name=\"description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"Yuri Gagarin\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/prohoster.info\/da\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 5.0.3\" \/>\n\t\t<meta property=\"og:locale\" content=\"da_DK\" \/>\n\t\t<meta property=\"og:site_name\" content=\"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster\" \/>\n\t\t<meta property=\"og:description\" content=\"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/prohoster.info\/da\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp\" \/>\n\t\t<meta property=\"og:image\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:secure_url\" content=\"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg\" \/>\n\t\t<meta property=\"og:image:width\" content=\"350\" \/>\n\t\t<meta property=\"og:image:height\" content=\"350\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2023-12-08T13:10:14+00:00\" \/>\n\t\t<meta property=\"article:publisher\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<meta property=\"article:author\" content=\"https:\/\/www.facebook.com\/prohoster\" \/>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"\ud83e\udd47Skaberen af GnuPG grundlagde LibrePGP, en fork af standarden OpenPGP | ProHoster","description":"Werner Koch, hovedudvikler og skaber af GnuPG (GNU Privacy Guard) projektet, grundlagde LibrePGP-projektet, som fokuserer p\u00e5 udviklingen af en opdateret specifikation, der er alternativ til standarden OpenPGP.","canonical_url":"https:\/\/prohoster.info\/da\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":null,"og:locale":"da_DK","og:site_name":"ProHoster | \u041a\u0443\u043f\u0438\u0442\u044c \u043d\u0430\u0434\u0435\u0436\u043d\u044b\u0439 \u0445\u043e\u0441\u0442\u0438\u043d\u0433 \u0434\u043b\u044f \u0441\u0430\u0439\u0442\u043e\u0432 \u0441 \u0437\u0430\u0449\u0438\u0442\u043e\u0439 \u043e\u0442 DDoS, VPS VDS \u0441\u0435\u0440\u0432\u0435\u0440\u044b","og:type":"article","og:title":"\ud83e\udd47\u0410\u0432\u0442\u043e\u0440 GnuPG \u043e\u0441\u043d\u043e\u0432\u0430\u043b LibrePGP, \u0444\u043e\u0440\u043a \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0430 OpenPGP | ProHoster","og:description":"\u0412\u0435\u0440\u043d\u0435\u0440 \u041a\u043e\u0445 (Werner Koch), \u043e\u0441\u043d\u043e\u0432\u043d\u043e\u0439 \u0440\u0430\u0437\u0440\u0430\u0431\u043e\u0442\u0447\u0438\u043a \u0438 \u0441\u043e\u0437\u0434\u0430\u0442\u0435\u043b\u044c \u043f\u0440\u043e\u0435\u043a\u0442\u0430 GnuPG (GNU Privacy Guard), \u043e\u0441\u043d\u043e\u0432\u0430\u043b \u043f\u0440\u043e\u0435\u043a\u0442 LibrePGP, \u0441\u043e\u0441\u0440\u0435\u0434\u043e\u0442\u043e\u0447\u0435\u043d\u043d\u044b\u0439 \u043d\u0430 \u0440\u0430\u0437\u0432\u0438\u0442\u0438\u0438 \u043e\u0431\u043d\u043e\u0432\u043b\u0451\u043d\u043d\u043e\u0439 \u0441\u043f\u0435\u0446\u0438\u0444\u0438\u043a\u0430\u0446\u0438\u0438, \u0430\u043b\u044c\u0442\u0435\u0440\u043d\u0430\u0442\u0438\u0432\u043d\u043e\u0439 \u0441\u0442\u0430\u043d\u0434\u0430\u0440\u0442\u0443 OpenPGP.","og:url":"https:\/\/prohoster.info\/da\/blog\/news\/avtor-gnupg-osnoval-librepgp-fork-standarta-openpgp","og:image":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:secure_url":"https:\/\/prohoster.info\/wp-content\/uploads\/2021\/11\/logo-350.jpg","og:image:width":350,"og:image:height":350,"article:published_time":"2023-12-08T13:10:14+00:00","article:modified_time":"2023-12-08T13:10:14+00:00","article:publisher":"https:\/\/www.facebook.com\/prohoster","article:author":"https:\/\/www.facebook.com\/prohoster"},"aioseo_meta_data":[],"gt_translate_keys":[{"key":"link","format":"url"}],"_links":{"self":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts\/112077","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/comments?post=112077"}],"version-history":[{"count":0,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/posts\/112077\/revisions"}],"wp:attachment":[{"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/media?parent=112077"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/categories?post=112077"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/prohoster.info\/da\/wp-json\/wp\/v2\/tags?post=112077"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}