Nach fast einem Jahr der Entwicklung wurde die neue stabile Version des Mailservers Postfix â 3.10.0 â veröffentlicht. Gleichzeitig wurde die UnterstĂŒtzung fĂŒr die Version Postfix 3.6 eingestellt, die Anfang 2021 veröffentlicht wurde. Der Code des Projekts ist in C geschrieben und wird unter den Lizenzen EPL 2.0 (Eclipse Public License) und IPL 1.0 (IBM Public License) verbreitet.
Postfix ist eines der wenigen Projekte, die hohe Sicherheit, ZuverlĂ€ssigkeit und Leistung vereinen, was durch eine Mehrprozessarchitektur erreicht wird, die einzelne Handler isoliert, sowie durch eine strenge Richtlinie zur Codegestaltung und zur PrĂŒfung von Patches. Zum Schutz vor Fehlern beim Umgang mit dem Speicher werden geschĂŒtzte Varianten von Funktionen zum Zuweisen und Freigeben von Speicher verwendet, sowie ein Satz abstrakter Wrapper-Funktionen fĂŒr die Arbeit mit Puffern (ĂberprĂŒfung auf PufferĂŒberlĂ€ufe und Zugriffe auf freigegebenen Speicher), Dateioperationen, der Formatierung von Ausgaben, gepuffertem Ein-/Ausgabe und der Bearbeitung von Zeichenfolgen (einschlieĂlich Möglichkeiten fĂŒr die Arbeit mit Zeichenfolgen beliebiger GröĂe und automatischer GröĂenĂ€nderung von Zeichenfolgen).
GemÀà einer automatisierten Umfrage im Februar wurden etwa 550.000 Mailserver registriert, ServerPostfix wird auf 37,64 % (vor einem Jahr 36,81 %) der Mailserver eingesetzt, der Anteil von Exim betrĂ€gt 56,03 % (vor einem Jahr 56,61 %), Sendmail â 3,39 % (3,60 %), MailEnable â 1,80 % (1,82 %), MDaemon â 0,39 % (0,40 %), Microsoft Exchange â 0,19 % (0,19 %), OpenSMTPD â 0,10 % (0,09 %).

Hauptneuheiten:
- Die Möglichkeit zur Verwendung von in TLS kryptografischen Algorithmen, die quantensicher sind, wurde hinzugefĂŒgt. Um diese Algorithmen nutzen zu können, ist die Verwendung der Entwicklungsversion der OpenSSL-Bibliothek 3.5 erforderlich, die noch in der Entwicklungsphase ist. FĂŒr die Auswahl von Post-Quanten-Algorithmen in Postfix wurde kein neuer Syntax fĂŒr TLS-Gruppen eingefĂŒhrt, sondern man verlieĂ sich auf die OpenSSL-Einstellungen, die bei der Installation der Parameter âtls_eecdh_auto_curvesâ und âtls_ffdhe_auto_groupsâ auf leere Werte gesetzt werden.
- UnterstĂŒtzung fĂŒr den Nachrichtenheader âTLS-Required: noâ (RFC 8689) wurde hinzugefĂŒgt, der eine Zustellung auch dann ermöglicht, wenn die in den Sicherheitseinstellungen von TLS festgelegte Richtlinie nicht umgesetzt werden kann. Bei Vorhandensein dieses Headers arbeitet der SMTP-Client im Modus âsmtp_tls_security_level = mayâ, d.h. das Zertifikat wird nicht ĂŒberprĂŒft. Server und kann auf die Verbindung mit DatenĂŒbertragung im Klartext zurĂŒckgesetzt werden. In der nĂ€chsten bedeutenden Version von Postfix beabsichtigt man, die SMTP-Erweiterung REQUIRETLS umzusetzen.
- UnterstĂŒtzung des Protokolls TLS-RPT (Transport Layer Security Reporting) hinzugefĂŒgt, das es ermöglicht, Fehler bei der Zustellung von Nachrichten zu verfolgen, die auftreten, wenn eine verschlĂŒsselte Verbindung, die durch die Verwendung von DANE (DNS-based Authentication of Named Entities) oder MTA-STS (MTA Strict Transport Security) vorgeschrieben ist, nicht hergestellt werden kann. Der EigentĂŒmer der E-Mail-Domain legt in DNS Parameter fĂŒr TLS-RPT fest, woraufhin die Mail-Server Berichte ĂŒber erfolgreiche und fehlerhafte TLS-Verbindungen an die MX-Server, die die Domain bedienen, senden werden. Die Umsetzung basiert auf der Bibliothek libtlsrpt.
- Die Einstellung âsmtpd_hide_client_session = yesâ wurde hinzugefĂŒgt, die das EinfĂŒgen von Informationen ĂŒber die Client-Sitzung beim Setzen des SMTP-Server--Headers âReceived:â deaktiviert. Beispiel fĂŒr einen gekĂŒrzten Header: âReceived: by mail.example.com (Postfix) id postfix-queue-id fĂŒr <user@example.com>; Tag, dd Mon yyyy hh:mm:ss tz-offset (zone)â.
- Die Möglichkeit zur MIME-Codierung (RFC 2047) von Namen in den generierten Postfix-Headers âFrom:â, die nicht-ASCII-Zeichen enthalten, wurde hinzugefĂŒgt. Das vorgeschlagene Codierungsschema ermöglicht es, ohne die Verwendung der SMTPUTF8-Erweiterung (RFC 6531) auszukommen, die nicht von allen Anwendungen unterstĂŒtzt wird. Das Ergebnis der MIME-Codierung sieht so aus: â=?charset?Q?gibberish?=â. Um die ursprĂŒngliche Codierung der Namen zu bestimmen, wurde der Parameter âfull_name_encoding_charsetâ hinzugefĂŒgt, der standardmĂ€Ăig auf utf8 gesetzt ist.
- Die Logik zur Verarbeitung von fehlerhaften Verbindungen wurde geĂ€ndert, wenn in den Einstellungen âmysql:â oder âpgsql:â nur ein Server angegeben ist. Ein solches Server wird jetzt als Lastverteiler angesehen, und im Falle eines einzelnen Fehlers wird die erneute Anfrage sofort ohne Verzögerung von 60 Sekunden gesendet.
- Im Milter wurde das Protokollieren von Informationen ĂŒber den Grund fĂŒr das QuarantĂ€ne von Nachrichten implementiert.
- Im SMTP-Server wurde das Ausgeben der Warteschlangen-ID oder der Werte âNOQUEUEâ im Log bei Verbindungsabbruch durch Timeout, Unterbrechung oder Ăberschreitung des Fehlerslimits sichergestellt. Der Cleanup-Prozess gibt dabei im Log âqueueid: canceledâ fĂŒr Nachrichten mit einer gestarteten, aber nicht abgeschlossenen Transaktion aus.
- Im Dovecot SASL-Client wird jetzt bei der Protokollierung von Nachrichten âUngĂŒltiger Authentifizierungsmechanismusâ der Authentifizierungsmechanismus angezeigt, der nicht verwendet werden konnte. Der SMTP-Server zeigt bei der Protokollierung von ârejectâ-EintrĂ€gen jetzt die Werte der Einstellungen sasl_method, sasl_username und sasl_sender an.
- Aufgrund der Ănderung des internen Protokolls, das vom Zustellagenten verwendet wird, ist nach dem Update der Postfix-Version ein Neustart ĂŒber den Befehl âpostfix reloadâ oder die Befehle âpostfix stopâ und âpostfix startâ erforderlich. Andernfalls wird die Warnung âunerwartetes Attribut smtputf8 von xxx-Socket (erwartet: sendopts)â im Protokoll ausgegeben.
Quelle: opennet.ru
