Veröffentlichung von Issuerd 0.1.17, einem Keycloak-kompatiblen Server fĂŒr IdentitĂ€ts- und Zugangsmanagement.

Die Version Issuerd 0.1.17 wurde veröffentlicht – ein IdentitĂ€ts- und Zugriffsmanagement-Server (IAM), der die Protokolle OpenID Connect und OAuth 2.x implementiert und mit der Keycloak-Plattform auf Datenmodell- und Management-REST-API-Ebene kompatibel ist. Es wurden Funktionen wie SSO, MFA (TOTP, WebAuthn/passkeys), Benutzerföderation aus LDAP und Kerberos/SPNEGO, Anmeldungen ĂŒber externe IdentitĂ€tsprovider (OIDC, soziale Netzwerke), anpassbare Login-Seiten mit Lokalisierung sowie deklarative Anfangskonfiguration ĂŒber YAML beim ersten Start umgesetzt. Der Server wurde in Rust geschrieben (unsafe-Code ist auf Attributebene verboten) und wird unter der Apache 2.0-Lizenz mit einer einzigen unabhĂ€ngigen BinĂ€rdatei verteilt, die sowohl die Verwaltungs- als auch die Benutzerkonsole integriert. Die Builds werden fĂŒr die Plattformen Linux, Windows und macOS (amd64 und
arm64).

Das Hauptmerkmal des Projekts ist die kontinuierliche ÜberprĂŒfung der KonformitĂ€t
mit dem offiziellen Testset der OpenID Foundation Conformance Suite (5.3.2). Die Tests werden in CI fĂŒr jede Veröffentlichung in einer isolierten Docker-Umgebung durchgefĂŒhrt. Modulare Ergebnisse werden im Repository gespeichert, und das vollstĂ€ndige Paket der Berichte wird jeder Veröffentlichung beigefĂŒgt.
Die Übereinstimmung mit Keycloak wird durch eine Reihe von Tests ĂŒberwacht. Offizielle Zertifizierungen sind in Planung.

Unter den Protokollen, die in Szenarien mit KI-Agenten gefragt sind, wurden DPoP (RFC 9449, Bindung des Tokens an den PrĂ€sentationsschlĂŒssel), Token-Austausch (RFC 8693, EinschrĂ€nkung der Berechtigungen beim Token-Austausch) und CIBA (Polling-Modus, BestĂ€tigung durch eine Person) implementiert. Außerdem werden PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dynamische Kundenregistrierung (RFC 7591/7592), und GerĂ€teautorisierung (RFC 8628) unterstĂŒtzt. Der vollstĂ€ndige Import von 100.000 Benutzern aus MS Active Directory dauert etwa 30 Sekunden.

Quelle: opennet.ru

ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server đŸ”„ ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server - ProHoster