Kategorie: Nachrichten aus dem Internet

JingOS 0.9, ein Distribution für Tablets, ist verfügbar

Die Veröffentlichung von JingOS 0.9, einer Distribution, die eine Umgebung bietet, die speziell für die Installation auf Tablets und Laptops mit Touchscreen optimiert ist, wurde bekanntgegeben. Das Projekt wird von dem chinesischen Unternehmen Jingling Tech entwickelt, das eine Niederlassung in Kalifornien hat. Das Entwicklungsteam besteht aus Mitarbeitern, die zuvor bei Lenovo, Alibaba, Samsung, Canonical/Ubuntu und Trolltech gearbeitet haben. Die Größe des Installationsabbilds beträgt 3 GB (x86_64). Die Entwicklungen des Projekts werden unter der Lizenz […]

Die Veröffentlichung von OpenRGB 0.6, einem Tool zur Steuerung von Geräten mit RGB-Beleuchtung

Eine neue Version von OpenRGB 0.6, einem freien Tool zur Steuerung von Geräten mit RGB-Beleuchtung, wurde veröffentlicht. Das Paket unterstützt Motherboards von ASUS, Gigabyte, ASRock und MSI mit RGB-Subsystem zur Gehäusebeleuchtung, RAM-Module mit Beleuchtung von ASUS, Patriot, Corsair und HyperX, Grafikkarten wie ASUS Aura/ROG, MSI GeForce, Sapphire Nitro und Gigabyte Aorus sowie verschiedene LED-Strip-Controller (ThermalTake, Corsair, NZXT Hue+), […]

Für die Sprache D wurde ein Runtime für die Programmierung von Mikrocontrollern vorgestellt.

Dylan Graham stellte ein leichtgewichtiges Runtime LWDR für die Programmierung von Mikrocontrollern in der Sprache D vor, die mit einem Echtzeitbetriebssystem (RTOS) ausgestattet sind. Die aktuelle Version ist auf ARM Cortex-M Mikrocontroller ausgerichtet. Die Entwicklung hat nicht das Ziel, alle Möglichkeiten von D vollständig abzudecken, bietet jedoch grundlegende Mittel. Die Speicherzuteilung erfolgt manuell (new / delete), ein Garbage Collector ist nicht implementiert, es gibt jedoch eine Reihe von Hooks für […]

Erscheinung des Anwendungsservers NGINX Unit 1.24.0

Die Veröffentlichung des NGINX Unit 1.24-Anwendungsservers fand statt, innerhalb dessen eine Lösung zur Ausführung von Webanwendungen in verschiedenen Programmiersprachen (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js und Java) entwickelt wird. Unter NGINX Unit können gleichzeitig mehrere Anwendungen in verschiedenen Programmiersprachen ausgeführt werden, deren Startparameter dynamisch geändert werden können, ohne die Konfigurationsdateien bearbeiten oder neu starten zu müssen. Der Code […]

Erscheinung von Electron 13.0.0, Plattform zur Erstellung von Anwendungen auf Basis der Chromium-Engine

Die Veröffentlichung der Electron-Plattform 13.0.0 wurde vorbereitet, die ein eigenständiges Framework zur Entwicklung plattformübergreifender Benutzeranwendungen bereitstellt, das auf Komponenten von Chromium, V8 und Node.js basiert. Die erhebliche Versionsänderung hängt mit dem Upgrade auf die Chromium 91-Codebasis, Node.js 14.16 und die V8 9.1 JavaScript-Engine zusammen. Zu den Änderungen in der neuen Version gehören: Das Prozessattribut process.contextIsolated wurde hinzugefügt, um die Ausführung des aktuellen […]

Veröffentlichung der Bibliothek PCRE2 10.37

Die Veröffentlichung der PCRE2-Bibliothek 10.37 ist erfolgt, die eine Sammlung von Funktionen in C zur Implementierung regulärer Ausdrücke und Mustererkennung (pattern matching) bereitstellt, die in Syntax und Semantik den regulären Ausdrücken von Perl 5 nahekommen. PCRE2 ist eine überarbeitete Umsetzung der ursprünglichen PCRE-Bibliothek mit einem inkompatiblen API und erweiterten Funktionen. Die Bibliothek wurde von den Entwicklern des E-Mail-Servers Exim erstellt und wird […]

Microsoft hat den Windows Package Manager 1.0 veröffentlicht, der apt und dnf ähnelt

Microsoft hat die Veröffentlichung des Windows Package Managers 1.0 (winget) bekannt gegeben, der Werkzeuge zur Installation von Anwendungen über die Befehlszeile bereitstellt. Der Code ist in C++ geschrieben und wird unter der MIT-Lizenz veröffentlicht. Pakete werden aus einem Repository installiert, das mit Unterstützung der Community gepflegt wird. Im Gegensatz zur Installation von Programmen aus dem Microsoft Store ermöglicht winget die Installation von Anwendungen ohne überflüssiges Marketing und […]

Die Veröffentlichungen des Paketmanagers Pacman 6.0 und des Installers Archinstall 2.2.0

Die neuen Versionen des Paketmanagers Pacman 6.0.0 und des Installationsprogramms Archinstall 2.2.0 sind im Arch Linux-Distribution verfügbar. Die wichtigsten Änderungen in Pacman 6.0: Unterstützung für das Herunterladen von Dateien in mehreren parallelen Threads wurde hinzugefügt. Es wurde eine Fortschrittsanzeige für das Herunterladen von Daten implementiert. Um die Fortschrittsanzeige in der pacman.conf zu deaktivieren, kann die Option „—noprogressbar“ angegeben werden. Automatisches Überspringen von Mirrors wurde gewährleistet, wenn diese angesprochen werden […].

Der Code des Passwortprüfungsdienstes HaveIBeenPwned wurde veröffentlicht

Troy Hunt hat den Quellcode des Dienstes zur Überprüfung kompromittierter Passwörter „Have I Been Pwned?“ (haveibeenpwned.com) veröffentlicht, der eine Prüfung in einer Datenbank von 11,2 Milliarden gestohlenen Konten aus Hacks von 538 Websites durchführt. Ursprünglich wurde im August letzten Jahres angekündigt, den Code des Projekts zu öffnen, aber der Prozess zog sich hin und der Code wurde erst jetzt veröffentlicht. Der Code des Dienstes ist in […] geschrieben.

Mozilla hat die Pläne zur Unterstützung der dritten Version des Chrome-Manifests in Firefox zusammengefasst.

Mozilla hat einen Plan zur Implementierung der dritten Version des Chrome-Manifests in Firefox veröffentlicht, das die Möglichkeiten und Ressourcen für Erweiterungen definiert. Die dritte Version des Manifests wurde wegen der Beeinträchtigung der Funktionalität vieler Erweiterungen zur Blockierung unerwünschten Inhalts und zur Gewährleistung der Sicherheit kritisiert. In Firefox beabsichtigt man, fast alle Funktionen und Einschränkungen des neuen Manifests umzusetzen, einschließlich der deklarativen API zur Inhaltsfilterung (declarativeNetRequest), […].

Das QUIC-Protokoll hat den Status eines vorgeschlagenen Standards erhalten.

Das IETF-Komitee (Internet Engineering Task Force), das sich mit der Entwicklung von Protokollen und der Architektur des Internets befasst, hat die RFC für das QUIC-Protokoll abgeschlossen und die zugehörigen Spezifikationen unter den Identifikatoren RFC 8999 (versionsunabhängige Eigenschaften des Protokolls), RFC 9000 (Transport über UDP), RFC 9001 (TLS-Verschlüsselung des QUIC-Kommunikationskanals) und RFC 9002 (Staukontrolle und Verlustbestimmung von Datenpaketen) veröffentlicht. […]

Das Unternehmen Virtuozzo hat die Distribution VzLinux veröffentlicht, die als Ersatz für CentOS 8 gedacht ist.

Das Unternehmen Virtuozzo (ehemals eine Sparte von Parallels), das Server-Software für Virtualisierung basierend auf Open-Source-Projekten entwickelt, hat mit der öffentlichen Verbreitung der Distribution VzLinux begonnen, die zuvor als Basisbetriebssystem für die von dem Unternehmen entwickelte Virtualisierungsplattform sowie verschiedene kommerzielle Produkte verwendet wurde. VzLinux ist nun für alle Interessierten verfügbar und positioniert sich als Ersatz für CentOS 8, der für den produktiven Einsatz bereit ist. Zum Herunterladen […]

Zuverlässiges Hosting für Websites mit DDoS-Schutz kaufen, VPS VDS Server 🔥 Zuverlässiges Hosting für Websites mit DDoS-Schutz kaufen, VPS VDS Server - ProHoster