Veröffentlichung des DNS-Servers BIND 9.16.0

Nach 11 Monaten Entwicklung hat das Konsortium ISC vor die erste stabile Version des neuen wichtigen Zweigs des DNS-Servers BIND 9.16 veröffentlicht. Die UnterstĂŒtzung des Zweigs 9.16 wird bis zum zweiten Quartal 2023 im Rahmen eines erweiterten Wartungszyklus bereitgestellt. Updates fĂŒr den vorherigen LTS-Zweig 9.11 werden bis Dezember 2021 veröffentlicht. Die UnterstĂŒtzung des Zweigs 9.14 endet in drei Monaten.

Haupt- Neuheiten:

  • KASP (Key and Signing Policy) wurde hinzugefĂŒgt, eine vereinfachte Möglichkeit zur Verwaltung von SchlĂŒsseln und digitalen Signaturen fĂŒr DNSSEC, die auf vordefinierten Regeln basiert, die durch die Direktive „dnssec-policy“ definiert sind. Mit dieser Direktive kann die Generierung neuer erforderlicher SchlĂŒssel fĂŒr DNS-Zonen konfiguriert und die Anwendung von ZSK- und KSK-SchlĂŒsseln automatisiert werden.
  • Das Netzwerksubsystem wurde grundlegend ĂŒberarbeitet und auf einen Mechanismus zur asynchronen Verarbeitung von Anfragen umgestellt, der auf der Bibliothek basiert libuv.
    Die Überarbeitung hat bisher zu keinen sichtbaren Änderungen gefĂŒhrt, wird jedoch in zukĂŒnftigen Versionen die Umsetzung erheblicher Leistungsoptimierungen ermöglichen und die UnterstĂŒtzung neuer Protokolle wie DNS ĂŒber TLS hinzufĂŒgen.
  • Der Prozess der Verwaltung von DNSSEC-Vertrauensanker (Trust Anchor, der mit der Zone verbundene öffentliche SchlĂŒssel zur Authentifizierung dieser Zone) wurde verbessert. Anstelle der jetzt als veraltet erklĂ€rten Einstellungen trusted-keys und managed-keys wurde eine neue Direktive trust-anchors eingefĂŒhrt, die die Verwaltung beider SchlĂŒsseltypen ermöglicht.

    Bei Verwendung von trust-anchors mit dem SchlĂŒsselwort initial-key verhĂ€lt sich diese Direktive identisch wie managed-keys, d.h. sie definiert die Einstellung des Vertrauensankers gemĂ€ĂŸ RFC 5011. Bei Verwendung von trust-anchors mit dem SchlĂŒsselwort static-key entspricht das Verhalten der Direktive trusted-keys, d.h. sie definiert einen permanenten SchlĂŒssel, der nicht automatisch aktualisiert wird. In trust-anchors werden auch zwei weitere SchlĂŒsselwörter initial-ds und static-ds angeboten, die die Verwendung von Vertrauensankern im Format DS (Delegation Signer) anstelle von DNSKEY ermöglichen, was die Konfiguration von Bindungen fĂŒr noch nicht veröffentlichte SchlĂŒssel ermöglicht (in Zukunft plant die Organisation IANA, das DS-Format fĂŒr SchlĂŒssel von Root-Zonen zu verwenden).

  • In die Tools dig, mdig und delv wurde die Option „+yaml“ fĂŒr die Ausgabe im YAML-Format hinzugefĂŒgt.
  • Im Tool dig wurde die Option „+[no]unexpected“ hinzugefĂŒgt, die den Empfang von Antworten von Hosts erlaubt, die sich von dem Server unterscheiden, an den die Anfrage gesendet wurde.
  • In das Dienstprogramm dig wurde die Option «+[no]expandaaaa» hinzugefĂŒgt, mit der IPv6-Adressen in AAAA-EintrĂ€gen im vollstĂ€ndigen 128-Bit-Format angezeigt werden, anstatt im RFC 5952-Format.
  • Die Möglichkeit, Gruppen von StatistikkanĂ€len umzuschalten, wurde hinzugefĂŒgt.
  • DS- und CDS-EintrĂ€ge werden jetzt nur auf Basis von SHA-256-Hashes generiert (die Generierung auf Basis von SHA-1 wurde eingestellt).
  • FĂŒr DNS-Cookie (RFC 7873) wird standardmĂ€ĂŸig der SipHash 2-4 Algorithmus verwendet, und die UnterstĂŒtzung fĂŒr HMAC-SHA wurde eingestellt (AES bleibt erhalten).
  • Die Ausgaben der Befehle dnssec-signzone und dnssec-verify werden jetzt an den Standardausgabestrom (STDOUT) geleitet, wĂ€hrend in STDERR nur Fehlermeldungen und Warnungen ausgegeben werden (bei Angabe der Option «-f» wird auch die signierte Zone ausgegeben). Um die Ausgabe zu dĂ€mpfen, wurde die Option «-q» hinzugefĂŒgt.
  • Der DNSSEC-Validierungscode wurde ĂŒberarbeitet und von doppeltem Code mit anderen Subsystemen befreit.
  • FĂŒr die Ausgabe von Statistiken im JSON-Format kann jetzt nur die JSON-C-Bibliothek verwendet werden. Die Configure-Option «—with-libjson» wurde in «—with-json-c» umbenannt.
  • Im Configure-Skript wird der Parameter «—sysconfdir» nicht mehr standardmĂ€ĂŸig auf /etc gesetzt und «—localstatedir» auf /var, wenn der Parameter «—prefix» nicht angegeben wird. StandardmĂ€ĂŸig werden nun die Pfade $prefix/etc und $prefix/var verwendet, die in Autoconf angewendet werden.
  • Der Code zur Implementierung des DLV-Dienstes (Domain Look-aside Verification, Option dnssec-lookaside) wurde entfernt, der in BIND 9.12 als veraltet erklĂ€rt wurde, und der zugehörige Handler dlv.isc.org wurde 2017 abgeschaltet. Die Entfernung von DLV hat es ermöglicht, den BIND-Code von unnötigen Komplikationen zu befreien.

Quelle: opennet.ru

ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server đŸ”„ ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server - ProHoster