V Veröffentlichung nginx 1.17.2

VerfĂŒgbar Release der Hauptversion nginx 1.17.2, im Rahmen dessen die Entwicklung neuer Möglichkeiten fortgesetzt wird (in der parallel unterstĂŒtzten stabilen Version 1.16 werden nur Änderungen vorgenommen, die mit der Beseitigung schwerwiegender Fehler und SicherheitsanfĂ€lligkeiten zusammenhĂ€ngen.

Haupt- Änderungen:

  • Die UnterstĂŒtzung fĂŒr den Wechsel von benannten 'location'-Blöcken mittels der Methode $r->internal_redirect(), bereitgestellt vom eingebauten Perl-Interpreter, wurde hinzugefĂŒgt. Diese Methode beinhaltet jetzt die Verarbeitung von URIs mit escaped Zeichen;
  • Die Anforderungen an die minimal unterstĂŒtzte Version von zlib wurden auf 1.2.0.4 angehoben;
  • Probleme mit der Fehlerbehandlung im integrierten Perl-Interpreter wurden behoben;
  • Probleme in den Modulen ngx_http_xslt_filter_module und ngx_http_ssi_filter_module wurden behoben;
  • Der Absturz bei der AusfĂŒhrung oder Neukonfiguration wurde behoben, wenn in den Einstellungen eine BlockgrĂ¶ĂŸe fĂŒr den Hash von mehr als 64 KB angegeben wurde;
  • Ein Problem mit hoher CPU-Auslastung beim unbuffered Proxieren oder Proxieren von WebSocket-Verbindungen unter Verwendung der Methoden select, poll oder /dev/poll wurde gelöst.

Quelle: opennet.ru

ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server đŸ”„ ZuverlĂ€ssiges Hosting fĂŒr Websites mit DDoS-Schutz kaufen, VPS VDS Server - ProHoster