Tomorrow's Windows Server update will break compatibility with Samba

Emergency updates for Samba 4.22.3 and 4.21.7 have been released to address the compatibility issue with Samba servers due to tomorrow's Windows Server update. If the recommended updates are not installed, Samba servers will be unable to function as members of Windows Active Directory domains when the 'ad' backend is used for user ID mapping.

Microsoft has scheduled updates for supported versions of Windows Server on July 8, which will address security issues in the Active Directory domain controller implementation. These updates will impact all supported versions, Windows Server, including Windows Server 2008, with changes being made to the Microsoft RPC Netlogon protocol to add additional access checks to certain RPC calls. Previously, enhanced checks were applied only in Windows Server 2025, but starting tomorrow they will be implemented in other versions as well.

Such changes disrupt compatibility with Samba and cause failures when the winbind service sends controller discovery requests domain (Netlogon DC Discovery). Due to this failure, domain users will be unable to connect to Samba-based SMB services that use the 'ad' backend.

Source: opennet.ru

Buy reliable website hosting with DDoS protection, VPS VDS servers 🔥 Buy reliable website hosting with DDoS protection, VPS VDS servers | ProHoster