nginx 1.17.5 release

The release of nginx 1.17.5 has occurred, containing fixes and improvements.

New features:

  • added support for ioctl(FIONREAD) calls, when available, to avoid reading from a fast connection for an extended period;
  • resolved the issue with incomplete encoded characters being ignored at the end of the URI request;
  • fixed the problem with normalizing the sequences '/.' and '/..' at the end of the URI request;
  • corrected the merge_slashes and ignore_invalid_headers directives;
  • fixed an error occurring when building nginx with MinGW-w64 gcc 8.1 and later.

Source: linux.org.ru

Buy reliable website hosting with DDoS protection, VPS VDS servers 🔥 Buy reliable website hosting with DDoS protection, VPS VDS servers | ProHoster