Oracle has released a patch update for the VirtualBox virtualization system, version 7.0.6, which includes 14 fixes. At the same time, an update for the previous branch, VirtualBox 6.1.42, has been created with 15 changes, including support for Linux kernels 6.1 and 6.2, as well as kernels from RHEL 8.7/9.1/9.2, Fedora (5.17.7-300), SLES 15.4, and Oracle Linux 8.
Key changes in VirtualBox 7.0.6:
- Support for the kernel from the RHEL 9.1 distribution and initial support for the UEK7 (Unbreakable Enterprise Kernel 7) from Oracle Linux 8 has been implemented in the host and guest system additions for Linux.
- Initial support for the vboxvideo driver build for the Linux 6.2 kernel has been added in the guest system additions for Linux.
- In the manager of virtual machines Issues with the FreeBSD bootloader failing to start on systems with older Intel CPUs that do not support the 'VMX Unrestricted Guest' mode have been resolved.
- The settings dialog in the graphical interface has been changed. Issues with grouping virtual machines created or modified from the command line have been resolved.
- The issue with network failure after booting from a saved state in VirtioNet has been fixed.
- Support for increasing the size of VMDK image types has been added: monolithicFlat, monolithicSparse, twoGbMaxExtentSparse, and twoGbMaxExtentFlat.
- A new option '--directory' has been added to the guestcontrol mktemp command in the VBoxManage utility. The '--audio' option has been deprecated, and users should instead use ‘--audio-driver’ and ‘--audio-enabled’.
- Mouse state transmission to the guest system has been improved.
- Auto-start of virtual machines has been established on Windows host systems.
Source: opennet.ru
