Se ha formado la versión principal de nginx 1.23.4, en la que continúa el desarrollo de nuevas funcionalidades. En la rama estable paralela 1.22.x solo se realizan cambios relacionados con la corrección de errores graves y vulnerabilidades. En el futuro, se formará una rama estable 1.24 basada en la rama principal 1.23.x.
Entre los cambios:
- Por defecto, se incluye el protocolo TLSv1.3.
- Se asegura la salida de una advertencia en caso de que se reconfiguren las configuraciones de los protocolos para el socket escuchante.
- Al utilizar el modo «pipelining» del cliente, se asegura el cierre de conexiones con espera de datos adicionales (lingering close).
- En el módulo ngx_http_gzip_static_module se ha añadido soporte para rangos de bytes (byte range).
- Se ha cambiado el nivel de registro de «crit» a «info» para SSL- los errores «data length too long», «length too short», «bad legacy version», «no shared signature algorithms», «bad digest length», «missing sigalgs extension», «encrypted length too long», «bad length», «bad key update», «mixed handshake and non handshake data», «ccs received early», «data between ccs and finished», «packet length too long», «too many warn alerts», «record too small» y «got a fin before a ccs.
- Se ha restablecido el funcionamiento de rangos de puertos en la directiva listen.
- Se ha resuelto el problema de seleccionar un bloque location incorrecto al utilizar un prefijo de location más largo de 255 caracteres.
- En los módulos ngx_http_autoindex_module y ngx_http_dav_module, así como en la directiva include, se ha añadido soporte para caracteres no ASCII en los nombres de archivos en la plataforma Windows.
- Se ha eliminado la fuga de sockets al utilizar HTTP/2 y la directiva error_page para redirigir errores con código 400.
Fuente: opennet.ru
