El cambio en la configuración del núcleo de Linux 6.12 ha causado problemas con zRAM en algunas distribuciones

Los usuarios de sistemas que utilizan el mecanismo zRAM para el almacenamiento comprimido de la partición de intercambio en memoria se han encontrado con un problema que provoca fallos en el arranque tras actualizar el núcleo de Linux a la versión 6.12. El problema se manifiesta en Gentoo, Void y otras distribuciones que soportan zRAM y ofrecen paquetes con nuevas versiones del núcleo.

La causa del fallo fue un cambio incluido en el núcleo 6.12 que agrega la opción de configurar los algoritmos de compresión en tiempo de ejecución. A su vez, en Kconfig se alteró la lógica de selección de los algoritmos de compresión disponibles durante la construcción del núcleo. Este cambio ha causado problemas en distribuciones que dependían de la configuración predeterminada y no habilitaron individualmente todos los algoritmos zRAM disponibles en la configuración de Kconfig para el núcleo 6.12.

Después de actualizar al núcleo 6.12, en estas distribuciones solo se mantuvo disponible el algoritmo de compresión base por defecto, y no todos los algoritmos soportados. Por lo tanto, al intentar activar en zRAM algoritmos que no coincidían con el algoritmo por defecto, se producía un fallo en el arranque. Por ejemplo, al seleccionar el algoritmo lz4 durante el arranque, aparecía el error «zramctl: /dev/zram0: failed to set algorithm: Invalid argument», ya que solo quedaba soporte para lzo, en lugar de los anteriormente soportados lzo, lz4, lz4hc, 842 y zstd.

El problema se soluciona habilitando en Kconfig cada backend de compresión individualmente (se añadieron las configuraciones CONFIG_ZRAM_BACKEND_* en el núcleo 6.12): CONFIG_ZRAM_BACKEND_LZ4=y CONFIG_ZRAM_BACKEND_LZ4HC=y CONFIG_ZRAM_BACKEND_ZSTD=y CONFIG_ZRAM_BACKEND_842=y CONFIG_ZRAM_DEF_COMP_LZO=y CONFIG_ZRAM_DEF_COMP=«lzo»

Fuente: opennet.ru

Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS 🔥 Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS | ProHoster