Lanzamiento de nginx 1.23.0

Se ha presentado la primera versión de la nueva rama principal nginx 1.23.0, en la cual se continuará el desarrollo de nuevas funcionalidades. En la rama estable soportada simultáneamente 1.22.x, solo se realizarán cambios relacionados con la corrección de errores graves y vulnerabilidades. En el próximo año, se formará una rama estable 1.24 a partir de la rama principal 1.23.x.

Principales cambios:

  • Se ha reestructurado la API interna, las líneas de encabezado ahora se transmiten en forma de lista conectada.
  • Se ha asegurado la fusión de líneas de encabezado con nombres idénticos al ser enviadas a los backends FastCGI, SCGI y uwsgi, en el método $r->header_in() del módulo ngx_http_perl_module y en las variables "$http_…", "$sent_http_…", "$sent_trailer_…", "$upstream_http_…" y "$upstream_trailer_…".
  • Para errores SSL "application data after close notify" el nivel de registro se ha reducido de "crit" a "info.
  • Se ha resuelto un problema de bloqueo de conexiones en nginx, compilado en sistemas Linux con núcleo 2.6.17 y versiones posteriores, pero utilizado en sistemas sin soporte para EPOLLRDHUP (por ejemplo, al usar emulación de epoll).
  • Se ha solucionado un problema de almacenamiento en caché de respuestas, si el encabezado "Expires" prohibía la caché, mientras que "Cache-Control" permitía.
  • Se han resuelto problemas que aparecían si el backend devolvía varios encabezados "Vary" y "WWW-Authenticate".

Fuente: opennet.ru

Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS 🔥 Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS | ProHoster