Categoría: Blog

Lanzamiento de OpenRGB 0.6, herramienta para gestionar dispositivos con retroiluminación RGB

Se ha publicado una nueva versión de OpenRGB 0.6, una herramienta gratuita para gestionar dispositivos con retroiluminación RGB. El paquete admite placas base ASUS, Gigabyte, ASRock y MSI con subsistemas RGB para la iluminación del chasis, módulos de memoria retroiluminados de ASUS, Patriot, Corsair y HyperX, tarjetas gráficas ASUS Aura/ROG, MSI GeForce, Sapphire Nitro y Gigabyte Aorus, varios controladores de tiras LED (ThermalTake, Corsair, NZXT Hue+), […]

Para el lenguaje D se presenta un runtime para programación de microcontroladores

Dylan Graham ha presentado un runtime liviano LWDR para programación en el lenguaje D de microcontroladores equipados con un sistema operativo de tiempo real (RTOS). La versión actual está enfocada en microcontroladores ARM Cortex-M. El desarrollo no busca cubrir completamente todas las capacidades de D, sino proporcionar herramientas básicas. La gestión de memoria se realiza manualmente (new / delete), no se ha implementado un recolector de basura, pero existen varios hooks para […]

Lanzamiento del servidor de aplicaciones NGINX Unit 1.24.0

Se ha lanzado el servidor de aplicaciones NGINX Unit 1.24, en el que se desarrolla una solución para ejecutar aplicaciones web en varios lenguajes de programación (Python, PHP, Perl, Ruby, Go, JavaScript/Node.js y Java). Bajo NGINX Unit, se pueden ejecutar simultáneamente varias aplicaciones en diferentes lenguajes de programación, cuyos parámetros de ejecución se pueden modificar dinámicamente sin necesidad de editar archivos de configuración y reiniciar. El código […]

Lanzamiento de Electron 13.0.0, plataforma para crear aplicaciones basadas en el motor Chromium

Se ha preparado el lanzamiento de la plataforma Electron 13.0.0, que proporciona un marco autosuficiente para desarrollar aplicaciones de usuario multiplataforma, utilizando como base los componentes de Chromium, V8 y Node.js. El cambio significativo en el número de versión se debe a la actualización a la base de código de Chromium 91, la plataforma Node.js 14.16 y el motor JavaScript V8 9.1. Entre los cambios en esta nueva versión: Se ha añadido la propiedad process.contextIsolated para determinar la ejecución actual […]

Lanzamiento de la biblioteca PCRE2 10.37

Se ha lanzado la versión 10.37 de la biblioteca PCRE2, que proporciona un conjunto de funciones en C para la implementación de expresiones regulares y herramientas de coincidencia de patrones, similares en sintaxis y semántica a las expresiones regulares de Perl 5. PCRE2 es una reimplementación de la biblioteca original PCRE, con una API incompatible y con capacidades ampliadas. La biblioteca fue desarrollada por los creadores del servidor de correo Exim y se distribuye […]

Microsoft ha lanzado el gestor de paquetes Windows Package Manager 1.0, similar a apt y dnf.

La compañía Microsoft ha publicado la versión 1.0 (winget) del gestor de paquetes Windows Package Manager, que proporciona herramientas para instalar aplicaciones utilizando la línea de comandos. El código está escrito en C++ y se distribuye bajo la licencia MIT. Los paquetes se instalan desde un repositorio mantenido con la ayuda de la comunidad. A diferencia de la instalación de software desde Microsoft Store, winget permite instalar aplicaciones sin el marketing innecesario y […]

Lanzamientos del gestor de paquetes Pacman 6.0 e instalador Archinstall 2.2.0.

Están disponibles nuevas versiones del gestor de paquetes Pacman 6.0.0 y del instalador Archinstall 2.2.0, utilizados en la distribución Arch Linux. Los cambios principales en Pacman 6.0 incluyen: Soporte para descargar archivos en múltiples hilos paralelos. Implementación de una línea de salida que indica el progreso de la descarga de datos. Para desactivar el indicador de progreso en pacman.conf, se puede especificar la opción "—noprogressbar". Se asegura el salto automático de espejos cuando se accede a […]

Se ha abierto el código del servicio de comprobación de contraseñas HaveIBeenPwned.

Troy Hunt ha publicado el código fuente del servicio de verificación de contraseñas comprometidas "Have I Been Pwned?" (haveibeenpwned.com), que verifica 11.2 mil millones de cuentas comprometidas como resultado de las violaciones de seguridad de 538 sitios. Originalmente, se anunció la intención de abrir el código del proyecto en agosto del año pasado, pero el proceso se retrasó y el código se publicó solo ahora. El código del servicio está escrito en […]

Mozilla ha resumido sus planes para soportar la tercera versión del manifiesto de Chrome en Firefox.

La compañía Mozilla publicó el plan de implementación en Firefox de la tercera versión del manifiesto de Chrome, que determina las capacidades y recursos disponibles para las extensiones. La tercera versión del manifiesto ha sido objeto de críticas debido a la interrupción del funcionamiento de muchas extensiones para bloquear contenido no deseado y garantizar la seguridad. En Firefox, tienen la intención de implementar casi todas las capacidades y restricciones del nuevo manifiesto, incluyendo la API declarativa para el filtrado de contenido (declarativeNetRequest), […]

El protocolo QUIC ha recibido el estatus de estándar propuesto

El Comité IETF (Internet Engineering Task Force), que se encarga del desarrollo de protocolos y la arquitectura de internet, ha finalizado la elaboración de RFC para el protocolo QUIC y ha publicado las especificaciones relacionadas con los identificadores RFC 8999 (propiedades del protocolo independientes de la versión), RFC 9000 (transporte sobre UDP), RFC 9001 (cifrado TLS del canal de comunicación QUIC) y RFC 9002 (gestión de la sobrecarga y detección de pérdida de paquetes durante la transferencia de datos). […]

La compañía Virtuozzo ha publicado la distribución VzLinux, enfocada en reemplazar CentOS 8

La compañía Virtuozzo (anteriormente una división de Parallels), que desarrolla software de servidor para virtualización basado en proyectos de código abierto, ha comenzado la distribución pública de la distribución VzLinux, que anteriormente se utilizaba como sistema operativo base para la plataforma de virtualización desarrollada por la compañía y varios productos comerciales. Desde ahora, VzLinux está disponible para todos los interesados y se posiciona como un reemplazo de CentOS 8, listo para implementaciones en producción. Para descargar […]

Lanzamiento de la distribución Simply Linux 9.1

La compañía Basalt SPO ha anunciado el lanzamiento de la distribución Simply Linux 9.1, construida sobre la novena plataforma ALT. El producto se distribuye bajo un acuerdo de licencia que no transfiere el derecho a distribuir la distribución, pero permite a personas físicas y jurídicas usar el sistema sin restricciones. La distribución se entrega en compilaciones para arquitecturas x86_64, i586, aarch64, armh (armv7a), mipsel, riscv64, e2kv4/e2k (beta) y puede […]

Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS 🔥 Compra un hosting fiable para sitios web con protección contra DDoS, servidores VPS VDS | ProHoster