Avaldatud on Moxi 0.0.15 projekti versioon, mis arendab terviklikku lahendust postiserverite töö tagamiseks, sisaldades kĂ”iki komponente, mis on vajalikud e-kirjade saatmiseks ja vastuvĂ”tmiseks. Pakutakse kohandatud SMTP ja IMAP4 serverite teostusi, soovimatute sisu filtreerimise sĂŒsteemi ning veebiliideseid administratoritele ja kasutajatele. Projekti kood on kirjutatud Go keeles ja levitatakse MIT litsentsi alusel.
Projekti eesmĂ€rk on luua «kĂ”ik-ĂŒhes» lahendus, mis vĂ”imaldab lihtsalt kĂ€ivitada töötava postiserveri ilma keerulise seadistamiseta ja ilma erinevate isoleeritud teenuste ja rakenduste omavahelise sidumiseta. Eeldatakse, et postiteenuste kĂ€itamise ja tugevdamise keerukuse tĂ”ttu eelistavad tarbijad tsentraliseeritud e-posti teenusepakkujaid, mis hĂ€vitab e-posti kui detsentraliseeritud teenuse idee, mis koosneb paljusid isiklikke postiservereid. serverid Mox vĂ”imaldab 10 minutiga seadistada turvalise postiserveri oma domeenide jaoks, toetades kaasaegset protokollide virna ja mitte nĂ”udes tĂ€iendavate sĂ”ltuvuste installimist. Postiserveri tarkvara uuendamine tĂ€hendab lihtsalt uue Moxi versiooni allalaadimist ja taaskĂ€ivitamist. Saamine ja uuendamine toimub automaatselt.
Seadistamiseks ja hooldustööde lĂ€biviimiseks saab kasutada veebiliidest, samas kui ulatuslikuks seadistamiseks on saadaval konfiguratsioonifail. TLS-sertifikaatide Kuna tekivad turvaprobleemid, mis on seotud madala taseme mĂ€lutöötlusega, kasutatakse arenduses Go keelt. KĂ”rge koodibaasi kvaliteedi sĂ€ilitamiseks rakendatakse uut ja automatiseeritud testimist populaarsete postiserverite ja klientide ĂŒhilduvuse katmiseks, samuti unit- ja fuzzing-testimist ning pĂ”hjalikku koodi dokumenteerimist.
Moxi peamised vÔimalused:
SMTP ja IMAP4 protokollide tugi.
- SPF, DKIM ja DMARC laienduste kasutamine postidomeenide tuvastamiseks, saatmisvolituste kinnitamiseks ja sÔnumite autentimiseks.
- Majutajate, domeenide ja saatjate reputatsiooni jÀlgimine. Soovimatute sÔnumite filtreerimiseks kasutatakse baasilist klassifikaatorit, DNSBL-i ja halli nimekirja.
- Hostide, domeenide ja saatjate maine jÀlgimine. Kasutades Bayesi klassifikaatorit, DNSBL ja hallide loendite kasutamine soovimatute sÔnumite filtreerimiseks.
- Toetuste laienemine Unicode'i ja rahvuslike tÀhestike kasutamisele nimedes ja domeenides.
- TLS-sertifikaatide automaatne hankimine ACME-protokolli toetavatelt sertifitseerimiskeskustelt, nĂ€iteks Letâs Encrypt.
- DANE ja MTA-STS mehhanismide toetamine SMTP-tasandil sissetulevate ja vĂ€ljaminevate saadetiste krĂŒpteerimiseks STARTTLS laiendusega.
- Sisseehitatud Webmail e-kirjade lugemiseks ja saatmiseks lÀbi brauseri.
- Sisseehitatud veebihaldur domeenide ja kontode haldamiseks, SPF/DKIM/DMARC/TLSRPT/MTA-STS seadistamiseks, statistika vaatamiseks ja konfiguratsioonifaili parameetrite muutmiseks.
- HTTP-serveri olemasolu staatiliste failide edastamiseks ja pĂ€ringute ĂŒmbersuunamiseks (tagasi proxy).
- HTTP/JSON API pakkumine kirjade saatmiseks/laadimiseks ja kohaletoimetamisega seotud sĂŒndmuste saamiseks.
- Metrika eksport tugisĂŒsteemile Prometheus.
- Toetust automaatse seadistamise mehhanismide jaoks (DNS SRV, https://autoconfig.domeen, QR-kood).
Uues versioonis on jÀrgmised muudatused:
- IMAP-i laienduste tugi on lisatud:
- NOTIFY (RFC 5465) sÔnumite ilmumise jÀlgimiseks,
- UIDONLY (RFC 9586) sÔnumite pÀrimiseks UID alusel serveri koormuse vÀhendamiseks.
- MULTISEARCH (RFC 7203) kirjade otsimiseks,
- PREVIEW (RFC 8970) sÔnumite kiireks eelvaate kuvamiseks,
- REPLACE (RFC 8508) sisu asendamiseks sÔnumite mustandites,
- MULTIAPPEND (RFC 3502) mitme sÔnumi lisamiseks korraga,
- METADATA (RFC 5464) metaandmete salvestamiseks,
- INPROGRESS (RFC 9585) pikaajaliste operatsioonide staatuse edastamiseks,
- NAMESPACE (RFC 2342) postkastide nimede mÀÀratlemiseks,
- WITHIN (RFC 5032) ajavahemike alusel otsimiseks,
- CREATE-SPECIAL-USE (RFC 6154) spetsialiseeritud postkastide, nagu "Sisse tulevad" ja "Edastatud", loomiseks,
- SAVEDATE (RFC 8514) sÔnumi salvestamise aja jÀlgimiseks postkastis.
- Seade e-posti aadressides "+" ja "-" eraldajate töötlemiseks (you+anything@example.com ja you-anything@example.com).
- Seade parooli muutmise keelamiseks (ainult usaldusvÀÀrse parooli automaatne genereerimine).
- Seade sissetulevate kohaletoimetamiste tagasilĂŒkkamiseks SMTP-tehingus esinevate tĂ”rgete korral.
- Webmailis on lisatud nupp kirja allalaadimiseks eml vÔi mbox/maildir vormingus zip/tgz/tar arhiivides, samuti nupud postkasti loetuks mÀrkimiseks ja tÀiendavate postkastide loomiseks.
Allikas: opennet.ru
