GOST krüptograafia algoritmide teostamine Java keeles

Avaldatud on crypto-gost raamatukogu, mis teostab GOST krüptoalgoritme Java keeles ilma täiendavate sõltuvusteta. Erinevalt GOST algoritmide teostusest Castle Bouncy Castle raamatukogust, on crypto-gost-iga paranenud "Kuznechik" krüpteerimise jõudlus, lahendatud on eraldi turbeprobleemid ning pakutakse lihtsaid mähiseid, mis ei nõua sügavaid teadmisi krüptograafiast. Kood on saadaval oma litsentsi alusel, mis lubab levitamist, muutmist ja tuletatud teoste loomist ilma piiranguteta.

Toetatud algoritmid:

  • GOST R 34.11-2012 (RFC 6986) — hash-funktsioon "Stribog" 256 ja 512 bitti.
  • GOST R 34.12-2015 — plokiseerija "Kuznechik", võtme pikkus 256 bitti.
  • GOST R 34.13-2015 — krüpteerimisrežiimid CBC, CFB, CTR (GAMMA), OFB; autentimisfunktsioon (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — elektrooniline allkiri 256 ja 512 bitti.
  • HMAC-Stribog (RFC 7836, HMAC-Streebog-256 ja HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — AEAD-režiim Kuznečikele (RFC 9058). Ühildub OpenSSL-iga.
  • SCrypt (RFC 7914) — paroole põhinev võtme genereerimise funktsioon.

Allikas: opennet.ru

Osta usaldusväärne veebimajutus DDoS-kaitsega veebisaitidele, VPS VDS serverid 🔥 Osta usaldusväärne veebimajutus DDoS-kaitsega veebisaitidele, VPS VDS serverid - ProHoster