Issuerd 0.1.17 väljaandmine, Keycloak'iga ühilduva identiteedi ja juurdepääsu haldusteenuse server

Ilmavaldus Issuerd 0.1.17 — identiteedi ja juurdepääsu (IAM) haldamise server, mis rakendab OpenID Connect ja OAuth 2.x protokolle ning on andmemudeli ja haldava REST API osas ühilduv Keycloakiga. Tehtud on SSO, MFA (TOTP, WebAuthn/passkeys), kasutajate föderatsioon LDAP-ist ja Kerberos/SPNEGO-st, sisselogimine väliste identiteedi pakkujatega (OIDC, sotsiaalmeedia), sisselogimislehed, millel on kohandatav kujundus ja lokaliseerimine, deklareeriv algkonfiguratsioon YAML-is esmakordsel käivitamisel. Server on kirjutatud Rustis (unsafe-kood on atribuutide tasemel keelatud), levitatakse Apache 2.0 litsentsi alusel ning tarnitakse ühe iseseisva binaarfailina, kuhu on integreeritud administratiivkonsool ja kasutajakonsool. Kogud luuakse platvormidele Linux, Windows ja macOS (amd64 ja
arm64).

Projekti peamine omadus on pidev vastavuse kontrollimine
OpenID Foundation Conformance Suite ametlikule testikomplektile (5.3.2). Testimine toimub CI-s iga versiooni jaoks isoleeritud docker-ümbruses. Moodulite tulemused salvestatakse hoidlas ja tervikpakett aruandeid lisatakse
iga versiooniga. Pariteeti Keycloakiga kontrollitakse testikomplekti abil. Plaanis on ametlik sertifitseerimine.

AI-agente kasutavates stsenaariumites rakendatakse protokolle DPoP (RFC 9449, tokeni sidumine esitaja võtmega), tokenivahetus (RFC 8693, õiguste piirmääramine tokeni vahetamisel) ja CIBA (poll-režiim, tegevuste kinnitamine inimese poolt). Toetatakse ka PAR (RFC 9126), JAR (RFC 9101), JARM, RAR (RFC 9396), dünaamiline kliendiregistreerimine (RFC 7591/7592), seadmete autoriseerimine (RFC 8628). 100 tuhande kasutaja täielik import MS Active Directory-st võtab aega umbes 30 sekundit.

Allikas: opennet.ru

Osta usaldusväärne veebimajutus DDoS-kaitsega veebisaitidele, VPS VDS serverid 🔥 Osta usaldusväärne veebimajutus DDoS-kaitsega veebisaitidele, VPS VDS serverid - ProHoster