La version légÚre du serveur http lighttpd 1.4.65 a été publiée, visant à allier haute performance, sécurité, conformité aux normes et flexibilité de configuration. Lighttpd est adapté pour une utilisation sur des systÚmes trÚs chargés et ciblé sur une faible consommation de mémoire et de ressources CPU. La nouvelle version introduit 173 changements. Le code du projet est écrit en C et est distribué sous licence BSD.
Les principales nouveautés :
- Ajout de la prise en charge de WebSocket sur HTTP/2, ainsi que la mise en Ćuvre de la RFC 8441, dĂ©crivant le mĂ©canisme pour lancer le protocole WebSockets dans un seul flux au sein d'une connexion HTTP/2.
- Mise en Ćuvre d'un schĂ©ma de gestion des prioritĂ©s amĂ©liorĂ©, permettant au client d'influencer la prioritĂ© des rĂ©ponses transfĂ©rĂ©es (RFC 9218), ainsi que de gĂ©rer les prioritĂ©s lors de la redirection des requĂȘtes. Pour HTTP/2, le support du cadre PRIORITY_UPDATE est assurĂ©. serveur Dans les rĂ©glages de lighttpd.conf, prise en charge des correspondances conditionnelles liĂ©es au dĂ©but (=^) et Ă la fin (=$) de la chaĂźne. De telles vĂ©rifications de chaĂźnes sont significativement plus rapides que les expressions rĂ©guliĂšres et suffisent pour de nombreuses vĂ©rifications simples.
- Dans mod_webdav, ajout de la prise en charge des opĂ©rations PUT partielles (celles couvrant une partie des donnĂ©es Ă l'aide de l'en-tĂȘte Range). Pour l'activer, vous pouvez utiliser l'option âwebdav.opts += («partial-put-copy-modifyâ => «enable»).
- Dans mod_accesslog, ajout de l'option âaccesslog.escaping = âjsonâ.
- Dans mod_deflate, ajout du support de la compilation avec libdeflate.
- AccĂ©lĂ©ration de l'envoi du corps de la requĂȘte via HTTP/2.
- La valeur par défaut du paramÚtre server.max-keep-alive-requests a été modifiée de 100 à 1000.
- Dans la liste des types MIME, «application/javascript» a été remplacé par «text/javascript» (RFC 9239).
- Pour l'avenir, il est prévu d'appliquer des réglages de chiffrement plus stricts pour TLS et de désactiver par défaut les chiffrages obsolÚtes. Le réglage CipherString sera changé de «HIGH» à «EECDH+AESGCM:AES256+EECDH:CHACHA20:SHA256:!SHA384». Il est également prévu de supprimer les options obsolÚtes TLS :
.honor-cipher-order, ssl.dh-file, ssl.ec-curve, ssl.disable-client-renegotiation, ssl.use-sslv2, ssl.use-sslv3. De plus, le nettoyage des mini-modules continuera, pouvant ĂȘtre remplacĂ©s par une rĂ©alisation Lua plus flexible du mod_magnet. En particulier, les modules mod_evasive, mod_secdownload, mod_uploadprogress et mod_usertrack sont prĂ©vus pour ĂȘtre supprimĂ©s. sslDistribution SUSE Linux Enterprise 15 SP4 disponible
Source : opennet.ru
