Sortie d'OpenBSD 7.2

La sortie du systÚme d'exploitation libre de type UNIX OpenBSD 7.2 a été annoncée. Le projet OpenBSD a été fondé par Theo de Raadt en 1995, à la suite d'un conflit avec les développeurs de NetBSD, ce qui a conduit à la fermeture de son accÚs au dépÎt CVS de NetBSD. Par la suite, Theo de Raadt et un groupe d'amis ont créé un nouveau systÚme d'exploitation ouvert basé sur l'arbre de codes sources de NetBSD, avec comme principaux objectifs la portabilité (support de 13 plateformes matérielles), la normalisation, un fonctionnement correct, la sécurité proactive et des outils cryptographiques intégrés. La taille de l'image ISO d'installation complÚte de la version de base d'OpenBSD 7.2 est de 556 Mo.

En plus du systĂšme d'exploitation lui-mĂȘme, le projet OpenBSD est connu pour ses composants qui ont Ă©tĂ© adoptĂ©s dans d'autres systĂšmes et qui se sont avĂ©rĂ©s ĂȘtre parmi les solutions les plus sĂ»res et de la plus haute qualitĂ©. Parmi eux : LibreSSL (un fork d'OpenSSL), OpenSSH, le filtre de paquets PF, les dĂ©mons de routage OpenBGPD et OpenOSPFD, le serveur NTP OpenNTPD, le serveur de messagerie OpenSMTPD, le multiplexeur de terminal texte (similaire Ă  GNU screen) tmux, le dĂ©mon identd implĂ©mentant le protocole IDENT, une alternative BSDL au paquet GNU groff — mandoc, le protocole pour la mise en place de systĂšmes tolĂ©rants aux pannes CARP (Common Address Redundancy Protocol), un serveur HTTP lĂ©ger, et l'outil de synchronisation de fichiers OpenRSYNC.

Améliorations principales :

  • Le support des systĂšmes basĂ©s sur l'architecture ARM a Ă©tĂ© amĂ©liorĂ©, y compris l'ajout de la prise en charge des puces ARM Apple M2 et Ampere Altra. Ajout d'un support pour l'ordinateur portable Lenovo ThinkPad x13s et d'autres appareils basĂ©s sur SoC Qualcomm Snapdragon 8cx Gen 3 (SC8280XP).
  • Ajout de la possibilitĂ© de dĂ©marrer dans les environnements Oracle Cloud avec un noyau pour disque RAM (bsd.rd) et un noyau pour systĂšmes multiprocesseurs (bsd.mp).
  • Un dispositif kstat a Ă©tĂ© inclus, exportant des statistiques sur le fonctionnement du noyau, pouvant ĂȘtre consultĂ©es avec l'outil kstat.
  • Des capteurs de frĂ©quence CPU ont Ă©tĂ© implĂ©mentĂ©s pour chaque cƓur de processeur prenant en charge MPERF/APERF. En fonctionnement sur batterie, un ajustement de la frĂ©quence CPU en fonction de la charge est activĂ©.
  • Un support initial du mode veille a Ă©tĂ© ajoutĂ© sur les systĂšmes ARM64. La limite du nombre de CPU pris en charge a Ă©tĂ© augmentĂ©e Ă  256. Il est dĂ©sormais possible de basculer depuis une console basĂ©e sur un framebuffer (glass console) vers une console sĂ©rie (serial console).
  • Le code pour dĂ©tecter les processeurs CPU 386sx/386dx, NexGen, Rise et les anciens processeurs Cyrix, sortis avant la puce Cyrix M2, a Ă©tĂ© supprimĂ©.
  • Le support des systĂšmes multiprocesseurs (SMP) a Ă©tĂ© amĂ©liorĂ©. Les fonctions de limitation de bande passante (rate limit), de recherche d'enregistrements ARP et de minuteur de routage ont Ă©tĂ© mises Ă  jour pour ĂȘtre mp-safe. La possibilitĂ© d'exĂ©cution parallĂšle d'opĂ©rations telles que la reconstruction de paquets IPv4 et le redirection des paquets IP a Ă©tĂ© mise en Ɠuvre. Des verrous de sockets utilisant des mutex ont Ă©tĂ© ajoutĂ©s aux fonctions de traitement des paquets UDP et IP entrants. Les appels systĂšme kbind et pledge ont Ă©tĂ© dĂ©barrassĂ©s de verrous. Des verrous de sockets UNIX, fonctionnant au niveau des sockets individuels, ont Ă©tĂ© rĂ©alisĂ©s.
  • La mise en Ɠuvre du framework drm (Direct Rendering Manager) a Ă©tĂ© synchronisĂ©e avec le noyau Linux 5.15.69 (dans la version prĂ©cĂ©dente — 5.15.26). Le pilote inteldrm a ajoutĂ© le support des puces Intel basĂ©es sur les microarchitectures Alder Lake et Raptor Lake. Le support des buffers de cadre non alignĂ©s sur les frontiĂšres de pages mĂ©moire (utilisĂ©s, par exemple, dans le MacBook Pro 2021 14″ et 16″) a Ă©tĂ© rĂ©alisĂ©.
  • Des amĂ©liorations ont Ă©tĂ© apportĂ©es Ă  l'hyperviseur VMM. Dans vmd, le support des gestionnaires en espace utilisateur basĂ©s sur MMIO a Ă©tĂ© ajoutĂ©. Dans vmm, l'Ă©mulation des ports d'entrĂ©e/sortie a Ă©tĂ© transfĂ©rĂ©e dans l'espace utilisateur. Les structures internes et les interfaces de vmd, vmctl et vmm ont Ă©tĂ© unifiĂ©es. Une possibilitĂ© de surveillance a Ă©tĂ© ajoutĂ©e. machines virtuelles Ă  l'aide de SNMP AgentX, en utilisant les paramĂštres VM-MIB (RFC7666).
  • La variable $rcexec dans les scripts d'initialisation rc.d a Ă©tĂ© remplacĂ©e par la fonction rc_exec. Une nouvelle variable daemon_execdir a Ă©tĂ© ajoutĂ©e pour changer de rĂ©pertoire avant d'exĂ©cuter la fonction rc_exec. Dans rc.d et rcctl, une nouvelle action configtest a Ă©tĂ© ajoutĂ©e pour vĂ©rifier la syntaxe de la configuration.
  • L'utilitaire ts a Ă©tĂ© intĂ©grĂ©, ajoutant Ă  chaque ligne reçue via l'entrĂ©e standard un horodatage indiquant le moment de la rĂ©ception de chaque ligne.
  • L'utilitaire ps a ajoutĂ© l'option « -f » pour un regroupement des processus en arbre, reflĂ©tant les relations entre les processus parent et enfant.
  • L'utilitaire openrsync a mis en Ɠuvre l'option « —contimeout » pour dĂ©finir un dĂ©lai d'attente pour l'Ă©tablissement de la connexion.
  • L'utilitaire pkg_add inclut par dĂ©faut la mise en cache, optimisation du traitement des paquets et affichage d'une barre de progression lors de la transmission des donnĂ©es.
  • Dans fdisk, le traitement des tables GPT et MBR a Ă©tĂ© amĂ©liorĂ©, avec des avertissements ajoutĂ©s en cas de placement incorrect des partitions MBR et GPT.
  • L'utilitaire disklabel a ajoutĂ© la prise en charge du mot-clĂ© raid dans les modĂšles pour le placement automatique des partitions avec RAID. La prise en charge de l'Ă©dition des informations sur la gĂ©omĂ©trie du disque a Ă©tĂ© arrĂȘtĂ©e. La prise en charge des attributs ‘bs’ (taille du bloc de dĂ©marrage), ‘sb’ (taille du superbloc) et d[0-4] (donnĂ©es du disque) a Ă©tĂ© arrĂȘtĂ©e.
  • Un ensemble de scripts utiles pour btrace pour le traçage dynamique et l'inspection des applications a Ă©tĂ© placĂ© dans le rĂ©pertoire /usr/share/btrace.
  • La bibliothĂšque sonore sndio a ajoutĂ© la fonction sio_flush pour arrĂȘter immĂ©diatement la lecture.
  • L'utilitaire llvm-profdata pour travailler avec des donnĂ©es de profilage a Ă©tĂ© inclus.
  • L'utilitaire wc a accĂ©lĂ©rĂ© le comptage des mots.
  • Le support de nouveau matĂ©riel a Ă©tĂ© ajoutĂ©, y compris de nouveaux pilotes :
    • aplaudio (sous-systĂšme audio Apple).
    • aplmca (contrĂŽleur MCA Apple).
    • aplsart (Apple SART).
    • alpdc, apldchidev, apldckbd, apldcms, aplrtk (clavier et trackpad Apple M2).
    • qcgpio, qciic (contrĂŽleurs GPIO et GENI I2C pour Qualcomm Snapdragon).
    • sfgpio, stfclock, stfpinctrl, stftemp (pilotes pour GPIO, minuteur et capteurs des cartes SiFive).
    • sxirintc (contrĂŽleur d'interruptions pour les puces Allwinner).
    • gpiorestart (pilote pour le rĂ©tablissement via GPIO).
    • Le support des capteurs d'alimentation a Ă©tĂ© Ă©largi dans ipmi.
    • Dans ehci, le support du contrĂŽleur utilisĂ© sur les cartes Marvell 3720 a Ă©tĂ© ajoutĂ©.
  • Dans le pilote igc pour les adaptateurs Ethernet gigabit Intel I225, l'accĂ©lĂ©ration matĂ©rielle du calcul des sommes de contrĂŽle pour IPv4, TCP et UDP a Ă©tĂ© incluse. Dans le pilote ix pour les adaptateurs Ethernet Intel 82598/82599/X540/X550, la prise en charge de l'accĂ©lĂ©ration matĂ©rielle du traitement des segments TCP (Large Receive Offloading) a Ă©tĂ© mise en Ɠuvre, activable avec l'option tso dans ifconfig.
  • Le pilote iwx a ajoutĂ© la prise en charge des puces Intel AX210/AX211 et a Ă©largi la gamme des dispositifs sans fil dĂ©tectĂ©s.
  • La possibilitĂ© de dĂ©marrer depuis des partitions RAID 1 logiciels (softraid) sur les systĂšmes amd64, sparc64 et arm64 a Ă©tĂ© ajoutĂ©e.
  • Dans snmpd et xlock, la sĂ©paration des privilĂšges a Ă©tĂ© mise en Ɠuvre.
  • Dans les fonctions bind et connect pour les sockets UNIX, l'isolation basĂ©e sur l'appel systĂšme unveil a Ă©tĂ© assurĂ©e.
  • Un nouvel appel systĂšme ypconnect a Ă©tĂ© ajoutĂ© pour crĂ©er un socket pour se connecter Ă  serveur YP, en utilisant l'adresse IP du fichier bloquĂ© ypbinding. Dans ypldap, un mode ‘local bind’ a Ă©tĂ© ajoutĂ©, oĂč le socket RPC est liĂ© Ă  l'interface loopback pour exclure les connexions externes au serveur.
  • Les programmes hcpleased, mountd, nfsd, pflogd, resolvd, slaacd et unwind rĂ©pertoriĂ©s dans le rĂ©pertoire /sbin ont Ă©tĂ© modifiĂ©s pour utiliser le liaison dynamique afin d'activer des mesures de sĂ©curitĂ© supplĂ©mentaires applicables aux fichiers exĂ©cutables liĂ©s dynamiquement.
  • Dans la pile rĂ©seau, les appels systĂšme sendmmsg et recvmmsg ont Ă©tĂ© implĂ©mentĂ©s, permettant d'organiser l'envoi et la lecture de plusieurs messages dans le cadre d'un seul appel systĂšme, qui auraient autrement nĂ©cessitĂ© des appels sĂ©parĂ©s sendmsg et recvmsg.
  • Dans le filtre de paquets pf, le traitement des paquets IGMP et ICMP6 MLD (Multicast Listener Discovery) a Ă©tĂ© modifiĂ©, permettant de gĂ©rer les paquets multicast de contrĂŽle dans la configuration par dĂ©faut. Une vĂ©rification plus stricte des messages IGMP / MLD a Ă©tĂ© mise en Ɠuvre.
  • Dans IPsec, la gestion des certificats a Ă©tĂ© amĂ©liorĂ©e. Dans iked, la compatibilitĂ© avec OpenIKED a Ă©tĂ© amĂ©liorĂ©e. La commande ikectl show stats a Ă©tĂ© Ă©tendue pour inclure des statistiques sur les connexions rĂ©ussies et Ă©chouĂ©es vers iked.
  • Dans bgpd, un filtre max-communities a Ă©tĂ© ajoutĂ© pour limiter le nombre de communautĂ©s permises, RFC 9234 (PrĂ©vention et dĂ©tection des fuites de route Ă  l'aide des rĂŽles dans les messages UPDATE et OPEN) a Ă©tĂ© mis en Ɠuvre, et un support complet de RFC 7911 (Annonce de plusieurs chemins dans BGP) a Ă©tĂ© assurĂ©. Des hachages statiques ont Ă©tĂ© remplacĂ©s par des arbres RB pour amĂ©liorer les performances des grands systĂšmes. Un processus bgplgd a Ă©tĂ© ajoutĂ© avec la mise en Ɠuvre d'un serveur FastCGI, fournissant une API REST pour les commandes bgpctl.
  • Dans rpki-client, l'utilisation de plusieurs URI CRL dans les certificats est dĂ©sormais autorisĂ©e, un paramĂštre skiplist a Ă©tĂ© implĂ©mentĂ© pour ignorer les domaines, et la vĂ©rification d'ASPA (Autorisation de fournisseur de systĂšme autonome) et de fichiers sig a Ă©tĂ© ajoutĂ©e. Le dĂ©codage TAL (RFC 8630) a Ă©tĂ© mis en Ɠuvre, le contrĂŽle des certificats EE a Ă©tĂ© renforcĂ©, et la compatibilitĂ© avec les spĂ©cifications HTTP a Ă©tĂ© amĂ©liorĂ©e.
  • Dans snmpd, l'utilisation de noms d'objets dans snmpd.conf est dĂ©sormais autorisĂ©e, en plus des OID. Il est dĂ©sormais possible de dĂ©finir une liste noire pour exclure les sous-arbres de la sortie. Le protocole AgentX a Ă©tĂ© amĂ©liorĂ© avec le support de l'agent master.
  • De nouvelles dĂ©finitions de types MIME ont Ă©tĂ© proposĂ©es dans httpd.
  • L'utilitaire ftp a Ă©tĂ© modifiĂ© pour utiliser des connexions gĂ©rĂ©es en mode non-bloquant via ppoll.
  • Dans tmux (multiplexeur de terminal), la possibilitĂ© d'utiliser des ACL pour permettre la connexion de plusieurs utilisateurs via un seul socket a Ă©tĂ© ajoutĂ©e.
  • Les paquets LibreSSL et OpenSSH ont Ă©tĂ© mis Ă  jour. Un aperçu dĂ©taillĂ© des amĂ©liorations est disponible dans les revues de LibreSSL 3.6.0 et OpenSSH 9.1.
  • Le nombre de ports pour l'architecture AMD64 a atteint 11451 (contre 11301 auparavant), pour aarch64 — 11261 (contre 11081), pour i386 — 10225 (contre 10136). Parmi les versions des applications dans les ports :
    • Asterisk 16.28.0, 18.14.0 et 19.6.0
    • Audacity 2.4.2
    • CMake 3.24.2
    • Chromium 105.0.5195.125
    • Emacs 28.2
    • FFmpeg 4.4.2
    • GCC 8.4.0 et 11.2.0
    • GHC 9.2.4
    • GNOME 42.4
    • Go 1.19.1
    • JDK 8u342, 11.0.16 et 17.0.4
    • KDE Gear 22.08.1
    • KDE Frameworks 5.98.0
    • Krita 5.1.1
    • LLVM/Clang 13.0.0
    • LibreOffice 7.4.1.2
    • Lua 5.1.5, 5.2.4 et 5.3.6
    • MariaDB 10.9.3
    • Mono 6.12.0.182
    • Mozilla Firefox 105.0.1 et ESR 102.3.0
    • Mozilla Thunderbird 102.3.0
    • Mutt 2.2.7 et NeoMutt 20220429
    • Node.js 16.17.1
    • OCaml 4.12.1
    • OpenLDAP 2.6.3
    • PHP 7.4.30, 8.0.23 et 8.1.10
    • Postfix 3.7.2
    • PostgreSQL 14.5
    • Python 2.7.18, 3.9.14 et 3.10.7
    • Qt 5.15.6 et 6.3.1
    • R 4.2.1
    • Ruby 2.7.6, 3.0.4 et 3.1.2
    • Rust 1.63.0
    • SQLite 3.39.3
    • Shotcut 22.06.23
    • Sudo 1.9.11.2
    • Suricata 6.0.6
    • Tcl/Tk 8.5.19 et 8.6.12
    • TeX Live 2021
    • Vim 9.0.0192 et Neovim 0.7.2
    • Xfce 4.16
  • Les composants des dĂ©veloppeurs tiers inclus dans OpenBSD 7.2 ont Ă©tĂ© mis Ă  jour :
    • La pile graphique Xenocara basĂ©e sur X.Org 7.7 avec xserver 1.21.4 + correctifs, freetype 2.12.1, fontconfig 2.13.94, Mesa 22.1.7, xterm 372, xkeyboard-config 2.20, fonttosfnt 1.2.2.
    • LLVM/Clang 13.0.0 (+ correctifs)
    • GCC 4.2.1 (+ patchs) et 3.3.6 (+ patchs)
    • Perl 5.32.1 (+ patchs)
    • NSD 4.6.0
    • Unbound 1.16.3
    • Ncurses 5.7
    • Binutils 2.17 (+ correctifs)
    • Gdb 6.3 (+ patch)
    • Awk 12.9.2022
    • Expat 2.4.9

Source : opennet.ru

Acheter un hĂ©bergement fiable pour les sites avec protection DDoS, serveurs VPS VDS đŸ”„ Acheter un hĂ©bergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster