La version principale de nginx 1.25.1 a été publiée, poursuivant le développement de nouvelles fonctionnalités. Dans la branche stable prise en charge 1.24.x, seuls les changements liés à la correction des erreurs critiques et des vulnérabilités sont apportés. À l'avenir, une branche stable 1.26 sera formée sur la base de la branche principale 1.25.x.
Parmi les changements :
- Une directive distincte «http2» a été ajoutée pour activer sélectivement le protocole HTTP/2 en liaison avec les serveurs (peut être utilisée dans des blocs «server» séparés). Le paramètre «http2» dans la directive «listen» est déclaré obsolète.
- La prise en charge de la technologie Server push dans HTTP/2 a été supprimée.
- La prise en charge de la directive «ssl», auparavant déclarée obsolète, a été interrompue.
- Des problèmes ont été résolus lors de l'utilisation de HTTP/3 avec une compilation utilisant la bibliothèque OpenSSL.
Source : opennet.ru
