Sortie d'OpenSSL 3.2.0 avec support client du protocole QUIC

Après huit mois de développement, la version de la bibliothèque OpenSSL 3.2.0 a été finalisée avec l'implémentation des protocoles SSL/TLS et de divers algorithmes de cryptage. Le support d'OpenSSL 3.2 sera assuré jusqu'au 23 novembre 2025. Le support des anciennes branches OpenSSL 3.1 et 3.0 LTS se prolongera jusqu'en mars 2025 et septembre 2026 respectivement. Le support de la branche 1.1.1 a cessé en septembre de cette année. Le code du projet est distribué sous la licence Apache 2.0.

Principales nouveautés d'OpenSSL 3.2.0 :

  • Ajout du support client pour le protocole QUIC (RFC 9000), utilisé comme transport dans le protocole HTTP/3. La mise en œuvre inclut notamment la possibilité de transmettre plusieurs flux sur un seul canal de communication. Les composants pour l'utilisation de QUIC sur serveurs seront inclus dans la version OpenSSL 3.3, qui est prévue pour être publiée au plus tard le 30 avril 2024.

    QUIC est une superstructure sur le protocole UDP, supportant le multiplexage de plusieurs connexions et offrant des méthodes de chiffrement équivalentes à TLS/SSL. Le protocole a été créé en 2013 par Google comme une alternative à la combinaison TCP+TLS pour le Web, afin de résoudre les problèmes de latence dans l'établissement et la négociation des connexions TCP et d'éliminer les retards causés par la perte de paquets lors de la transmission des données.

  • Le TLS a mis en œuvre le support de l'extension pour la compression des certificats lors de l'étape de négociation des connexions (RFC 8879), permettant d'accélérer l'établissement de la connexion, car la transmission des données des certificats représente une part importante du trafic à cette étape. La compression est supportée en utilisant les bibliothèques zlib, zstd et Brotli.
  • Ajout du support d'une variante déterministe des signatures numériques ECDSA (Deterministic ECDSA, RFC 6979) où, au lieu d'une séquence aléatoire lors de la génération de la signature, un hachage HMAC-SHA256 de la clé privée et du texte du message signé est utilisé, ce qui permet d'obtenir toujours la même signature dans différentes opérations de signature, mais empêche les fuites d'informations pouvant être utilisées pour déduire la clé privée (la clé privée peut être déduite si au moins deux signatures pour des données différentes sont générées à l'aide d'une séquence aléatoire répétée).
  • Ajout du support de variantes étendues des signatures numériques à clé publique Ed25519 et Ed448 : Ed25519ctx, Ed25519ph et Ed448ph (RFC 8032).
  • Prise en charge du mode de cryptage AES-GCM-SIV (RFC 8452), qui combine les performances élevées du mode GCM (Galois/Counter Mode) avec la résistance aux fuites lors de la réutilisation du code nonce.
  • Implémentation de la fonction de génération de clé Argon2 (RFC 9106), qui a remporté le concours de fonctions de hachage de mots de passe en 2015. Ajout de la possibilité d'utiliser un pool de threads.
  • Ajout de la prise en charge du cryptage hybride basé sur le mécanisme HPKE (Hybrid Public Key Encryption, RFC 9180), combinant la simplicité de la transmission de clé dans le cryptage à clé publique avec la haute performance du cryptage symétrique (les données sont chiffrées avec une clé symétrique rapide, tandis que cette clé est chiffrée avec une clé asymétrique lente).
  • Dans TLS, possibilité d'utiliser des clés publiques « brutes » (raw) (RFC 7250).
  • Ajout de la prise en charge d'un mécanisme d'établissement rapide des connexions TCP (TFO - TCP Fast Open, RFC 7413), qui permet de réduire le nombre d'étapes d'établissement de connexion en combinant en une seule requête la première et la deuxième étapes du processus classique en trois étapes pour l'établissement de connexions, et permet l'envoi de données au début de l'établissement de la connexion.
  • Dans TLS, prise en charge de schémas de signature numérique connectables, permettant d'utiliser des implémentations tierces d'algorithmes, par exemple, pour utiliser dans TLS des algorithmes résistants à la recherche sur des ordinateurs quantiques.
  • Dans TLS 1.3, ajout de la prise en charge des courbes elliptiques protégées Brainpool.
  • Ajout du support des instructions de processeur SM4-XTS.
  • Sur la plateforme Windows, possibilité d'utiliser le stockage système des certificats racines (par défaut désactivé). Pour accéder aux certificats dans le stockage Windows, un URI « org.openssl.winstore:// » est proposé.

Source : opennet.ru

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster