Publication de nginx 1.29.2 et du fork FreeNginx 1.29.2.

La version principale de nginx 1.29.2 a été publiée, poursuivant le développement de nouvelles fonctionnalités. Seules les modifications liées à la correction de bogues graves et de vulnérabilités sont apportées à la branche stable 1.28.x, qui est maintenue en parallèle. Dans le futur, une branche stable 1.30 sera formée sur la base de la branche principale 1.29.x. Le code du projet est écrit en C et est distribué sous licence BSD.

Dans cette nouvelle version :

  • Ajout de la possibilité de compiler avec la bibliothèque cryptographique AWS-LC, développée par Amazon.
  • Un problème a été résolu lors de l'utilisation de la directive «ssl_protocols» avec un serveur virtuel, différent du serveur par défaut. Le problème se manifestait lors de l'utilisation d'OpenSSL 1.1.1 et des versions ultérieures.
  • Un échec de négociation de connexion TLSv1.3 a été corrigé dans les configurations avec OpenSSL et des certificats clients. L'échec se produisait lors de la reprise d'une session avec une autre valeur SNI.
  • Un bug qui entraînait l'affichage dans les journaux du message «ignoring stale global SSL error» lors de l'utilisation du protocole QUIC et de la directive «ssl_reject_handshake» a été corrigé.
  • Un problème a été résolu lors du traitement des valeurs temporelles dans l'en-tête HTTP «Cache-Control» retourné par le backend.
  • L'utilisation de l'encodage xtext dans l'équipe XCLIENT a été mise en place.
  • Un problème de mise en cache a été résolu des certificats TLS lors de la reconfiguration.

Il convient également de noter la publication de la version 1.29.2 du projet FreeNginx, qui développe un fork de Nginx. Le développement du fork est dirigé par Maxim Dunin, l'un des principaux développeurs de Nginx. FreeNginx se positionne comme un projet non commercial garantissant le développement de la base de code Nginx sans intervention corporate. Le code de FreeNginx continue d'être distribué sous licence BSD. Parmi les changements dans FreeNginx 1.29.2, on note l'ajout de la prise en charge de l'extension TLS ECH (Encrypted Client Hello).

Source : opennet.ru

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster