Implémentation des algorithmes cryptographiques GOST en Java

La bibliothèque crypto-gost a été publiée avec une implémentation des algorithmes cryptographiques GOST en Java, sans dépendances supplémentaires. Contrairement à l'implémentation des algorithmes GOST de la bibliothèque Bouncy Castle, crypto-gost améliore les performances du chiffrement avec l'algorithme « Bouchon », résout des problèmes de sécurité spécifiques et fournit des wrappers simples ne nécessitant pas de connaissances approfondies en cryptographie. Le code est distribué sous une licence permissive qui permet la distribution, la modification et la création d'œuvres dérivées sans restrictions.

Algorithmes pris en charge :

  • GOST R 34.11-2012 (RFC 6986) — fonction de hachage « Stribog » 256 et 512 bits.
  • GOST R 34.12-2015 — chiffrement par blocs « Bouchon », clé de 256 bits.
  • GOST R 34.13-2015 — modes de chiffrement CBC, CFB, CTR (GAMMA), OFB ; insertion d'authenticité (CMAC).
  • GOST R 34.10-2012 (RFC 7091) — signature électronique 256 et 512 bits.
  • HMAC-Stribog (RFC 7836, HMAC-Streebog-256 et HMAC-Streebog-512).
  • MGM (Multilinear Galois Mode) — mode AEAD pour Bouchon (RFC 9058). Compatible avec OpenSSL.
  • SCrypt (RFC 7914) — fonction de dérivation de clé basée sur un mot de passe.

Source : opennet.ru

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster