Apache 2.4.63

La version du serveur HTTP Apache 2.4.63 est sortie.

Modifications les plus importantes :

  • mod_ssl : Des améliorations ont été intégrées dans le traitement des erreurs lors de l'initialisation d'OpenSSL. Désormais, le serveur termine correctement son démarrage si l'initialisation d'OpenSSL échoue. Cela est important pour garantir la fiabilité du démarrage du serveur.
  • mod_md (mises à jour) : Des modifications ont été apportées concernant la gestion des certificats ACME :
    1. Les délais d'attente pour la vérification des domaines ACME sont augmentés de 30 secondes à 5 minutes. serveur Un problème lié à l'obtention de certificats lors de la mise à jour ACME a été corrigé, de sorte qu'il n'est plus nécessaire d'avoir l'en-tête 'Location:', améliorant ainsi la compatibilité avec d'autres CA en dehors de Let's Encrypt.
    2. Des améliorations ont été mises en place pour gérer plus efficacement les certificats lors des erreurs et pour les activer en cas d'échec.
    3. mod_proxy :
  • Les paramètres pour ProxyPassMatch sont désormais pris en charge, y compris les substitutions dans le nom d'hôte et le port. Cela est important pour une configuration de proxy plus flexible. mod_authnz_ldap :serveurs.
  • Une option ldap-search a été ajoutée, permettant l'autorisation basée sur des expressions LDAP personnalisées sans avoir besoin d'un nom d'utilisateur. Cela étend les possibilités de configuration de l'autorisation. mod_rewrite :
  • Des améliorations ont été apportées aux règles de traitement des points d'interrogation et une protection contre l'erreur UnsafeAllow3F a été ajoutée. Il s'agit d'un changement important pour le fonctionnement correct des URL réécrites, en particulier dans des configurations complexes. mod_proxy_balancer :
  • Le traitement du paramètre stickysession dans la configuration du répartiteur de charge a été corrigé. Cela est important pour le bon fonctionnement des sessions lorsqu'une répartition de charge est utilisée. mod_lua :
  • Le champ r.ap_auth_type est désormais accessible en écriture. Cela ouvre de nouvelles possibilités pour la configuration et le travail avec l'authentification dans Apache via Lua. mod_tls :
  • Le module expérimental a été supprimé et est maintenant disponible séparément. Cela peut affecter ceux qui l'utilisaient pour travailler avec TLS via Rust. La version du serveur HTTP Apache 2.4.63 est sortie. Changements les plus importants : mod_ssl : Des améliorations ont été apportées au traitement des erreurs lors de l'initialisation d'OpenSSL.

Source : linux.org.ru

Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS 🔥 Acheter un hébergement fiable pour les sites avec protection DDoS, serveurs VPS VDS | ProHoster