Des versions correctives du paquet Samba 4.10.8 et 4.9.13 ont été publiées, dans lesquelles est résolu (), permettant à un utilisateur d'accéder au répertoire racine où est situé le partage réseau Samba. Le problème se manifeste en spécifiant dans les paramètres l'option ‘wide links = yes’ en combinaison avec ‘unix extensions = no’ ou ‘allow insecure wide links = yes’. L'accès aux fichiers en dehors du répertoire partagé actuel est limité par les droits d'accès de l'utilisateur, c'est-à-dire qu'un attaquant peut lire et écrire des fichiers selon son uid/gid.
Le problème est causé par le fait qu'après la première requête du répertoire racine du partage, le client reçoit une erreur d'accès, mais smbd met en cache l'accès au répertoire et ne purge pas le cache en cas de problème d'accès. En conséquence, après l'envoi d'une nouvelle requête SMB, celle-ci est traitée avec succès sur la base de l'enregistrement dans le cache sans nouvelles vérifications des droits.
Source : opennet.ru
